Results 1 to 8 of 8

Thread: How to verify I'm on 1.0.4? No updates available today (using update && upgrade)

  1. #1
    Join Date
    2013-Mar
    Posts
    29

    How to verify I'm on 1.0.4? No updates available today (using update && upgrade)

    Yesterday, I ran apt-get update && apt-get dist-upgrade and some updates ran. However, seeing that the news about 1.0.4 were released today, I tried running the same update commands and now I don't have any updates available.

    I have a feeling I'm not on the latest version, but I'm not sure how to verify. Can someone help clarify?

  2. #2
    Join Date
    2013-Mar
    Posts
    269
    Hi there are several commands that you may use to find details about your install:

    "lsb_release -a" should do the trick, also, "uname -a" will work as well. I believe there are a few other ways.

    Here is an article that further clarifies, http://www.cyberciti.biz/faq/find-li...ersion-number/
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  3. #3
    Join Date
    2013-Mar
    Posts
    29
    Quote Originally Posted by charonsecurity View Post
    Hi there are several commands that you may use to find details about your install:

    "lsb_release -a" should do the trick, also, "uname -a" will work as well. I believe there are a few other ways.

    Here is an article that further clarifies, http://www.cyberciti.biz/faq/find-li...ersion-number/
    Thanks for your reply. I downloaded the new version a few hours ago and issued those two commands. I don't think this was changed with the new update though.

  4. #4
    Join Date
    2013-Jul
    Posts
    4
    Thanks for the info.
    I installed 1.0.0 lately and did the same update as altjx. lsb_release says that im still on 1.0.0. There were no errors during installation, but some packages are missing (stated in the 1.0.4 release info) e.g. Ghost Phisher, Unicornscan.
    Any idea?

  5. #5
    Join Date
    2013-Mar
    Posts
    15
    True Sziller. They are even "missing" after a clean 1.0.4 installation.
    From the blog entry I also understood that these tools would be a part of the image already.
    But, they are not.

    Nevertheless, they are in the repos for sure. Just use "apt-get update && apt-get install ghost-phisher" (or unicornscan, or etc.).

    Best,

  6. #6
    Join Date
    2013-Jul
    Posts
    4
    So I'm not the only one who misunderstood this.
    But Tirn, do you have any idea, that why lsb_release still states that I have 1.0.0? (packages all upgraded, nothing is missing)

  7. #7
    Covered in another thread (from a kali developer):
    Quote Originally Posted by dookie View Post
    The lsb_release information will only be updated for major versions, not minor ones.
    Not all of the new tools were added to the default iso as it helps us keep the iso smaller while still having all the core tools. You will need to apt-get the ones you want manually.
    Source: Kali did not upgrade to the latest release
    Last edited by g0tmi1k; 2013-08-13 at 12:55.

  8. #8
    Join Date
    2013-Jul
    Posts
    4
    Thank You.

Similar Threads

  1. Metasploit missing payload after update today :(
    By tipoe in forum NetHunter General Questions
    Replies: 4
    Last Post: 2015-05-16, 03:15
  2. I install updates today and i lost the boot entry for Windows
    By pamamolf in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-03-05, 07:12
  3. Problem with python-configargparse today (apt-get dist-upgrade)
    By kaliusr56 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2015-01-02, 13:07
  4. Hard Track new updates 2013 (Today)
    By lawrencethepentester in forum General Archive
    Replies: 1
    Last Post: 2013-08-20, 17:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •