Results 1 to 7 of 7

Thread: Kali did not upgrade to the latest release

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Kali did not upgrade to the latest release

    i run this command apt-get update && apt-get dist-upgrade no errors found and installed all updates but i did not seem to find the pentesting tools that was added with the latest release.
    and to verify if im on version 1.0.4 i run this command lsb_release -a and the result was




    No LSB modules are available.
    Distributor ID: Debian
    Description: Debian GNU/Linux Kali Linux 1.0
    Release: Kali Linux 1.0
    Codename: n/a


    any help from here?

  2. #2
    Join Date
    2013-Feb
    Posts
    13
    The lsb_release information will only be updated for major versions, not minor ones.
    Not all of the new tools were added to the default iso as it helps us keep the iso smaller while still having all the core tools. You will need to apt-get the ones you want manually.

  3. #3
    Quote Originally Posted by dookie View Post
    The lsb_release information will only be updated for major versions, not minor ones.
    Not all of the new tools were added to the default iso as it helps us keep the iso smaller while still having all the core tools. You will need to apt-get the ones you want manually.
    From the release of 1.0.6, release numbers will show up.
    1.0.5 and under, will still show up as 1.0

    Code:
    root@kali~$ lsb_release -a
    No LSB modules are available.
    Distributor ID:	Debian
    Description:	Debian GNU/Linux Kali Linux 1.0.6
    Release:	Kali Linux 1.0.6
    Codename:	n/a
    root@kali~$ cat /etc/issue
    Kali GNU/Linux 1.0.6 \n \l
    
    root@kali~$
    Last edited by g0tmi1k; 2014-01-11 at 16:10.

  4. #4
    From the kali blog post: Pass the Hash toolkit, Winexe and more
    Code:
    apt-get update
    apt-get dist-upgrade
    apt-get install passing-the-hash unicornscan winexe
    apt-get install unicornscan enum4linux polenum 
    apt-get install nfspy firmware-mod-kit wmis
    # and if you haven't already:
    apt-get install nipper-ng jsql oclgausscrack ghost-phisher uniscan 
    apt-get install lbd automater arachni bully inguma sslsplit dumpzilla 
    apt-get install owasp-mantra-ff recon-ng ridenum regripper jd-gui

  5. #5
    Join Date
    2013-Mar
    Location
    localhost
    Posts
    41
    first : apt-get update
    apt-get upgrade
    apt-get dist-upgrade
    then : reboot
    and here u are

  6. #6
    Join Date
    2015-Apr
    Posts
    1

    Question

    Is it possible to use

    • apt-get update
    • apt-get upgrade
    • apt-get dist-upgrade
    • reboot

    to "upgrade" from 1.1.0 to 1.1.0a?

    I'm current on updates and all I see when I try upgrade or dist-upgrade is:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  7. #7
    Quote Originally Posted by regexaurus View Post
    Is it possible to use

    • apt-get update
    • apt-get upgrade
    • apt-get dist-upgrade
    • reboot

    to "upgrade" from 1.1.0 to 1.1.0a?

    I'm current on updates and all I see when I try upgrade or dist-upgrade is:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Then you're up-to-date.
    lsb_release will not show '1.1.0a' as it was a release due to the first release having a bad kernel.
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: https://tools.kali.org/

Similar Threads

  1. Upgrade distro from Kali 1.1.0 (moto) to the latest one.
    By leramos00 in forum General Archive
    Replies: 1
    Last Post: 2017-03-21, 11:45
  2. Replies: 2
    Last Post: 2016-12-05, 13:14
  3. issue upgrading 1.0.9 32 bit to latest release 1.1.0
    By alejandroguerrat in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2015-04-15, 13:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •