Results 1 to 7 of 7

Thread: Wireless problem disconnecting

  1. #1
    Join Date
    2013-Sep
    Posts
    3

    Wireless problem disconnecting

    Hello
    i've installed Kali linux yesterday, i didn't have an active connection during installation so i could not download the required drivers (as far as i remmeber it was b43-fwcutter or something

    the wireless connection is working, but after few minutes it stops (doesn't show as disconnection or anything but no page will open, youtube stops etc...) until i reset connection

    i've installed b43 module and firmware-b43-lpphy-installer

    still same problem, not sure if module isn't loaded or i have to black list something?

    lspci shows:

    Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

    lspci -k shows:
    Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
    Subsystem: Dell Wireless 1397 WLAN Mini-Card
    Kernel driver in use: b43-pci-bridge

    any help is highly appreciated,
    thanks

  2. #2
    Join Date
    2013-Mar
    Posts
    269
    Well from the sounds of it (and please correct me if I am wrong) you do get an internet connection, but after a few minutes it drops connection? So I assume, while you are connected, you can successfully connect to web sites and such right? Also you tried to install via "apt-get install firmware-b43-lpphy-installer", while you were connected via wired connection?

    (Note: I don't have this particular card) Looking at possible solutions, how far away from the wifi point are you, have you tried using a different channel, make sure you have strong signal?
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  3. #3
    Join Date
    2013-Sep
    Posts
    3
    Hello Charonsecurity thanks for your reply,
    yes that is correct, i get 75% to 100% signal from my point with this wireless chip,
    i have a USB wifi i'm using right now as a replacement until the problem is fixed, i'm only getting 50% signal but it's working very well, so the problem must be from card
    yes i installed firmware-b43-ipphy-installer, but not during wired connection,
    i'm thinking that the b43-ipphy is not loaded

  4. #4
    Join Date
    2013-Mar
    Posts
    269
    Hmm that is defiantly an interesting issue. I don't know where the problem lies exactly, but I would like to try to suggest to reinstall the driver using the previous command while on a good connection (assuming maybe the download and install never went trough.) Could also be that particular driver may be buggy.. I am happy to hear that you do have a temporary solution working for you.
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  5. #5
    Join Date
    2013-Sep
    Posts
    3
    Thanks for the support very helpful,
    not sure what what was wrong but it's working very well now, i guess reinstalling the drivers fixed something
    thanks again, much appreciated

  6. #6
    Join Date
    2013-Oct
    Posts
    1
    Hello everyone, i have the same problem as discussed in this topic, i have the latest version of Kali on my live usb stick. Wi-fi disconnects after a few minutes every time. I managed to capture a log at the moment of crash. Can anyone help with this?
    Attached Files Attached Files

  7. #7
    Join Date
    2013-Mar
    Posts
    354
    Do you have the same chipset and the same wifi model?...

    If not, please open up another thread. If the same wifi device or chipset, the man reinstalled the drivers and that did it for him.

    Luck.

Similar Threads

  1. VPnnc disconnecting
    By Ahmed_F in forum General Archive
    Replies: 0
    Last Post: 2015-09-30, 05:19
  2. Bluetooth disconnecting
    By nekromantik in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2014-09-15, 21:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •