Results 1 to 2 of 2

Thread: Running Software Update as a privileged user

  1. #1
    Join Date
    2013-Apr
    Posts
    9

    Running Software Update as a privileged user

    Hi,

    Is there a difference between using the Terminal commands apt-get update && apt-get upgrade (or apt-get dist-upgrade) as the root user and running Software Update from the System Tools menu ?

    When I try to run Software Update from the System Tools menu a notification message window shows up saying

    "Software Update Viewer is running as a privileged user
    Package management applications are security sensitive.
    Running graphical applications as a privileged user should be avoided for security reasons."

    As I understood from some Google search results then if such a messages shows up then it should not be ignored, so I press Cancel on the notification message window.

    So is using the Terminal commands apt-get update && apt-get upgrade (or apt-get dist-upgrade) as the root user the same as running Software Update from the System Tools menu (if I would press Continue Anyway instead of Cancel on the notification message window) ?

    Thank you.


    kvadrat

  2. #2
    Join Date
    2013-Aug
    Posts
    6
    when you run graphic updates, additional services is required, so there are more security problems from that services. Then terminal with official repos are more secure

Similar Threads

  1. complete failure installing/running cups/software center
    By mr2face in forum General Archive
    Replies: 0
    Last Post: 2016-07-11, 08:47
  2. have problem in software update
    By eslamzadeh in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2014-06-13, 01:19
  3. Software Update Error
    By Escape in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-08-23, 09:59
  4. Software Update Issues
    By Bauta in forum General Archive
    Replies: 4
    Last Post: 2013-04-02, 09:19

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •