Results 1 to 16 of 16

Thread: Kali Repo and Tools in Mint 15 x64 (MATE) /w 3.10.10 kernel

  1. #1
    Join Date
    2013-Sep
    Posts
    7

    Kali Repo and Tools in Mint 15 x64 (MATE) /w 3.10.10 kernel

    Hey, I am running Mint 15 x64 (MATE GUI) with the kernel updated to 3.10.10.
    I do not wish to triple-boot and I do not wish to replace Mint with Kali or BT5.
    I would like the tools Kali provides, however.

    If I add the repos, it seems to cause problems with the Mint (MATE) Update Manager not wanting to get updates.
    apt-get update and upgrade seem to be installing and overwriting key parts of Mint. I can fix this by removing Kali repos and purging with apt-get update, upgrade, and autoremove.
    This puts the recommended Mint 15 packages back on and removes Kali ones so I can try again.

    Here's what I've tried today. I did some other stuff last week, but it got less far.

    This is added to /etc/apt/sources.list
    Code:
    deb http://http.kali.org/ /kali main contrib non-free
    deb http://http.kali.org/ /wheezy main contrib non-free
    deb http://http.kali.org/kali kali-dev main contrib non-free
    deb http://http.kali.org/kali kali-dev main/debian-installer
    deb-src http://http.kali.org/kali kali-dev main contrib non-free
    deb http://http.kali.org/kali kali main contrib non-free
    deb http://http.kali.org/kali kali main/debian-installer
    deb-src http://http.kali.org/kali kali main contrib non-free
    deb http://security.kali.org/kali-security kali/updates main contrib non-free
    deb-src http://security.kali.org/kali-security kali/updates main contrib non-free
    Save and then
    Code:
    sudo -s
    apt-get update
    apt-get install kali-linux -yq
    apt-get upgrade
    kali-linux -yq is from a YouTube guide I found, but it seems to be bugging out. I'm going to try kali-linux-full (Another YouTube guide) and hope it installs dependencies this time.

    But if a veteran could figure this out with me, that would be amazing.
    I'm kind of wondering if I have too many sources that it doesn't need. Old ones, maybe?
    Authentication key 7D8D0BF6 seems to work, however. No complaints about invalid file sources.

  2. #2
    What you're wanting todo isn't recommend at all.

    Using Kali, adding other repos isn't supported ~ http://docs.kali.org/general-use/kal...t-repositories
    Using another OS, and adding Kali's repos - will break stuff. Might not be straight away - but it will happen.

    It would be much safer to have have Kali in a VM or on a USB stick if you do not wish to do the dual booting option.
    Last edited by g0tmi1k; 2013-09-24 at 08:25.

  3. #3
    Join Date
    2013-Sep
    Posts
    7
    So I would effectively have to either figure out how to emulate Kali (To maintain the menu structure) or get every program separately from source or hope a deb package exists? There's no package, like maybe kali-linux-tools, that ONLY installs the tools and nothing else?

    Why is there no package for other systems by now? It isn't like Kali / Backtrack get paid ad revenue. ..Right?

  4. #4
    Join Date
    2013-Sep
    Location
    Cape May, NJ
    Posts
    10
    g0tmi1k,

    Well, your answer here solves a question that I had regarding adding repositories to a Kali install.

    I plan on running Kali Linux as my base OS. Then virtualize Whonix (https://www.whonix.org/wiki/Main_Page) like I did with my Linux Mint 15 set-up. The SSD on my H-P Ultrabook died, and when I get it back I'll install Kali.

    THX for the reply here!
    ________________

    Down On The Jersey Shore

  5. #5
    Join Date
    2013-Sep
    Posts
    7
    I think I have almost all of the tools installed.
    There's a few dependencies missing or a few that are the wrong version, but it's a lot of tedious work.
    Not hard or confusing, really.
    A lot of typing, a lot of loading, a lot of refreshing. More refreshing. Then more typing. Refresh and repeat.

  6. #6
    Join Date
    2013-Sep
    Location
    Cape May, NJ
    Posts
    10
    I think I have almost all of the tools installed.
    Ownpawn,

    Are you referring to Kali Tools? Seems pretty tedious, and risky as g0tmi1k has mentioned. IMHO.
    ________________

    Down On The Jersey Shore

  7. #7
    Join Date
    2013-Sep
    Posts
    7
    Quote Originally Posted by Adler View Post
    Seems pretty tedious
    I'm searching for a dependency that needs to be set to Raring or Raring updates that's sometimes four or five levels deep.
    Tedious is pretty close to the correct term.

    I still need like six packages that I realistically will never need or use.
    Two I probably don't want due to stability concerns.

    OpenVas (Missing "gsd" which should have been included in "greenbone-security-assistant")
    wpscan (Needs libcurl4-gnutls-dev, which needs libkrb5-dev and libldap2-dev, which need krb5-multidev and libldap-2.4-2 (Which WAS the wrong version and needed changing). krb5-multidev needs seven others, which all need to be sorted through, six of which look to be the wrong version, which by itself is easy to change, but if they have dependencies that are on the wrong version, I have to go through all of them and their dependencies and their dependencies... And the best part is most of these different versions are pretty much the same aside from if it's labeled for raring or not)
    ollydbg (Needs Wine. I'll double check Wine is installed correctly right after this. Checked it. Probably close to fifty dependencies needed. And that's the surface. Who knows how many dependencies those dependencies need?)
    kali-linux (Not sure if I want it. Seems like it would be too invasive)
    kali-linux-full (Not sure if want)

    So yea, it looks to be working, but it's certainly not quick or easy.
    Tedious for sure.

    Also, MATE does not recognize kali-menu, but it is installed correctly and working. I am trying to switch to gnome classic / gnome fallback, but it won't start.
    It's giving this error message.
    Code:
    Xsession: unable to launch "gnome-session --session=gnome-fallback-compiz" X
    session --- "gnome-session --session=gnome-fallback-compiz" not found; falling
    back to default session.
    I used apt-get -f install gnome-session-fallback
    There doesn't seem to be a package gnome-fallback-compiz
    This appears in a error window, and I do not think the line breaks are important, but they are there.
    After clicking okay, it loads Unity, or a partial install of Unity. It seems to work.

    Is there some common issue I can't seem to find anything on to get Gnome Fallback to work? I don't know if I have Gnome 3 installed or if I had installed it, if it still works.

  8. #8
    Join Date
    2013-Sep
    Posts
    7
    So I didn't want to post the guide I used until I was halfway sure it was halfway stable.
    But seeing as I have almost every tool installed and very few or no dependency conflicts, and the stability is that of any other modded heavy distro.
    https://top-hat-sec.com/forum/index.php?topic=2799.0

    I don't have OpenVas or wpscan. OpenVas is incorrectible it seems. Can't find gsd. Should be part of the Greenbone Security Suite, but it wasn't.
    Synaptics calls it a "dummy package," so I'm wondering if I have it installed under a different name. OpenVas-Client or something.
    Wpscan is useless to me. Don't care about WordPress much, and if I need it that badly, there's live USB's.
    I also opted out of installing kali-linux, kali-defaults, or kali-linux-full due to stability concerns, though these concerns aren't tested. It just required a shitload of dependencies I didn't want to go through and it didn't provide any clear description of what it actually changes.

    However, MATE still does not recognize Kali Tools as a menu item.
    I do not expressly mind MATE, though I prefer Gnome Classic, so if anyone knows how to correct this problem, perhaps it's popped up when someone tried installing MATE in Kali?

    However, Gnome Classic recognizes Kali-menu just fine, and I prefer it greatly.
    I fixed the error I was getting in the last post (Gnome was removed due to a dependency change) and it loaded perfectly for probably a day.
    By the next morning, it started to refuse to load any of the tool bar things or window frames.
    Screenshots linked below:
    https://dl.dropboxusercontent.com/u/...%3A47%3A13.png
    https://dl.dropboxusercontent.com/u/...%3A46%3A59.png
    https://dl.dropboxusercontent.com/u/...%3A46%3A29.png

    I have tried reinstalling many of the bigger Gnome packages, such as gnome, gnome-core, gnome-common, gnome-session, gnome-session-fallback.
    It hasn't fixed it.
    If there is a gnome log file I can access, I can easily pastebin the contents.
    It does this on all three gnome DE's: gnome, gnome fallback (No effects), and gnome fallback.

  9. #9
    Join Date
    2013-Sep
    Posts
    22
    jesus man you are in a world of pain, chances are 50%+ of those packages you have installed are either broken or worse half broken, for a start your running ubuntu kernel, you patched it for all the wifi exploits ? if so i wander why you are having problems with a simple thing like metacity not loading your decorator ( gtk ).
    Anyway listen to g0tmi1k in your case he is bang on.
    Kali can be mixed with jessie ( or sid if your suicidal ) but only then on a per-package baisis, Once your up to jessie versions on the packages you want you can mix in quite a lot of ubuntu binaries.
    Also why the f***k would you want to run ubuntu as a base, jeees you like upstart, plymouth, and all the other crud they have plastered into their core system ? Pretty much the only thing they have is compiz ( which can be easely stolen ) and current working nvidia drivers ( which is a **** !, debian is stuck on the old driver set which aint no good for cuda 5-5 ).
    Just try to take out gdm and replace it with startx ( xinit ) on your ubuntu box, and you start seeing the crud float up , in real code terms they are just one step above ferora and arch ( systemd suckers )
    Kali is a huge git overlay, they have moded packeges as obscure as maloc and initscripts, to the point that its not really wheezy anymore, something different and a much much cooler
    So maybe you might consider delving into the 2gig of cool kali stuff instead of smashing your brains into a brick wall
    Last edited by g0tmi1k; 2014-04-01 at 08:57. Reason: Swearing

  10. #10
    Join Date
    2013-Sep
    Posts
    7
    Fine.
    You guys win.
    Whatever.
    What's the best way to revert back to Mint stock? Remove the Kali tools, remove the repo, and apt-get -f upgrade, apt-get dist-upgrade, put the 3.10.10 kernel back on and apt-get -f upgrade and apt-get dist-upgrade again?

  11. #11
    As you're using MINT as the base OS, you would have to ask them, not us. This forum is for Kali-Linux support.

    However, I could guess at what there response would be - your best bet will be to back up, wipe everything and start fresh.
    I know thats a pain & sounds like a lot of work - but trying to figure out what you have done, altered & installed will take much longer.

  12. #12
    Join Date
    2013-Sep
    Posts
    22
    there is a little tool i developed to help kali-jessie integration which might help if slightly modified, it will show you all the pakages that have "kali" in the version number that is installed in your system, you can then use that list to purge kali packages, but start again is your best bet.
    the tool is here https://forums.kali.org/showthread.p...innamon1-9-git
    But if you read the post you should realise you can have EVERY worthwhile ubuntu app working on your kali box, ( you can have your cake and eat it ), but not the other way round, ie you cant get both if you start with a ubuntu base
    I am typing on a kali box carefully updated to jessie, with cinnnamon 1.9 compiled from git ( the ubuntu version ) , and compiz 0.910 from saucy as the base of my second DE, everything works perfect, its hard to check but i feel i have only broken 5-10% of the kali packages by the upgrades, there may even be a chance have not broken any
    Im using gpase, linaro, oracle and a whole bunch of other ubuntu PPA,s, everything just works ( the same post above contains scripts to add ubuntu PPA's to your kali box )

  13. #13
    Join Date
    2013-Jun
    Posts
    113

    Lightbulb

    Quote Originally Posted by Owndapwn View Post
    Fine.
    You guys win.
    I solved this problem other way around. Installed MATE Desktop in Kali Linux. See solution here. Might suit your need.

  14. #14
    Join Date
    2013-Sep
    Posts
    7
    Quote Originally Posted by blackMORE View Post
    I solved this problem other way around. Installed MATE Desktop in Kali Linux. See solution here. Might suit your need.
    I, admittedly, have not used Kali hardly at all.
    I have used Backtrack extensively for a while, and it was a horribly unstable OS, if it could be considered that.
    I wanted Kali tools on Mint in hopes of a more usable environment, not because I like MATE. I prefer Gnome Classic over all others.

  15. #15
    Noticing this is an old thread but wishing i had seen it sooner i dunno if it would help others but;

    When i did this originally i replaced mdm with gdm3 in Linux Mint 14 Nadia LMDE Debian/Cinnamon Edition BUT i used a 32GB SanDisk Micro USB to install it to as a test to see if it can be done - a very high speed one is necessary. Updating is ALWAYS breaking systems even in the first moments of installing just Mint alone in 14, 15 AND 16 now so i don't care about griping "Your not supposed to this and that" - if it wasn't meant to be hacked then why do we have ALL the cmd's and alike? These systems are flaky any way, all are sensitive in the respect to programing in various capacity's NO MATTER WHAT YOU DO! I used to have to re-install Mint alone like 30 frigging times before it would FINALLY properly update or install a separate manager from the software sources that prioritized the updates and install only the high priority ones with a number 1 beside them. When that was done and gdm3 was installed i would carefully ensure proper Kernel structure via the following:
    dpkg -l | grep linux-image-2; echo; uname -a
    Then i would proceed to update the GRUB file:
    sudo update-grub
    Then open:
    sudo gedit /var/lib/dpkg/status
    And remove Package: initramfs-tools which will not properly work in my own configuration but can in part stay until/if i decide to fix it. After all that i would run:
    sudo gedit /etc/pam.d/gdm3
    And then replace the text in the window with the following:
    #%PAM-1.0
    # This is kali-root-login's version of /etc/pam.d/gdm3
    auth requisite pam_nologin.so
    @include common-auth
    auth optional pam_gnome_keyring.so
    @include common-account
    # SELinux needs to be the first session rule. This ensures that any
    # lingering context has been cleared. Without out this it is possible
    # that a module could execute code in the wrong domain.
    session [success=ok ignore=ignore module_unknown=ignore default=bad] pam_selinux.so close
    session required pam_limits.so
    session required pam_env.so readenv=1
    session required pam_env.so readenv=1 envfile=/etc/default/locale
    session required pam_loginuid.so
    @include common-session
    # SELinux needs to intervene at login time to ensure that the process
    # starts in the proper default security context. Only sessions which are
    # intended to run in the user's context should be run after this.
    session [success=ok ignore=ignore module_unknown=ignore default=bad] pam_selinux.so open
    session optional pam_gnome_keyring.so auto_start
    @include common-password
    When that was done i would reboot. At that time, (about when this forum post seems to have started,) i would fix my source list via:
    gedit /etc/apt/sources.list
    To the following, (likely outdated,) list's:
    deb http://packages.linuxmint.com/ debian main upstream import
    deb http://mirror.rts-informatique.fr/li.../debian/latest testing main contrib non-free
    deb http://mirror.rts-informatique.fr/li...atest/security testing/updates main contrib non-free
    deb http://mirror.rts-informatique.fr/li...est/multimedia testing main non-free
    deb http://ftp.it.debian.org/debian wheezy main
    deb-src http://ftp.it.debian.org/debian wheezy main
    deb http://security.debian.org/ wheezy/updates main
    deb-src http://security.debian.org/ wheezy/updates main
    deb http://http.kali.org/kali kali main non-free contrib
    deb-src http://http.kali.org/kali kali main non-free contrib
    deb http://security.kali.org/kali-security kali/updates main contrib non-free
    deb-src http://security.kali.org/kali-security kali/updates main contrib non-free
    deb http://repo.kali.org/kali kali-bleeding-edge main
    Then i would simply apt-get update which took around a half hour or so.
    I would get an pgp key error and solve it with:
    gpg --keyserver pgpkeys.mit.edu --recv-key ED444FF07D8D0BF6
    gpg -a --export ED444FF07D8D0BF6 | sudo apt-key add -
    apt-get update
    I let it do the updates , then open synaptic and type in search bar : kali. You will see 8 maybe 9 results from Kali. If not > RELOAD SYNAPTIC.I chose the following on the list:
    *Kali-archive-keyring
    *Kali-debtags
    *Kali-defaults
    *Kali-linux
    *Kali-linux-full
    *Kali-menue
    *Kali-root-login
    Now when you see the results appear , check them all for installation and hit “ apply ”. Retain ALL default configuration entry's when asked. Again, open Root terminal and enter:
    update-grub && apt-get install lxpanel
    I noticed only two menus were available for Kali at this point but there were other parts throughout
    the rest of the menu and a lot still un-configured. Do be sure all Synaptec mgr's are completely closed and none of there associated additional processes are functioning before this point or your sys will bork out. I ignored the warning "Exiting will result in lost packages and items will not be installed and rebooted any way then ran that in terminal and got the following:
    update-grub && apt-get install lxpanel
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    kali-linux : Depends: snmp but it is not going to be installed
    lxpanel : Depends: libmenu-cache1 but it is not going to be installed
    Depends: lxmenu-data but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    sudo apt-get -f install - Fixed the Unmet Dependency's.
    Errors were encountered while processing:
    /var/cache/apt/archives/snmp_5.7.2~dfsg-8.1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    dragon puff #
    sudo dpkg-reconfigure man-db
    Fixed error code 1.
    At this point, since the above was ran the rest of the menu MOSTLY appeared.
    Run: sudo apt-get install -f
    If things get hairy try these:
    gksudo synaptic
    sudo apt-get -f install
    sudo dpkg -i --force-all [deb file path]
    sudo dpkg-reconfigure -phigh -a
    sudo dpkg-reconfigure gdm3
    sudo dpkg-reconfigure man-db
    sudo apt-get -f install
    sudo dpkg-reconfigure man-db
    sudo apt-get update
    sudo dpkg-reconfigure gdm3
    sudo apt-get install mdm
    Restart. Install the skin's, cursor's, mouse pointers, icon's and log in screen. Remember: the directory is in the "File System": usr/share/themes Restart. Installed BleachBit from the software manager and run to remove all unused files on the system. Reboot. I set the default session to Cinnamon. Load in Screenlets, Docky other software. Performed a "Shell hardening" via software manager. Reboot. Encrypted System. Reboot.

    No haters. Mine STILL WORKS great.
    One problem:
    I installed WAY too much software at once to test in addition to all this and now have murked it all up but using it now for this.
    I look forward to remaking this with the newest versions and figuring that out. Some of us enjoy doing this because we learn by doing not simply reading the dumb change logs and alike but many other books out there.

    Words of wisdom i can offer:
    IF you wanna do this, do it on a thumb drive that is high speed so you don't mess things up, it can all install to one.
    ALWAYS remove ALL devices such as but not limited to: USB's, hard drives, SD cards and alike BEFORE trying this, just to be safe.
    Become familiar with Parted Magic distro, and i have VERY GOOD reason to say that, it is because there you can clone disks with CloneZilla simply and effectively and it serves as a great backup for these projects but also when GParted decides to become stubborn with re-partitioning it'll work there. Lastly, like i originally said i used a 32GB Mini Sandisk USB now i use a 64GB with the clone fully expanded to it and as long as your only expanding the arias of partition spaces like / and /home it should work but if you decrease it then you loose the forewarned data.

    I truly hope this helps and cover's it, i know i still have many unanswered questions of my own and never stop learning but i have come to love my system and use it well for digital forensics, network security and much more. Don't go too far and try to add any other or non-Debian type systems to this. I doubt it will work but i won't say it is imposable. Best wishes and LuLz to ya' doubta'$ !!!

  16. #16
    A nice way to getting MATE on Kali (if you haven't seen it already): http://www.offensive-security.com/ka...linux-recipes/
    and the bash script behind it: https://github.com/offensive-securit...p10-nonroot.sh
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: https://tools.kali.org/

Similar Threads

  1. Kali Tools in Mint
    By ShenLun in forum Installing Archive
    Replies: 6
    Last Post: 2015-10-07, 08:53
  2. Can't boot my Linux Mint after installing Kali Tools
    By drag00n3333 in forum General Archive
    Replies: 1
    Last Post: 2014-07-08, 08:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •