Results 1 to 13 of 13

Thread: Unable to get the realtek 8191su in Monitor Mode

  1. #1
    Join Date
    2013-Oct
    Posts
    56

    Post Unable to get the realtek 8191su in Monitor Mode

    Moved this from the Wireless Trouble Shooting Sticky to allow for a wider audience.

    To the Mods - if this is wrong then please excuse my ignorance and take the appropriate action.

    Hi,

    I have just purchased a new unbranded USB to use on the vmware image I downloaded from the website, as the old belkin wasn't giving me the range I required.

    The chipset is a realtek 8191 although when plugged into Vm it displays 8191Su.

    I have the linux drivers for this item and have used the install.sh provided (for end users who are not familiar with Linux system) like me and seemed to install ok.

    iwconfig lists it as being present but it will not start with airmon-ng start wlan1.

    My Questions are as follows

    1. Is this chipset supported - I have read that it is under the 8192 drivers?
    2. If it is supported - Is there a driver that i can download with instructions pertinent to kali-linux ?
    3. If the above is "don't waste your time" - Is the Atheros AR5008 or the TL-WN722N (AR9002U) compatable?

    I have downloaded the backports-3.11.6-1 file but cannot get it to install so if there is a glimmer of hope
    that this may work could someone help me with the correct syntax to get this installed I am having a
    problem with the ./scripts/driver-select section.

    I have today tried the instructions from a livecd 32 bit edition at https://forums.kali.org/archive/index.php/t-127.html but this too failed

    Another quick update - after using the dmesg command I have discovered that the usb is using the r8712u: DriverVersion: v7_0.20100831 (don't know if this is relevant) and a msg at the bottom of the list stating ADDRCONF(NETDEV_UP): wlan0: link is not ready.

    Somebody please please please help me - this is daein ma heid in!
    Rab.

  2. #2
    Join Date
    2013-Oct
    Posts
    56

    Dmesg listing

    Code:
    [  186.281015] usb 1-2: new high-speed USB device number 3 using ehci_hcd
    [  186.588446] r8712u: module is from the staging directory, the quality is unknown, you have been warned.
    [  186.590573] r8712u: DriverVersion: v7_0.20100831
    [  186.590595] r8712u: register rtl8712_netdev_ops to netdev_ops
    [  186.590597] r8712u: USB_SPEED_HIGH with 4 endpoints
    [  186.593741] r8712u: Boot from EFUSE: Autoload OK
    [  192.180748] r8712u: CustomerID = 0x000a
    [  192.180758] r8712u: MAC Address from efuse = 00:11:22:33:44:55
    [  192.180764] r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
    [  192.182766] usbcore: registered new interface driver r8712u
    [  193.267606] r8712u: 1 RCR=0x153f00e
    [  193.273701] r8712u: 2 RCR=0x553f00e
    [  193.419055] ADDRCONF(NETDEV_UP): wlan0: link is not ready

  3. #3
    Join Date
    2013-Mar
    Posts
    354
    The realtek-firmware install the rtl8712u module (the driver is r8712u) which supports the USB devices based on the RTL8188SU, RTL8191SU and RTL8192SU.

    One question: where did you get this driver you posted and that you installed from?.

    It would be better if you post the model and brand of the USB device.

    Please be more specific as to model and brand, even version of device is aplicable, also what have you done so far to install it.

    Luck.
    Last edited by maverik35; 2013-11-02 at 16:28.

  4. #4
    Join Date
    2013-Oct
    Posts
    56
    All I can tell you is it is an unbranded usb purchased from fleabay and that on the module itselft it says ieee802.11-11N 300n wireless usb adapter.
    the driver came with the Usb-I realise that all the relevant drivers are included in the distribution but I thought (wrongly it appears) that this would
    make a difference.

    I have tried various things (too many to remember) that have been posted on the net and on both this site and the former backtrack forum.

    As this is on a VM I will reinstall it to remove any conflicts that may have occured during my quest to resolve this issue.

    Rab.

  5. #5
    Join Date
    2013-Oct
    Posts
    56

    Dmesg and Iwconfig results after clean vm image installed

    Code:
    [   95.605118] usb 1-1: new high-speed USB device number 2 using ehci_hcd
    [   95.750767] usb 1-1: New USB device found, idVendor=0bda, idProduct=8172
    [   95.750771] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [   95.750774] usb 1-1: Product: RTL8191S WLAN Adapter 
    [   95.750776] usb 1-1: Manufacturer: Manufacturer Realtek 
    [   95.750778] usb 1-1: SerialNumber: 00e04c000001
    [   95.955936] r8712u: module is from the staging directory, the quality is unknown, you have been warned.
    [   95.957104] r8712u: Staging version
    [   95.957121] r8712u: register rtl8712_netdev_ops to netdev_ops
    [   95.957124] r8712u: USB_SPEED_HIGH with 4 endpoints
    [   95.960006] r8712u: Boot from EFUSE: Autoload OK
    [  101.407224] r8712u: CustomerID = 0x000a
    [  101.407228] r8712u: MAC Address from efuse = 00:0b:81:ab:10:c5
    [  101.407231] r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
    [  101.407306] usbcore: registered new interface driver r8712u
    [  102.545696] r8712u: 1 RCR=0x153f00e
    [  102.549180] r8712u: 2 RCR=0x553f00e
    [  102.682550] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    
    root@kali:~# iwconfig
    wlan0     unassociated  Nickname:"rtl_wifi"
              Mode:Managed  Access Point: Not-Associated   Sensitivity:0/0  
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0

  6. #6
    Join Date
    2013-Mar
    Posts
    354
    Try putting interface wlan0 to monitor mode: airmon-ng start wlan0

    See if it works.

    Also try booting without the USB plugged in. After boot, plug it in and see if device is present: iwconfig

  7. #7
    Join Date
    2013-Oct
    Posts
    56
    Thanks for responding, but as you can see from the above....I have already tried the iwconfig and it is there. Below is the output(which has been
    tried on many occassions) or the airmon output-

    root@kali:~# airmon-ng start wlan0


    Found 3 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!
    -e
    PID Name
    2556 NetworkManager
    13606 wpa_supplicant
    13646 dhclient


    Interface Chipset Driver


    root@kali:~# kill 2556
    root@kali:~# kill 13606
    root@kali:~# kill 13646
    root@kali:~# airmon-ng start wlan0


    Interface Chipset Driver


    root@kali:~#

  8. #8
    Join Date
    2013-Oct
    Posts
    56
    Problem Solved - My thanks to all who viewed this thread.

  9. #9
    Join Date
    2013-Nov
    Posts
    2
    What was required for you to get this chipset into monitor mode. I have been working on this for it seems like Forever!! lol. I can't seem to get any of the modified drivers to install. I am fairly new to linux but not to computers in general. I know that I am overlooking the simplest detail. Did you have to install a modified driver to get the process completed? Any help would be greatly appreciated at this point.

  10. #10
    Join Date
    2013-Nov
    Location
    Vancouver
    Posts
    1

    How did you solve the problem?

    Quote Originally Posted by flyinghaggis View Post
    Problem Solved - My thanks to all who viewed this thread.

    ??

    when I type the following i get this below... just like you were reporting.. how did you solve it?

    root@kail# airmon-ng start wlan0

    Found 3 pro.......
    PID
    2948 Network Manager
    3043 dhclient
    3773 wpa_supplicant

    Interface Chipset Driver





    ===========================================

    then nothing listed for interface chipset and dirver.. it doesn't creat a mon0 either when I type airmon-ng start wlan0

    Please help.

  11. #11
    Join Date
    2013-Oct
    Posts
    56
    Sorry to Mislead -

    I just went out and bought another one (different of course) with the atheros chipset on board.

    Rab.

    Quick update....have been told by another source to try - airmon-zc

    airmon-zc start wlan0


    Found 3 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!

    PID Name
    2666 NetworkManager
    2864 wpa_supplicant
    2865 dhclient
    Process with PID 10738 (wlan0) is running on interface wlan0

    X[PHY]Interface Driver[Stack]-FirmwareRev Chipset Extended Info

    S[null]wlan0 r8712u[ieee80211]-unavailable Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter No monitor or injection support

    Rab.
    Last edited by flyinghaggis; 2013-11-19 at 17:59. Reason: Update

  12. #12
    Join Date
    2013-Dec
    Posts
    1
    I have a USB card with the same chipset and I can't get it into monitor mode as well.

    I can confirm the same error messages as flyinghaggis.

  13. #13
    Join Date
    2014-Jan
    Posts
    1
    [QUOTE=flyinghaggis;28356
    root@kali:~# airmon-ng start wlan0


    Found 3 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!
    -e
    PID Name
    2556 NetworkManager
    13606 wpa_supplicant
    13646 dhclient


    Interface Chipset Driver


    root@kali:~# kill 2556
    root@kali:~# kill 13606
    root@kali:~# kill 13646
    root@kali:~# airmon-ng start wlan0


    Interface Chipset Driver


    root@kali:~#[/QUOTE]
    probably off the main topic (the rtl8191su) but instead of seperate kill command, try

    root@kali:~# airmon-ng check kill

Similar Threads

  1. Unable to set MONITOR mode / 8812au (wusb6300) / Kali in Parallels
    By msteele999 in forum TroubleShooting Archive
    Replies: 9
    Last Post: 2016-01-31, 17:41
  2. Plz Help ! Cannot install Realtek 8191SU USB Wireless lan driver
    By a340090 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2014-09-15, 15:24
  3. Unable to capture 5GHz wireless N traffic in monitor mode
    By smmalis37 in forum General Archive
    Replies: 6
    Last Post: 2014-04-01, 23:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •