Results 1 to 3 of 3

Thread: Wireless Adapter TP LinkTL-WN722N not recognized in VM VirtualBox

  1. #1
    Join Date

    Wireless Adapter TP LinkTL-WN722N not recognized in VM VirtualBox

    Hi everyone.
    Ok, here's my problem. Here I got Windows 7 with a VM VirtualBox where I installed the Kali Linux 32 bit version.
    My PC has the Wireless Adapter TP LinkTL-WN722N plugged and I'm connected to a Wifi network. I don't have
    a cable to the computer. That's the only connection to the internet I have. So everything is running just fine, except
    when I try to recognize the Wifi adapter.
    There i go:
    Also nothing appears when i type airmon-ng
    I have successfully updated and upgraded the system. When I open Iceweasel I'm surfing the internet with no problem.
    I also tried in VM VirtualBox to change the network settings to bridge, then from Devices I chose USB Device (My Wifi adapter).
    No success.
    My goal is to get the wifi adapter recognized, working and configured for packet injection.
    I looked all over in the forums and internet.
    Is the problem that I don't have internet connection (cable) + my Wifi adapter or the way I'm using Kali (VM VirtualBox) ?
    Or maybe there's another solution to my problem?

    I will appreciate any help. And please excuse me, I'm new to linux and especially to Kali. I've tried Ubuntu and I was
    interested in Backtrack. Now I moved to Kali and I just want to learn and educate myself in Linux and Internet/Network security.
    Thanks in advance!

  2. #2
    Join Date
    Hi, Im also new here and to Kali. On the virtualbox, in the settings area, did you enable USB area. select both checkboxes and then click the add button and see if your adapter shows up in there.

    I just ordered the same adapter so I am hoping that this helps some!

  3. #3
    Join Date
    Do you have the vbox tools installed in kali?

Similar Threads

  1. KALI WSL - Wireless adapter(s) - How to be recognized?
    By hmarie in forum Installing Archive
    Replies: 0
    Last Post: 2020-09-19, 07:03
  2. Replies: 1
    Last Post: 2016-10-03, 11:48
  3. TP-Link WN722N adapter does not connect to wireless on Kali installed to HD
    By stantheman2000 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-07-20, 02:01

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts