Hi, after trying to get my alfa awus051nh card to work in kali 1.0.5, I almost gave up.
After googling for 2 days I found a solution that worked for me.

First I have to downgrade to Kali 1.0.1 from http://cdimage.kali.org/kali-1.0/

After installing that on my SD card I resized my SD card cause I only used 5 gb of my 16 gb SD card, I did that with "gpartd" builtin in Kali I hade om ny desktop computer.

But I had some problem trying to boot from the SD card on my RPI, the RPI just showed a quick green light then red.
I figured out that after installing kali 1.0.1 the boot files seemed of.

I had a backup of my old kali 1.0.5 just in case.

I copied almost all files from my old usb0 folder except the kernel files to my new made usb0 ( usb0 is my small boot partition that is 64mb)

Now it started up, and wifite wlan1 worked ! ( as I have a Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter as wlan0 )

Im sorry if my english sucks, but I hope this helps other ALFA card owners out their ....