Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Alfa AWUS036NHA Tx Power Boost Guide

  1. #11
    Junior Member
    Join Date
    Mar 2013
    Posts
    23
    can you show your results after the reboot, as i did all of that before and it didnt work

  2. #12
    Junior Member
    Join Date
    Mar 2013
    Posts
    23
    i tried it again, and now this is working for me, did it on a normal boot not in a VM, thanks for the help bro


    ignore the attached image, uploaded the wrong one
    Attached Images Attached Images
    Last edited by wifiuk; 2015-08-22 at 09:39 PM.

  3. #13
    Junior Member
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    3
    Quote Originally Posted by Battleship View Post
    Hey man there is no useful reason to raise your TX power unless you are in a region that everyone is using -30dbm to transmit. All that it does is makes your outbound signal stronger not your inbound reception. And more than likely burn up your card sooner.
    In my opinion its useful, lets say you want to make a evil twin attack its easier to make the client connect to your fake router since they get better reception. But for recieving data you need to raise the tx power of the router/client or get a better antenna/use a directional antenna to focus the signal better, but thats another story. This is just for educational purposes and should never be used for illegal purposes.


    Quote Originally Posted by Rocketballz View Post
    Duuuuude thats the long way. This way takes 5 seconds to boost the TX power....
    #sudo ifconfig wlan1 down <<<<Assuming that's you're alfa card
    #iw reg set BO
    #sudo ifconfig wlan1 up
    #sudo iwconfig and you will see it just about double
    Thats not possible in this case since the card is region locked.. This guide works perfect.
    Very useful when on "vacation" in regions where its allowed to use tx rate of 30

  4. #14
    Junior Member
    Join Date
    May 2015
    Posts
    2
    ifconfig wlan0 down
    iw reg set BZ # new Region. BO does not work any more
    iwconfig wlan0 txpower 30
    ifconfig wlan0 up

  5. #15
    Junior Member
    Join Date
    Aug 2015
    Posts
    11

    How to increase TX Power Signal Strength of WiFi

    though risky but if you wish -
    for increasing TX power - Copy paste the following commands into a text file and save it in Home Directory as - WifiTxBoost

    Code:
    #!/bin/bash
    
    echo "hello, root!"
    echo " taking down wlan0"
    ifconfig wlan0 down
    sleep 3
    
    echo "setting Region to Bolivia"
    iw reg set GY
    sleep 3
    
    echo "setting TxPower to 30"
    iwconfig wlan0 txpower 30
    sleep 2
    
    echo "starting wlan0"
    ifconfig wlan0 up 
    echo "pulling wlan0 interface up"
    iwconfig
    sleep 5
    
    echo "good bye"
    apply following commands to increase TX power (when needed) -

    Code:
    chmod +x WifiTxBoost
    ./WifiTxBoost
    (you may edit file with wlan1 too, the monitor mode (wlan1mon will be as per TX power set)



    i here put a simple list of commands before starting penetration testing - (i assume that you are using 2 network cards)
    save these commands in a text file and apply these commands before starting any testing -


    Code:
    ifconfig -a
    
    macchanger -m 00:01:02:03:04:05 eth0
    
    iw wlan0 interface add wlan0mon type monitor
    
    ifconfig wlan0 down
    ifconfig wlan0mon down
    
    macchanger -m 00:02:03:04:05:06 wlan0
    macchanger -m 00:04:05:06:07:08 wlan0mon
    
    chmod +x WifiTxBoost
    ./WifiTxBoost
    
    ifconfig wlan0 up
    ifconfig wlan0mon up
    
    
    ifconfig wlan1 down
    macchanger -m 00:03:04:05:06:07 wlan1
    ifconfig wlan1 up
    
    iwconfig 
    
    ifconfig -a
    thanking you.
    Last edited by maulesh; 2015-09-18 at 05:21 PM.

  6. #16
    Junior Member
    Join Date
    Jan 2016
    Location
    Vancouver, BC CANADA
    Posts
    3
    Just a question on tx power. I setup your script and this is the output. Wondering if I'm getting 20 or 30dBm? Using Kali v2

    root@kali:~# ./wifitx.sh
    hello, root!
    taking down wlan0
    setting Region to GY
    setting TxPower to 30
    starting wlan0
    pulling wlan0 interface up
    wlan0 IEEE 802.11bgn ESSIDff/any
    Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
    Retry short limit:7 RTS thr=2347 B Fragment thrff
    Encryption keyff
    Power Managementff

    lo no wireless extensions.

    eth0 no wireless extensions.

    good bye
    root@kali:~# iw reg get
    country GY: DFS-UNSET
    (2402 - 2482 @ 40), (N/A, 30), (N/A)
    (5735 - 5835 @ 80), (N/A, 30), (N/A)
    root@kali:~#

  7. #17
    Member
    Join Date
    Dec 2015
    Posts
    36
    forget this tutorial it doesn't work. read here: https://forums.kali.org/showthread.p...-via-UART-JTAG

  8. #18
    Junior Member
    Join Date
    Jan 2016
    Location
    Vancouver, BC CANADA
    Posts
    3
    I'm able to change to TX Power for my Alfa AWUS036H but not for my new AWUS036NHR v.2

    AWUS036NHR v.2
    wlan0 IEEE 802.11bgn ESSID off/any
    Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
    Retry short limit:7 RTS thr=2347 B Fragment thr off
    Encryption key off
    Power Management off

    AWUS036H
    wlan1 IEEE 802.11bg ESSID off/any
    Mode:Managed Access Point: Not-Associated Tx-Power=30 dBm
    Retry short limit:7 RTS thr off Fragment thr off
    Encryption key off
    Power Management off

  9. #19
    Junior Member
    Join Date
    Oct 2016
    Posts
    2
    Does it work for anyone? Does it has any advantage over the default value (20) ?

    Thanks

  10. #20
    Junior Member
    Join Date
    Mar 2017
    Posts
    1
    can somehelp to update this tutorial for kali linux 2.0

    im struggle for a week and still unsuccessful. please help guys!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •