Results 1 to 3 of 3

Thread: Wifi adapter installation problem (Ralink Technology. corp. RT2870/RT3070)plz help me

  1. #1
    Join Date

    Wifi adapter installation problem (Ralink Technology. corp. RT2870/RT3070)plz help me

    Hello Everybody!

    I would like to ask you for some help. I was thinking I can do it on my own, but I cant.
    Today is my 4th day, trying to install my wifi adapter. I have tried a lot of techniques, followed youtube tutorials, googled a lot, but nothing really changed.
    I'm new to kali linux, please keep that in mind. Anyway since i spent 4 day with it, I know the more information I give, the easier for you to help me, so I will try to do my best.

    First of all, kali is installed on a raspberry pi. (i dont know it is important, but after booting I get black screen, than I press ctrl+f1 which opens xterm, command: startx, after that kali boots normally.)

    I have just reinstalled it, because in the last couple days i tried that much thing, I cant even remember.

    Modifications since reinstall:

    - apt-get upgrade
    - apt-get update
    - apt-get install wireless-tools
    - I have also installed some ralink firmware

    I have tried to follow this instruction:

    Downloaded this file:


    Pasted into lib/firmware

    In xterm with some command I have extracted it.

    As network manager Im using wicd

    No problem if I need to reinstall it, Its just a couple minutes with raspberry.

    And finally here are some info from xterm:

    command: dmesg

    new high-speed usb device number4 using duc_otg
    new usb device found idVendor=148f . idProduct=3070
    new usb device strings: Mfr=1. Product=2. SerialNumber=3
    Product: 802.11 n wlan
    Manufacter Ralink
    serial number 1.0

    Command: lsusb

    Bus 001 Device 004: ID 148f:3070 Ralink Technology. corp. RT2870/RT3070 wireless adapter

    Command: ifconfig

    Wlan0 Link encap: Ethernet. HWaddr 00:e0:4c:20:05:11
    MTU:1500 Metric 1

    (At the end txquenuelen:1000, otherwise ewerything 0)

    Command iwconfig

    Wlan0 no wireless extension

    Thank you for your help!

  2. #2
    Please,... post a


    Output, to see which module its been loaded...

  3. #3
    You don't have to do nothing, just plug your device and enjoy.
    Kali is a debian with all this kind of stuff, drivers, firmwares, tools, that the interest of kali, a full and complete distribution for wireless, pentesting, hacking, cracking
    The tutorial you followed is for PCI ralink chipset so i guess you just made a mess...
    Quote Originally Posted by h3rucutu
    My wireless module is RT 3090 which package in rt2080pci
    I use severals ralink USB chipsets RT3070, RT3072, RT3572 and all of them work out of the box with kali ( actually with 99% of GNU Linux distributions )

Similar Threads

  1. Replies: 0
    Last Post: 2020-02-23, 09:06
  2. Kali 2.0 SANA "Ralink Technology, Corp. MT7601U" USB wifi not working
    By k.v.manjunath in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2016-01-19, 15:03
  3. Ralink Technology, Corp. RT5370 Wireless Adapter not functioning
    By maggg in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-11-21, 12:02

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts