Results 1 to 2 of 2

Thread: Windows 7 Kali dual boot install error. Atheros E2200 killer + 2 HDD

  1. #1
    Join Date

    Windows 7 Kali dual boot install error. Atheros E2200 killer + 2 HDD


    I'm having trouble installing Kali on a MSI GE70 2OE with a SSD HD and a standard SATA HD.

    I've installed W7 on the SSD, and then partitioned my SATA in two parts: One 800Gb for W7 and another 200Gb of empty space to install Kali. There's as well 2Gb occupied by a FreeDos installation on my SATA that I've left just in case.

    First problem: When installing Kali my Atheros Killer 2200 netword card is not recognized. I've found possible solutions to this problem AFTER the installation, but so far I don't have access to a console (nor I can use a package administrator). I've to pass this point without installing drivers for my ethernet card and with no access to internet.

    Second problem: I can't install a package administrator. No internet -> No package administrator. I've to skip this point as well. Is this really troublesome?

    Third and final problem: I can't install GRUB. When starting the GRUB installation the only SO that finds is FreeDos, that is in my SATA along with Kali. I've tried all possibilities to install GRUB but none works:
    /dev/sda -> MBR for SATA disk (I think). It doesn't work
    /dev/sda5 - Partition for Kali, 200 Gb. It doesn't work
    /dev/sda6 -> SWAP space, 10Gb. Doesn't work
    /dev/sdb -> W7 on my SSD, 128Gb. Doesn't work.

    I think I didn't try sda2 where my FreeDos is, but I guess it wouldn't work anyway.

    I would like to know if I can fix the network card problem during installation, and specially I would like to know how to install GRUB, as this is the point where I'm stack.

    Thanks in advance! Don't hesitate to ask me for more details.

  2. #2
    Join Date

    SOLVED Windows 7 Kali dual boot install error. Atheros E2200 killer + 2 HDD

    Hello. I managed to solve the dual boot and installation problem.

    I installed W7 first on my SSD. My BIOS is UEFI enabled, however my installation was done with a MBR (not GTP) partition, so I assume it's working on legacy BIOS. I reinstalled again Kali on my standard DATA HDwith the mandatory partitions. This time however I managed to install GRUB on the Kali partition. This could be because previously my partition was logical and not primary, but since this time I started the partitioning phase from the very beginning I managed to change this. This, however, could not be the case of GRUB not giving me a chance to install it. Anyway, this time worked if partitioning was done from zero with the installator, not just changing the file system to ext4 and the root to /.

    My ethernet card was not recognized (ouch!) so the Kali installation on my SATA was finished. Then, when switching the system on again, my W7 was booted with no multiboot (as expected as GRUB was installed on SATA, not on the primary disk). To add Kali to my boot menu I used the easyBCD application. It's possible to do it on a command console with bcdedit, but no need to deal with the console. Simply choose the Linux distribution from the menu (it should appear on easyBCD if GRUB was installed) and add the entry to your BIOS menu. Work done!

    I'm facing now the issue of not having drivers for my atheros killer e2200. Without Internet, I'll have to install drivers from a USB, but that's another story.

Similar Threads

  1. Kali-Windows dual boot error (no such device ...)
    By abkunal in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-10-02, 09:58
  2. Replies: 0
    Last Post: 2013-12-21, 02:44

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts