I've been trying to get this Wireless USB adapter working in Kali VM with Virtualbox, but I believe the host has a hold of it and won't let it go.
So I would like to know how to unmout the Wireless USB Adapter from Ubuntu so that the guest OS can grab it.

Compy: Acer E1-572 laptop
Host: Ubuntu amd64 13.10
Guest: Kali on Virtualbox 4.3.6
$:uname -a
Linux kali 3.7-trunk-amd64 #1 SMP Debian 3.7.2-0+kali8 x86_64 GNU/Linux
Virtualbox guest additions and extensions are both installed.

Wireless USB: TP-Link TL-WN722N

No wlan* found, but device is found in lsusb.

I've tried (in Kali) -- downloading and copying the firmware, compiling the firmware from backports' source, installing the drivers, removing & adding from modprobe, etc...
A lot of users say this adapter is just plug and play with Kali -- and it seems that it already had the firmware and drivers, so I don't think firmware is the issue.
If I plug in the USB before launching Virtualbox, then the green light comes on the USB adapter, and it works fine on the Ubuntu side.
I tried the following, to try and unmount it from Ubuntu, which removes wlan1, but still seems connected to the host:
sudo ifconfig wlan1 down
If I plug it in after launching Virtualbox, then it shows up in lsusb, but will not initialize.
dmesg says, "ath9k_htc: Target is unresponsive"

logs in Kali:
dmesg (snipped)
dmesg (full)
modinfo ath9k_htc --- maybe looks a little weird???
While VB is running, if I do an lsusb on the host (Ubuntu) the wireless USB shows up there as well as in Kali:
$: lsusb 
Bus 002 Device 024: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
If I try and Uncheck the USB Sharing in Virtualbox, Kali / VB tends to freeze for a minute -- then if I try and remount, or check to share the USB, then it gives the following error:
USB Devices is busy with a previous request.

I'm thinking the hangups are on the Ubuntu Host side, in that it still has a hold of of the Wireless USB adapter.
Any help would be appreciated.