Okay, so I have a computer that would usually be a Windows 7 Family Premium with 4Go of RAM. I had installed Linux Mint 15 on it (not partition install though). Following some... issues I had with windows, I'm stuck with only the Linux Mint. Now, I decided to try Kali on a virtual machine a while ago when I was on windows, but messed up something in the install, and I coulndn't connect. Not too long ago, I decided to retry and so I tried installing it from a virtual machine agin. As my computer is x64, I tried the amd64, which had already worked on Windows, but the installation failed. After a few tries, I decided to launch it live, only to notice that my version of Mint was apparently not x64 compatible for Kali. So I tried the x86 version. Once again, it didn't work. I tried the normal ISO files, the mini ones, but it didn't work. Every time, the PAE/NX was activated, and I always created a new disk to avoid complication. Whatever the installation, may it be graphic or normal, nothing works. Every time, it stops almost at the end (90% for the mini ISO) and suddenly fails. It says that the step that failed is 'installing the system'.
If you wanna know, the virtual machine always have 1024Mo RAM and 10Go of storage.

Does anyone know what is wrong? The fact that there is no log of error is very disturbing, because there's no way to know what's wrong in the install.

Thanks in advance,