Results 1 to 5 of 5

Thread: nvidia-xconfig and reboot, "x(gdm3)" will not load. Several days research and nothing

  1. #1
    Join Date
    2014-Feb
    Posts
    12

    Angry nvidia-xconfig and reboot, "x(gdm3)" will not load. Several days research and nothing

    I've reloaded kali about 3 times, in order to try different methods of installing nVidia drivers for my machine. None of have worked so far, but I am closer than before with this latest attempt.

    The problem is this, I installed using this guide here. I was successful all the way to the point where I ran nvidia-xconfig and then rebooted the system. Upon restart, I get to the point where the screen is blank with the flashing cursor at the top left corner of the screen. From there I can do a ctrl-alt-f1 to get to the console, but no GUI. I know that the problem exists in the xorg.conf file because when I delete that file and reboot everything comes up fine, but without my nvidia driver loading.

    I ran dmesg and here is the portion where I see that the driver is attempting to load and is followed by what appear to be several error messages about a conflicting version number or something. Had I not taken a 6 year hiatus from linux I may of been able to figure this out, but I need help. Here is the dmesg output from where I believe the nvidia driver is trying to load up.

    Code:
    [    6.039345] nvidia: module license 'NVIDIA' taints kernel.
    [    6.039349] Disabling lock debugging due to kernel taint
    [    6.046915] nvidia 0000:01:00.0: enabling device (0006 -> 0007)
    [    6.046986] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
    [    6.047062] NVRM: loading NVIDIA UNIX x86 Kernel Module  304.117  Tue Nov 26 21:36:39 PST 2013
    [    6.536829] media: Linux media interface: v0.10
    [    6.599308] Linux video capture interface: v2.00
    [    6.804787] uvcvideo: Found UVC 1.00 device USB 2.0 WebCam Device (064e:d282)
    [    6.808117] input: USB 2.0 WebCam Device as /devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.4/3-1.4:1.0/input/input15
    [    6.808265] usbcore: registered new interface driver uvcvideo
    [    6.808268] USB Video Class driver (1.1.1)
    [    6.808749] [drm] Enabling RC6 states: RC6 on, RC6p on, RC6pp off
    [    6.817657] cfg80211: World regulatory domain updated:
    [    6.817660] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [    6.817662] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [    6.817664] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [    6.817665] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [    6.817667] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [    6.817668] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [    8.523640] Adding 11707388k swap on /dev/sda6.  Priority:-1 extents:1 across:11707388k 
    [    8.536415] EXT4-fs (sda5): re-mounted. Opts: (null)
    [    8.773767] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
    [    9.059342] loop: module loaded
    [   10.231324] alx 0000:03:00.0: irq 48 for MSI/MSI-X
    [   10.231382] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [   10.232158] alx 0000:03:00.0 eth0: NIC Up: 100 Mbps Full
    [   10.232387] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [   11.736445] Netfilter messages via NETLINK v0.30.
    [ 1566.999752] NVRM: API mismatch: the client has the version 319.82, but
    [ 1566.999752] NVRM: this kernel module has the version 304.117.  Please
    [ 1566.999752] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 1566.999752] NVRM: components have the same version.
    [ 1628.787947] NVRM: API mismatch: the client has the version 319.82, but
    [ 1628.787947] NVRM: this kernel module has the version 304.117.  Please
    [ 1628.787947] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 1628.787947] NVRM: components have the same version.
    [ 1656.497396] NVRM: API mismatch: the client has the version 319.82, but
    [ 1656.497396] NVRM: this kernel module has the version 304.117.  Please
    [ 1656.497396] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 1656.497396] NVRM: components have the same version.
    [ 1698.484559] NVRM: API mismatch: the client has the version 319.82, but
    [ 1698.484559] NVRM: this kernel module has the version 304.117.  Please
    [ 1698.484559] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 1698.484559] NVRM: components have the same version.
    [ 1708.234963] NVRM: API mismatch: the client has the version 319.82, but
    [ 1708.234963] NVRM: this kernel module has the version 304.117.  Please
    [ 1708.234963] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 1708.234963] NVRM: components have the same version.
    [ 1982.489383] NVRM: API mismatch: the client has the version 319.82, but
    [ 1982.489383] NVRM: this kernel module has the version 304.117.  Please
    [ 1982.489383] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 1982.489383] NVRM: components have the same version.
    [ 1987.759691] NVRM: API mismatch: the client has the version 319.82, but
    [ 1987.759691] NVRM: this kernel module has the version 304.117.  Please
    [ 1987.759691] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 1987.759691] NVRM: components have the same version.
    [ 1988.858817] NVRM: API mismatch: the client has the version 319.82, but
    [ 1988.858817] NVRM: this kernel module has the version 304.117.  Please
    [ 1988.858817] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 1988.858817] NVRM: components have the same version.
    [ 2652.273131] NVRM: API mismatch: the client has the version 319.82, but
    [ 2652.273131] NVRM: this kernel module has the version 304.117.  Please
    [ 2652.273131] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 2652.273131] NVRM: components have the same version.
    [ 2658.335612] NVRM: API mismatch: the client has the version 319.82, but
    [ 2658.335612] NVRM: this kernel module has the version 304.117.  Please
    [ 2658.335612] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 2658.335612] NVRM: components have the same version.
    [ 2691.362314] NVRM: API mismatch: the client has the version 319.82, but
    [ 2691.362314] NVRM: this kernel module has the version 304.117.  Please
    [ 2691.362314] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 2691.362314] NVRM: components have the same version.
    Thanks in advance for any help!!

  2. #2
    Join Date
    2013-Mar
    Posts
    354
    There is a different version as to 319.82 and the 304.117.

    Make sure you installed the correct versions in modulkes (headers, dkms, etc).

  3. #3
    Join Date
    2014-Feb
    Posts
    12
    I actually got my issue solved while working through it in a different thread. Thanks for the suggestion though!!

  4. #4
    Join Date
    2014-Jan
    Posts
    3
    Quote Originally Posted by skittlebeezy View Post
    I actually got my issue solved while working through it in a different thread. Thanks for the suggestion though!!
    Can you post how you fixed this fault or the link to the site you used to get it working

  5. #5
    Join Date
    2014-Feb
    Posts
    12
    Quote Originally Posted by emmanneil View Post
    Can you post how you fixed this fault or the link to the site you used to get it working
    https://forums.kali.org/showthread.p...stall-problems

    Look at the last post

Similar Threads

  1. Replies: 3
    Last Post: 2018-03-22, 20:24
  2. Errors booting Kali: "you need to load the kernel first"
    By Redemption116 in forum Installing Archive
    Replies: 3
    Last Post: 2017-06-27, 11:31
  3. Replies: 3
    Last Post: 2017-06-10, 09:29
  4. Kali doesn't "load" after GRUB
    By GoldenDracoa in forum TroubleShooting Archive
    Replies: 10
    Last Post: 2017-03-19, 21:29
  5. MSF "failed to load module"
    By focus in forum General Archive
    Replies: 2
    Last Post: 2016-12-26, 05:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •