Results 1 to 10 of 10

Thread: Optimus install problems.

  1. #1
    Join Date
    2013-Mar
    Posts
    30

    Unhappy Optimus install problems.

    I've been trying to get Kali and my laptop (with an Nvidia Optimus GPU) to work together but I can not figure it out.

    I have Kali 64bit installed on a partition and dual booted with Windows.

    List of guides I have tried:
    These ones seem the most promising and they are the ones that I am currently using:
    PHP Code:
    https://wiki.ubuntu.com/Bumblebee#Installation
    https://forums.kali.org/showthread.php?20006-How-to-install-Nvidia-driver-on-Kali-1-0-6and-solve-ERROR-Unable-to-build-the-Unifin&p=30487#post30487 
    Also tried:
    PHP Code:
    http://debbase.wordpress.com/2012/07/26/install-cuda-pyrit-in-ubuntu-12-04-lts-precise-pangolin-64-bit/
    https://help.ubuntu.com/community/Cuda
    http://samiux.blogspot.com/2013/11/howto-cuda-on-kali-linux-105.html
    http://news.softpedia.com/news/How-to-Install-the-Latest-NVIDIA-331-20-Drivers-in-Ubuntu-13-10-399182.shtml
    http://santhecoder.blogspot.com/2013/08/install-nvidia-proprietary-driver-in.html 
    I have also tried the ".run" files from nvidia and the ".run" for CUDA.

    I installed the latest drivers using "apt-get install nvidia-drivers" (Nvidia meta file, installes everything) and I installed bumblebee using "apt-get install bumblebee" and "apt-get install bumblebee-nvidia."

    If I configure xorg.conf, I go to the terminal that happens when gdm3 isn't running and can't "service gdm3 start"

    Bumblebee gives this error when I try something like:
    Code:
    root@kali:~# optirun pyrit list_cores
    
    [   52.047678] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
    
    [   52.047736] [ERROR]Aborting because fallback start is disabled.
    Can someone please help me get my optimus gpu working please?
    Last edited by xNotta; 2014-02-07 at 01:56.

  2. #2
    Join Date
    2013-Mar
    Posts
    8
    Quote Originally Posted by xNotta View Post
    I've been trying to get Kali and my laptop (with an Nvidia Optimus GPU) to work together but I can not figure it out.

    I have Kali 64bit installed on a partition and dual booted with Windows.

    List of guides I have tried:
    These ones seem the most promising and they are the ones that I am currently using:
    PHP Code:
    https://wiki.ubuntu.com/Bumblebee#Installation
    https://forums.kali.org/showthread.php?20006-How-to-install-Nvidia-driver-on-Kali-1-0-6and-solve-ERROR-Unable-to-build-the-Unifin&p=30487#post30487 
    Also tried:
    PHP Code:
    http://debbase.wordpress.com/2012/07/26/install-cuda-pyrit-in-ubuntu-12-04-lts-precise-pangolin-64-bit/
    https://help.ubuntu.com/community/Cuda
    http://samiux.blogspot.com/2013/11/howto-cuda-on-kali-linux-105.html
    http://news.softpedia.com/news/How-to-Install-the-Latest-NVIDIA-331-20-Drivers-in-Ubuntu-13-10-399182.shtml
    http://santhecoder.blogspot.com/2013/08/install-nvidia-proprietary-driver-in.html 
    I have also tried the ".run" files from nvidia and the ".run" for CUDA.

    I installed the latest drivers using "apt-get install nvidia-drivers" (Nvidia meta file, installes everything) and I installed bumblebee using "apt-get install bumblebee" and "apt-get install bumblebee-nvidia."

    If I configure xorg.conf, I go to the terminal that happens when gdm3 isn't running and can't "service gdm3 start"

    Bumblebee gives this error when I try something like:
    Code:
    root@kali:~# optirun pyrit list_cores
    
    [   52.047678] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
    
    [   52.047736] [ERROR]Aborting because fallback start is disabled.
    Can someone please help me get my optimus gpu working please?
    hi, problem is in kernel, in my test bumblebee didnt work with the kernel 3.12. as for cuda, i didnt test, but it might work. i use debian 3.2 stable kernel with kali. you dont have to command optirun for pyrit, pyrit will find itself cuda if it works. i just logged for you cause i was like you here but all i got was insalt to my questions by some *******.

  3. #3
    Join Date
    2014-Feb
    Posts
    12
    I have been through all of the same sites that you have listed and am having the very same issue that you are having. Only difference is that I did find one that says not to use xorg.conf at all, you don't want one of those because it doesn't work with Optimus. If you have one you want to delete it and then edit "/etc/bumblebee/xorg.conf.nvidia". Just open "xorg.conf.nvidia" and run the command that it states in the commented section. After running that command you will enter your BusID of your nvidia card into the "xorg.conf.nvidia" file. If you don't know what a BusID looks like already, you will be adding something similar to this BusID "PCI:01:00.0" in the device section of your "xorg.conf.nvidia" file.

    I installed bumblebee on kali today in hopes of get my nVidia Optimus enabled laptop with a GeForce GT 650m to work properly. After getting the "Cannot access secondary GPU" error the first time I did some research and found that I needed to add my cards BusID to the xorg.conf.nvidia file. I did that and then rebooted and again tried to run "optirun -glxgears -info"(like the bumblebee wiki suggests) and I still come up with the "Cannot access secondary GPU" error. Anything that I try to run with "optirun" gives me the exact same result.

    One more detail, I ran "dmesg" and everything seems to be completely normal with the nvidia driver. But then again, I am pretty much a n00b again so I could be very wrong.

  4. #4
    Join Date
    2013-Mar
    Posts
    30
    Quote Originally Posted by kaliuser View Post
    hi, problem is in kernel, in my test bumblebee didnt work with the kernel 3.12. as for cuda, i didnt test, but it might work. i use debian 3.2 stable kernel with kali. you dont have to command optirun for pyrit, pyrit will find itself cuda if it works. i just logged for you cause i was like you here but all i got was insalt to my questions by some *******.
    I really do appreciate your help and I'm sorry to hear about how some people are, not sure why people reply just to insult someone/something.

    To update the kernel, would I just "apt-get install linux-image-3"?

  5. #5
    Join Date
    2014-Feb
    Posts
    12
    Quote Originally Posted by xNotta View Post
    I really do appreciate your help and I'm sorry to hear about how some people are, not sure why people reply just to insult someone/something.

    To update the kernel, would I just "apt-get install linux-image-3"?
    Did that work out for you or not?

  6. #6
    Join Date
    2013-Mar
    Posts
    30
    Quote Originally Posted by skittlebeezy View Post
    Did that work out for you or not?
    I just got time to try it tonight and it didn't work. Knowing my lack of knowledge of linux, I probably messed something up.

    I updated using debian wheezy backport following http://www.cyberciti.biz/faq/debian-...ux-kernel-3-2/
    Then installed nvidia drivers via "apt-get install nvidia-driver"
    Then installed Bumblebee and BUmblebee-nvidia.
    Tried pyrit list_cores and still only got my CPUs cores. When using optirun I got the "[ERROR]Cannot access secondary GPU - error: Could not load GPU driver" error.

    While still on the 3.2 kernel I tried http://allitsecurity.blogspot.com/20...a-optimus.html
    Followed the steps but used apt-get to install CUDA.
    In step 4 it says to see if the drivers installed correctly by running glxspheres and optirun glxspheres.
    When I typed it in, it said the command was not found.

    I wiped the partitions and am going to try again following the previous linked guide and using the .run file probably tomorrow night.

    If you have any tips, I am open to ideas.

  7. #7
    Join Date
    2013-Mar
    Location
    localhost
    Posts
    41
    Download driver from official website with *.run format , then run it ./*.run and install it simply
    r00tv.org
    telegram @bondbenz

  8. #8
    Join Date
    2014-Feb
    Posts
    12
    Quote Originally Posted by xNotta View Post
    I just got time to try it tonight and it didn't work. Knowing my lack of knowledge of linux, I probably messed something up.

    I updated using debian wheezy backport following http://www.cyberciti.biz/faq/debian-...ux-kernel-3-2/
    Then installed nvidia drivers via "apt-get install nvidia-driver"
    Then installed Bumblebee and BUmblebee-nvidia.
    Tried pyrit list_cores and still only got my CPUs cores. When using optirun I got the "[ERROR]Cannot access secondary GPU - error: Could not load GPU driver" error.

    While still on the 3.2 kernel I tried http://allitsecurity.blogspot.com/20...a-optimus.html
    Followed the steps but used apt-get to install CUDA.
    In step 4 it says to see if the drivers installed correctly by running glxspheres and optirun glxspheres.
    When I typed it in, it said the command was not found.

    I wiped the partitions and am going to try again following the previous linked guide and using the .run file probably tomorrow night.

    If you have any tips, I am open to ideas.
    One thing that I have noticed is recently is that you don't want to install the nvidia driver from nvidia themselves. You want to install it using apt-get install bumblebee-nvidia. Also, I too have tried running glxspheres in the past both with and without optirun and I get the same output, command not found. I have had "success" with glxgears though. I say that loosely because it didn't actually run, I just get the "Could not load GPU driver" error. But, it didn't say command not found, so I know that it's there at least haha.

    Also, I've found a few more sites(UBUNTU FORUMS) explaining some things a little better. Only problem is that they are meant for Ubuntu, not Debian. It seems that most of the support out there for anything linux related is going to be on an Ubuntu forum.

    Here are those sites:

    Ubuntu forum link 1
    Ubuntu forum link 2

    I'll mess around with it a little more here and let ya know if I come up with anything. I took a break from this problem for a few days so I feel refreshed and ready to tackle it....hopefully.

  9. #9
    Join Date
    2014-Feb
    Posts
    12
    Quote Originally Posted by bond benz View Post
    Download driver from official website with *.run format , then run it ./*.run and install it simply


    That's the very first thing that I tried, and I'm sure xNotta has as well. But it's not that simple with Optimus my friend. Thanks for the thought though.

  10. #10
    Join Date
    2014-Feb
    Posts
    12
    OK xNotta, I spent some time on irc in the #bumblebee chan. After quite some time the complete lack of response was broken by a gentleman who helped me figure out a fix for my issue. I can't guarantee that it will work for you as well, but it's worth a shot. I will tell you what I did with my fresh install to get this to work.

    1.You will want to follow the bumblebee wiki for installing bumblebee here‎.

    2. Reboot and then run lspci | egrep 'VGA|3D'

    3. From that output, find your nvidia gpu's BusID(should be similar to "01:00:0")

    4. Go to and open /etc/bumblebee/xorg.conf.nvida and enter your BusID into the Device section. Mine looks like this:
    Section "Device"
    Identifier "DiscreteNvidia"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BusID "PCI:01:00:0"


    5. Then run find /lib/modules -name nvidia\*

    6. You should get something similar to "/lib/modules/3.12-kali1-686-pae/updates/dkms/nvidia-current.ko" as your output. You want to take the end part "nvidia-current"(or whatever yours is) and enter that into /etc/bumblebee/bumblebee.conf in the [driver-nvidia] section as the Kernel Driver.
    Mine looks like this:
    ## Section with nvidia driver specific options, only parsed if Driver=nvidia
    [driver-nvidia]
    # Module name to load, defaults to Driver if empty or unset
    KernelDriver=nvidia-current
    PMMethod=auto


    7. Normally that would fix the problem, but if it doesn't you should at least be getting a different error now, similar to this "[ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please". If you are getting that error then continue to 8. If not, then I'm not sure what the problem is and you may want to get on irc freenode #bumblebee and ask around for some help there.

    8. After getting that error from step 7, reboot your machine.

    9. Run "tee /sys/module/rcutree/parameters/rcu_idle_gp_delay <<<1"

    10. Try running "optirun glxgears -info" again and it should start working.

    11. If it's working you will want to add "rcutree.rcu_idle_gp_delay=1" to GRUB so that it does it everytime linux boots.

    I hope that this works for you, I totally understand how frustrating this whole process can be. Which is why I spent the last 30 minutes writing this post. Good Luck!!!

    *EDIT* Oh, and I'm not sure how well CUDA will work now that I have this fixed. I'm just happy to be one step closer and at least having my gpu working properly.
    Last edited by skittlebeezy; 2014-02-10 at 19:46.

Similar Threads

  1. v1.1.0 NVIDIA Optimus hardware support?
    By Quest in forum General Archive
    Replies: 9
    Last Post: 2015-02-15, 12:33
  2. bumblebee driver for you optimus GPU
    By AbhimanyuAryan in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2014-08-15, 13:26
  3. NVIDIA and CUDA with OPTIMUS
    By jolubedju in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2014-06-03, 10:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •