Results 1 to 8 of 8

Thread: Help with VirtualBox

  1. #1
    Join Date

    Angry Help with VirtualBox

    Hi, I've been having a lot of trouble trying to get VirtualBox running.

    It seems that everything I try just leads to the same outcome of not being able to run my VMs. I can install it fine (I think) and it runs, but when I try to run a machine it gives me this:

    Kernel driver not installed (rc=-1908)

    The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

    '/etc/init.d/vboxdrv setup'

    as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.
    but that file isn't there. There are other vbox files there, just not that one.

    Any Ideas?

  2. #2
    Join Date

    There is a glitch after the upgrade to 3.12-kali1-amd64 (and possibly the 32-bit x86) see /var/lib/dkms/virtualbox/4.1.18/build/make.log about "bad return status from guid function". I did not see a bug report against Kali Linux though. Reboot to 3.7-trunk-amd64 previous kernel version and run 'dpkg-reconfigure virtualbox-dkms'. Allow the process to complete. The 3.7-trunk-amd64 rebuild will be successful and you will be able to start VirtualBox again without rebooting.

    With kind regards

  3. #3
    Join Date
    Quote Originally Posted by ROCKTUX88 View Post
    *post removed*
    Not sure that's the kind of thing we condone here.

    Removed quote - and for the record - no we do not condone it.
    Last edited by g0tmi1k; 2014-04-14 at 06:29. Reason: Removed ROCKTUX88
    If it smells like a duck, walks like a duck and quacks like a duck; then it probably is a duck.

  4. #4
    Join Date
    Quote Originally Posted by rastamouse View Post
    Not sure that's the kind of thing we condone here.
    And im sure many dont condone the use of kali and its tools but its reality , besides it was only a recommendation not a must.

  5. #5
    Join Date
    ran into the same problem and solved it by doing the following:

    1. download the latest binaries from the official website.

    2. remove all virtualbox packages using synaptic tool.

    3. run command below where file was downloaded
    root@host:/in/here/~# dpkg -i downloaded_file.deb
    this might be unrelated but for the sake of documentation,

    my machine overheated & shuts down in the middle of it.

    waited a minute, restarted and reinstall it again.

    hope that helps and best of luck~

  6. #6
    Join Date
    We have just junked virtual box and loaded VMWARE. Virtual box gave us one big headache. VMWARE loaded Kali 1.05 easily. We loaded 1.06 but it was so ******* up we found we spent less time reinstalling 1.05 then trying to sort out all the problems with 1.06.
    Last edited by g0tmi1k; 2014-04-14 at 06:31. Reason: Swearing

  7. #7
    Quote Originally Posted by mmusket33 View Post
    We loaded 1.06 but it was so ******* up we found we spent less time reinstalling 1.05 then trying to sort out all the problems with 1.06.
    If you don't report the bugs/issues with kali - they will not get fixed in later releases...
    Doesn't take too long to sign up to the bug tracker:

    Cleaned up thread: Illegal Activities & swearing.
    Forum rules:
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Documentation: (Offline PDF version)
    Bugs Reporting & Tool Requests:
    Kali Tool List, Versions & Man Pages:

  8. #8
    Join Date
    i tried it on vmware workstation it works like charm i think you should try vmware workstation.

Similar Threads

  1. Replies: 3
    Last Post: 2017-12-23, 05:50
  2. VirtualBox
    By Despionnage in forum Installing Archive
    Replies: 1
    Last Post: 2016-09-08, 19:55
  3. VirtualBox Trouble
    By WinSux in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-08-01, 16:14

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts