Results 1 to 7 of 7

Thread: HeLp Me for NVIDIa Driver after installation black screen

  1. #1
    Join Date
    2014-Feb
    Posts
    15

    HeLp Me for NVIDIa Driver after installation black screen

    hi guy, I use kali 64 bit and i have Ge force GT 620M on my laptop !!

    I install nvidia driver following this :

    apt-get update && apt-get install -y linux-headers-$(uname -r)

    sed 's/quiet/quiet nouveau.modeset=0/g' -i /etc/default/grub

    update-grub
    reboot

    CRTL+ALT+F1
    service gdm3 stop
    chmod 755 NVIDIA-Linux-x86_64-310.44.run
    ./NVIDIA-Linux-x86_64-310.44.run

    Now reboot,then reboot i have the black screen, then i type control+alt+f1 and type : nvidia-xconfig

    but I always have the same Black Screen when reboot !! why ??

  2. #2
    Join Date
    2014-Feb
    Location
    OZ
    Posts
    1
    Hello.

    Please read my post fully before you do anything else.

    I followed this http://docs.kali.org/general-use/ins...-on-kali-linux

    I might add though that this did not initially fix my problem of a black screen with a flashing cursor at top left. I also had NO xorg.conf installed on my system for some reason.
    I had to manually install nvidia-xconfig.

    After you install the 'nvidia-kernel-dkms' type the following commands into the terminal.

    $ aptitude install nvidia-xconfig

    Wait for this to finish and then type this.

    $ nvidia-xconfig

    You should see something about writing xorg.conf to the /etc/X11/ folder.
    Now follow the rest of the intructions on the URL above.
    Just a note on the last bit about cudaHashcat. This does not work for me so I ignored it, for now.

    Hopefully when you reboot your computer you should have a desktop show up.

    I hope this helps you out.

  3. #3
    Join Date
    2014-Feb
    Posts
    15
    i have the same problem !! aft nvidia-xconfig rebooot the system and show black screen

  4. #4
    Join Date
    2013-Mar
    Posts
    354
    Enter recovery mode when booting, and post the dmesg, please. Also make sure nouveau was blacklisted.

    I quote: "I install nvidia driver following this :

    apt-get update && apt-get install -y linux-headers-$(uname -r)"


    Yes, indeed you need the headers for installing propietary drivers.

    I quote: sed 's/quiet/quiet nouveau.modeset=0/g' -i /etc/default/grub

    You could have edited the file with nano go to the line with GRUB_CMDLINE_LINUX_DEFAULT="quiet" and add it. If line does not exist, add it.

    But when in grub menu, press "e" key and add "nouveau.modeset=0". If it works, make it permanent as detailed above.

    It keeps my attention that you are disabling modeset to nouveau driver? and then install nvidia?..I don't see any reason to do so, after all, nouveau will be blacklisted by nvidia installation (/etc/blacklist.d/"nvidia-nouveau-blacklist or something like that") and I do not see that nouveau is removed before installing propietary (rm noveau).

    There are some inconsistencies in your thread..Anyway, I suggest to post the dmesg and then see if nouveau was blacklisted or nvidia propietary was installed correctly.

    luck

  5. #5
    Join Date
    2014-Feb
    Posts
    15
    THe Nouveau driver are blacklisted and my grub is set to : sed 's/quiet/quiet nouveau.modeset=0/g' -i /etc/default/grub
    but i have the same error !! black screen every reboot system ! ctrl+alt+f1 > service gdm3 stop > nvidia-xconfig > reboot and Show Black screeen !! I Don't kNOW !

  6. #6
    Join Date
    2013-Aug
    Location
    Italy
    Posts
    65
    try to remove xorg.conf
    rm /etc/X11/xorg.conf and
    reboot
    I had the same problem and I solved it so then I installed or the backport drivers or the latest beta drivers version
    I just install the official nvidia site I had to recompile the kernel,while to have a fully functional installation of drivers in the repositories I had to add some packages in the source backport
    https://forums.kali.org/showthread.p...ild-the-Unifin
    sorry for my english
    Last edited by Devil_D; 2014-02-25 at 08:03.
    Est modus in rebus
    cd /usr/bin/bad

  7. #7
    Join Date
    2013-Mar
    Posts
    354
    Quote Originally Posted by netdestroyer View Post
    THe Nouveau driver are blacklisted and my grub is set to : sed 's/quiet/quiet nouveau.modeset=0/g' -i /etc/default/grub
    but i have the same error !! black screen every reboot system ! ctrl+alt+f1 > service gdm3 stop > nvidia-xconfig > reboot and Show Black screeen !! I Don't kNOW !
    How do you know it is blacklisted?...Have you checked the /etc/modprobe.d and see if it is blacklisted...Do not take it for granted..

    sed 's/quiet/quiet nouveau.modeset=0/g' does not mean nouveau will be blacklisted...

    By the way, just as information: you have 2 ways to install propietary driver: download from nvidia page or from repos.

Similar Threads

  1. Nvidia optimus black screen
    By huntlikeahound in forum TroubleShooting Archive
    Replies: 8
    Last Post: 2016-10-18, 16:41
  2. Replies: 1
    Last Post: 2016-09-24, 07:25
  3. Nvidia proprietary driver shows a black screen
    By dron100 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-08-18, 12:37
  4. Nvidia 460 gtx install driver + nvidia-settings black screen
    By zero-z in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2013-08-28, 03:30
  5. Black screen after NVIDIA driver (.run) installation
    By kalilinuxx in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-07-15, 00:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •