Results 1 to 2 of 2

Thread: Trouble installing qemu

  1. #1

    Question [SOLVED] Trouble installing qemu

    Hello all,

    I'm having a lot of trouble installing qemu within the 1.0.6 VMware machine. I've tried both apt-get, which gives me this response:

    Code:
    root@kali:/etc/apt# apt-get install qemu
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     qemu : Depends: qemu-system (>= 1.7.0+dfsg-2~kali2) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    Using aptitude gives me this feedback:

    Code:
    The following NEW packages will be installed:
      ipxe-qemu{a} libfdt1{a} libiscsi1{a} libspice-server1{a} 
      libusbredirparser1{a} libvdeplug2{a} libxen-4.1{a} libxenstore3.0{a} qemu 
      qemu-keymaps{a} qemu-system{a} qemu-system-arm{a} qemu-system-common{a} 
      qemu-system-mips{a} qemu-system-misc{a} qemu-system-ppc{ab} 
      qemu-system-sparc{ab} qemu-system-x86{a} qemu-user{a} qemu-utils{a} 
      seabios{a} sharutils{a} 
    The following packages will be upgraded:
      libusb-1.0-0 
    1 packages upgraded, 22 newly installed, 0 to remove and 132 not upgraded.
    Need to get 56.1 MB of archives. After unpacking 159 MB will be used.
    The following packages have unmet dependencies:
     qemu-system-sparc : Depends: openbios-sparc (>= 1.1) but it is not going to be installed.
     qemu-system-ppc : Depends: openbios-ppc (>= 1.1) but it is not going to be installed.
                       Depends: openhackware but it is not going to be installed.
                       Depends: qemu-slof which is a virtual package.
    The following actions will resolve these dependencies:
    
         Keep the following packages at their current version:
    1)     qemu [Not Installed]                               
    2)     qemu-system [Not Installed]                        
    3)     qemu-system-ppc [Not Installed]                    
    4)     qemu-system-sparc [Not Installed]
    I've tried installing the unmet dependencies, but the package manager is getting versions less than the ones required, and it can't install qemu-slof.

    Any thoughts on what I'm missing here?
    Last edited by snakegriffin; 2014-02-26 at 15:21. Reason: solved

  2. #2

    Lightbulb

    Ended up just compiling/installing from source, problem solved. Others may want to use the package manager to grab it, though!

Similar Threads

  1. Work with Kali ARM in QEMU
    By bolexxx in forum Kali Linux ARM Architecture
    Replies: 6
    Last Post: 2021-05-02, 18:24
  2. Install Kali on Linux Qemu VM
    By netskink in forum Installing Archive
    Replies: 4
    Last Post: 2014-10-03, 17:25
  3. Trouble in installing Dradis
    By kartic_iyer in forum Installing Archive
    Replies: 0
    Last Post: 2014-02-01, 13:37

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •