Results 1 to 3 of 3

Thread: Different problem with Ettercap remote_browser plugin

  1. #1
    Join Date
    2013-Oct
    Posts
    9

    Question Different problem with Ettercap remote_browser plugin

    I've really been getting serious with ettercap lately, and the one thing that I just cannot seem to get working is the remote_browser plugin! I've serached around the web for ages, but it seems that no one has a tutorial yet for KALI LINUX. Here are some details:

    I've changed the etter.conf remote_browser line to this:
    #the command used by the remote_browser plugin
    remote_browser = "iceweasel -remote openurl(http://%host%url)"
    I've also made all the other necessary changes to etter.conf.

    After successfully launching the MITM attack and starting the remote_browser plugin using this command:
    ettercap -i wlan0 -Tq -M arp:remote -P remote_browser /192.168.1.1/ /192.168.1.100/
    I open iceweasel, go to the test-victim computer (192.168.1.100) and go to a URL, google.com for example. When I come back to Ettercap, Iceweasel is still on the same home page, and I see these kinds of errors printed all over the Text interface of ettercap:

    REMOTE COMMAND: iceweasel -remote openurl(http://www.google.com/)

    (iceweasel:12399): GLib-WARNING **: getpwuid_r(): failed due to unknown user id (1000)
    No protocol specified
    Error: Failed to connect to X server.
    suff .php
    You can see that the command to open iceweasel was executed successfully, but it looks like iceweasel refused to open the URL because of some permission issues? Thinking that this was the case, I found the Iceweasel.exe file and edited the permissions to accept Read and write from all groups. But that still didn't change anything.

    I also have tried using "firefox" in the etter.conf instead of "iceweasel," but the results are the same.

    I'm able to open iceweasel from the Terminal just fine, but it seems that iceweasel refuses ettercap's remote connection. Any solutions that you can think of?

  2. #2
    Join Date
    2014-May
    Posts
    15
    type first in a shell: xhost +


    etterconf:

    remote_browser = "xdg-open http://%host%url"

    or

    remote_browser = "iceweasel -remote openurl(http://%host%url)"

    ozzy

  3. #3
    Firstly I wasn't sure if I should post this in a new thread or cling onto the end of this post. I realise this is old so hopefully it will get seen.
    I have followed the intructions as set by ozzy66 edited the etter.conf file to use remote_browser = "xdg-open http://%host%url"
    I am able to succesfully arp pision a remote machine on my home network now when using the remote browser plugin in ettercap it will open the pages in FireFox ESR however it's diplaying the url incorrectly and it's not able to open the page. Using abc.go.com firefox shows the address as http://abc.go.comhttp//abc.go.com/ this happens with everypage
    http://www.bing.comhttp//www.bing.com/
    I am thinking that there is something incorrect with the remote_browser changes I have made. I just can't see what would be causing it.
    Running Kali 2.0 rolling.

    Thanks in advance.

Similar Threads

  1. Ettercap Problem(s)
    By AdamElite in forum General Archive
    Replies: 39
    Last Post: 2013-11-01, 18:37
  2. ettercap problem using 0.7.6 and 0.7.3
    By johnjohnsp1 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-05-25, 08:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •