Results 1 to 7 of 7

Thread: apt-get dist-upgrade fails

  1. #1
    Join Date
    2013-Mar
    Location
    Canada
    Posts
    31

    apt-get dist-upgrade fails

    i had to format my laptop and re-install kali
    insted of downloading the new version i installed kali 1.0 wich i had from before

    it installed fine, then when i do apt-get update, then apt-get upgrade after a wile i get the follwoing error

    Processing triggers for shared-mime-info ...
    Errors were encountered while processing:
    /var/cache/apt/archives/libnfc5_1.7.0-3kali1_amd64.deb
    Error: GDBus.Errorrg.freedesktop.DBus.Error.Spawn.PermissionsInvalid : The permission of the setuid helper is not correct
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    any idea why or how to fix?
    “A goal without a plan is just a wish.”

  2. #2
    Join Date
    2014-Mar
    Posts
    14
    What did you do?

    1) apt-get dist-upgrad or apt-get-upgrade?
    2) Did you work in init 5 or 3?
    3) Did you try it as root or user?

  3. #3
    Join Date
    2013-Mar
    Posts
    354
    Clean the /var/cache/apt/archives (aptitude clean and aptitude autoclean). Do it twice or 3 times if necessary.

    Then try:
    1. aptitude update
    2. aptitude safe-upgrade
    3. aptitude safe-upgrade again to see if there was something new as you were updateing.
    4. aptitude full-upgrade

    Remember, Kernel versions are increasing from 1.0 to 1.6, so the video drivers are compiled with different kernel versions, in other words, you might encounter video issues, which you can fix in an easy way, if any issues.

  4. #4
    Join Date
    2013-Mar
    Posts
    354
    Quote Originally Posted by my68_ View Post
    What did you do?

    1) apt-get dist-upgrad or apt-get-upgrade?
    2) Did you work in init 5 or 3?
    3) Did you try it as root or user?
    Debian always uses runlevel 2 as DEFAULT. So whether in 5 or 3, unless you need to input an script in the runlevels (update-rc.d which is the legacy mode or with insserv if script is using LSB tags), it is in runlevel 2.

    Just to clear things out.

  5. #5
    Join Date
    2013-Mar
    Location
    Canada
    Posts
    31
    after further search found out it was a bug in debian and was fixed in a later release, seeing how i could not upgrade from command line i end up downloading 1.06 install it from usb

    Thanks everyone
    Last edited by nix; 2014-03-18 at 18:02.
    “A goal without a plan is just a wish.”

  6. #6
    Join Date
    2014-Mar
    Posts
    14
    Hi maverik35,

    thanks for clearing that up. Just a question, as I could not find an answer in the docu.

    Can I update all packs via the gui? Is there no risk? Or do I have to change runlevel for that?
    Do I use apt or aptitude or apt-get upgrade or ..dist-upgrade?

  7. #7
    Join Date
    2013-Jun
    Location
    Utah
    Posts
    22
    Did you download the Mirrors?

Similar Threads

  1. apt-get -y upgrade fails apt-get -y dist-upgrade fails
    By billp11 in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2016-11-04, 03:42
  2. Kali Rolling - gdm fails to start after dist-upgrade
    By wtf in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-09-25, 07:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •