I am using the Beaglebone Black Kali Linux version, and am having trouble with getting wifi working without ethernet being connected. I have a script that uses wlan0 that runs on boot, but there is a delay (1-2 minutes) when eth0 is disconnected. I have previously fixed this issue on other OSes (ie ubuntu) by modifying /etc/init/failsafe.conf and removing the delays. That file runs on boot on Ubuntu to delay a minute or so while it looks for ethernet. However this is apperently not the case for Kali Linux.
I have experimented with the /etc/network/interfaces file, but I can't seem to get a combination of options that removes the delay (generally by modifying "iface eth0 inet dhcp"), and retains usability of ethernet if I plug it in.
So is there any way to get it to automatically assign the default interface according to whats plugged in? (and if both are available then it uses both)