Results 1 to 8 of 8

Thread: Problems Writing Kali Linux for Raspberry Pi onto SDCARD, Using Linux or Windows

  1. #1
    Join Date
    2014-Jun
    Posts
    4

    Problems Writing Kali Linux for Raspberry Pi onto SDCARD, Using Linux or Windows

    Ive been having trouble flashing the kali distributions for ARM onto a sdcard to boot it up on my RPi. Ive used multiple different methods, none of which have worked for me. I have done days of research and have finally come to the conclusion that i can not get this working without some help or idea of what i could possibly be doing wrong. i have had success with plenty of other distributions like raspbian. i cant be the only one having these problems so hopefully if anything this post will help others out as well.

    Problem:
    Can Not successfully write kali linux to sdcard.



    Hardware Used:

    Gateway nv52 laptop with Windows 7 and Backtrack5 r3 running side by side
    included sdcard that came with my Rpi which is an unknown 8gb class 4 sdcard
    Sony 8gb class 4 sdcard that i had in my cell phone
    PNY 16gb class 10 sdcard, PNY Multi-slot usb & flash card reader that i bought just to install kali with
    Internal card reader from my laptop

    Software Used:

    Windows:
    MD5_and_SHA_Checksum_Utility
    7zip
    winrar 5.1
    Win32DiskImager


    Linux:
    Main terminal commands used- unxz and dd


    Approaches Ive taken.

    Windows
    1. downloaded Kali from the downloads page and http://cdimage.kali.org/. versions 1.0.7 and 1.0.6, image and torrent downloads.
    2. checked SHA1SUM with MD5_and_SHA_Checksum_Utility, Found correct SHA1sum. ( I am a little confused on if i am suppose to check against the img.xz file or the uncompressed .img file. the uncompressed file comes back with no match on SHA1SUM )
    3. Uncompressed .img.xz with both 7zip and winrar.
    4. Write to sdcard using Win32DiskImager

    Ive tried this several times, with all 3 sdcards which work with raspbian. Tried writing with both my internal card reader and PNY usb reader. this has all been done with the armel 1.0.7 , armhf 1.0.7 and 1.0.6 armel. ive download those 3 versions both from the downloads page and here. http://cdimage.kali.org/, both the torrent and img file. so 12 different downloads with all the correct SHA1SUM that i have attempted to write to 3 different sdcards with 2 different card readers. that is 64 attempts on windows alone and every time i do that i have to reformat my sdcard using diskpart in cmd prompt because they are an unrecognized format and/or no longer the correct size in gigabytes.

    ive done this whole process on my backtrack 5 distribution as well except i used "unxz imagefile.img.xz"
    then wrote to sdcard using dd if=imagefile.img of=/dev/sdb1 bs=512k.
    mounted, umounted, partition using fdisk.
    ive used multipule other commands, nothing i try seems to work.

    im completely lost as to why i can not get it working, if anyone has any suggestions or questions let me know so i can help you help me cause it has me mind boggled.

  2. #2
    Join Date
    2014-Jun
    Posts
    4
    update since ive posted this thread yestereday. unfortunately i still havent got kali installed yet. i have now tried every ARM distribution kali offers on this page > http://cdimage.kali.org/
    1.0.4 - 1.0.7. none have worked for me yet. i also tried using flashnul and fedora installer to flash the sd card. everything works fine with other distribution like raspbian,. no problems decompressing, reading, writing with any of the programs or hardware i have listed when flashing other distributions. i have no clue if my problem is extracting or flashing, my sha1sums are correct after downloading. i cant see every distribution i have download being bad since every sha1sum has been correct. i dont feel it has anything to do with my sdcards or card readers, as far as my software goes, i dont know, but they all seem to work fine for other distros.

    i kinda feel that my problem lies somewhere within extracting the img file but ive tried every possible way i know of or have found on forums.


    could someone compare this SHA1SUM from my copy of the kali-linux-1.0.7-armel.img.xz file AFTER being extracted, to their sha1sum of the extracted file?


    that way i will know if im having problems extracting the .img from the.img.xz

    SHA1SUM from my extracted copy of kali linux 1.0.7 armel. Same sum when extracting with 7zip as winrar or using unxz on linux.
    F67EDD8B17A2517F3217C393E27BA630C86F55B0

    anyone have a clue as to what im doing or not doing thats fucking me up?

  3. #3
    Join Date
    2014-Feb
    Posts
    244
    You need to dd it using the entire disk, not the first partition. so instead of dd if=imagefile.img of=/dev/sdb1 bs=512k you'd do something like dd if=imagefile.img of=/dev/sdb bs=512k - I don't use Windows at all for imaging, so i can't say what or why it doesn't work there.

  4. #4
    Join Date
    2014-Jun
    Posts
    4
    Quote Originally Posted by steev View Post
    You need to dd it using the entire disk, not the first partition. so instead of dd if=imagefile.img of=/dev/sdb1 bs=512k you'd do something like dd if=imagefile.img of=/dev/sdb bs=512k - I don't use Windows at all for imaging, so i can't say what or why it doesn't work there.


    thanks steev, i see how that would be a problem when trying to dd it in linux. i should have known this considering i read this page about 500 times as it mentions it like you have.

    http://elinux.org/RPi_Easy_SD_Card_Setup

    i gave it a shot, still no success unfortunately. heres the commands i did.


    to decompress
    unzx kali-linux-1.0.7-armel.img.xz

    to unmount
    umount /dev/sdb
    umount /dev/sdb1
    (did both because sdb1 was still mounted after unmounting /dev/sdb, /dev/sdb1 was the only partition showing up when using df -h to see what was mounted also tried to dd while it was still mounted, no success.)

    to flash sdcard
    dd if=kali-linux-1.0.7-armel.img of=/dev/sdb bs=512k
    after that finished i dd my /dev/sdb back to root and compared my md5sums, they did not match.

    i tried this with my new 16gb pny class 10 sdcard and my pny card reader. i havent tried my other sdcards this way yet.

  5. #5
    Join Date
    2014-Feb
    Posts
    244
    the armel image is for using a chroot, the image you actually need for an rpi is http://www.offensive-security.com/ka...mage-download/ here - the armhf and armel images do not have any kernels.

    Note that the contributed images are still at 1.0.6 but I'm hoping we will have 1.0.7 pushed out by the end of the week.

  6. #6
    Join Date
    2014-Jun
    Posts
    4
    haha well, no wonder it wouldn't work for me, i was wondering why everyone elses distro actually said rpi in its name and the ones i was downloading didnt. im new to rpi so the arm architecture is new to me. and since the other downloads said arm in the name i assumed i had the right fine. i havent tried it yet but i feel way more confident about it working. ill let you know if it works out. thanks again.

    surely i cant be the only person who has made that mistake. im surprised with all the searching i did i didnt stumble across that page.

    Edit: no clue,

    ?^lol
    Last edited by martymcfly; 2014-06-05 at 23:14.

  7. #7
    Join Date
    2014-Jun
    Posts
    1
    I collected several guides for raspberry PI. You can use it.http://turbobit.net/download/folder/1607073

  8. #8
    Join Date
    2014-Feb
    Posts
    244
    Are those all freely available books? The names of some make it seem like they should be purchased and not just downloaded.

Similar Threads

  1. Replies: 1
    Last Post: 2017-05-20, 23:46
  2. Replies: 10
    Last Post: 2015-12-18, 12:56
  3. *HELP* Problems with Kali Linux and Windows 8.1
    By KomninosK in forum Installing Archive
    Replies: 1
    Last Post: 2015-05-21, 04:31
  4. Kali Linux & Windows 8.1 - Installing Problems
    By jlucasp25 in forum Installing Archive
    Replies: 0
    Last Post: 2014-09-07, 15:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •