I'm attempting to setup a VPN on my Samsung Chromebook. I'm booting Kali Linux from a USB. Now, before people start yelling at me to search the forums and try google: this has been a problem for almost a week. I have done those things. So read this first, and then suggest.

Here's what I've done:

I ran the following the commands to get VPN access:

apt-get install network-manager-openvpn-gnome
apt-get install network-manager-pptp
apt-get install network-manager-pptp-gnome
apt-get install network-manager-strongswan
apt-get install network-manager-vpnc
apt-get install network-manager-vpnc-gnome
/etc/init.d/network-manager restart

Alright, everything looks good, I can finally access the VPN settings. So I jump in there and do this:

1) Configure VPN

2) Add


4) Create

From here, I input the information. I've used multiple servers and none of them have worked, so choose your favorite and picture it.

I enable it for all users, I've played with the different possible settings. It never connects. I tell it to connect, it thinks, and then it says it's unable to connect.

So I tried using OpenVPN. I download the .ovpn files, import them into the network manager, and it fails to important the certificates, so I can't connect.

Any help is greatly appreciated.