Page 38 of 38 FirstFirst ... 28363738
Results 371 to 376 of 376

Thread: (Guide) Installing Nvidia + Bumblebee + CUDA for Optimus enabled Laptops

  1. #371
    Junior Member
    Join Date
    Dec 2016
    Quote Originally Posted by unknown1995 View Post
    This tutorial works on kali 2016.2 rolling and both nvidia and Cuda will install
    - bumblebee dont start itself
    ---- bumblebeed -D (to start it)
    - Cuda installation problem(i installed it from run file) file missing
    ---sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/ (jjust create link)
    -----Can't locate in @INC
    ---Do this it will work
    1. unpack .run file ./cuda*.run --tar mxvf
    2. copy to /usr/lib/x86_64-linux-gnu/perl-base
    3. export $PERL5LIB

    Follow the steps provided in tutorial it will work
    This is tempting but I'm a bit hesitant only because thrice it has forced me to completely reinstall Kali, my own fault for not creating a backup but I've hit a wall when it won't install the dep as well. I don't recall the repo source I used to get dep to install. Even though it worked once, I never was able to get it to set my Nvidia card as the main card for use.

  2. #372
    Junior Member
    Join Date
    Nov 2016
    I had a 2010's GPU (a 330m notebook) does the cuda toolkit 7.5 support it?...The appropriate driver should be version 340.xx and on Nvidia page is listed they supports cuda toolkit 6.5

  3. #373
    Junior Member
    Join Date
    Jul 2015
    I succesfully installed Nvidia driver with Bumblebee and CUDA 8.0 but when I try to run optirun hashcat -b I get this error:

    hashcat (v3.30) starting in benchmark mode...

    clGetDeviceIDs(): CL_DEVICE_NOT_FOUND

    clGetDeviceIDs(): CL_DEVICE_NOT_FOUND

    No devices found/left

    Started: Fri Feb 24 16:01:02 2017
    Stopped: Fri Feb 24 16:01:02 2017
    optirun glxgears output:

    14130 frames in 5.0 seconds = 2825.824 FPS
    optirun ./deviceQuery output:

    ./deviceQuery Starting...

    CUDA Device Query (Runtime API) version (CUDART static linking)

    Detected 1 CUDA Capable device(s)

    Device 0: "GeForce GT 750M"
    CUDA Driver Version / Runtime Version 8.0 / 8.0
    CUDA Capability Major/Minor version number: 3.0
    Total amount of global memory: 4038 MBytes (4233953280 bytes)
    ( 2) Multiprocessors, (192) CUDA Cores/MP: 384 CUDA Cores
    GPU Max Clock rate: 1085 MHz (1.09 GHz)
    Memory Clock rate: 900 Mhz
    Memory Bus Width: 128-bit
    L2 Cache Size: 262144 bytes
    Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
    Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
    Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
    Total amount of constant memory: 65536 bytes
    Total amount of shared memory per block: 49152 bytes
    Total number of registers available per block: 65536
    Warp size: 32
    Maximum number of threads per multiprocessor: 2048
    Maximum number of threads per block: 1024
    Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
    Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
    Maximum memory pitch: 2147483647 bytes
    Texture alignment: 512 bytes
    Concurrent copy and kernel execution: Yes with 1 copy engine(s)
    Run time limit on kernels: Yes
    Integrated GPU sharing Host Memory: No
    Support host page-locked memory mapping: Yes
    Alignment requirement for Surfaces: Yes
    Device has ECC support: Disabled
    Device supports Unified Addressing (UVA): Yes
    Device PCI Domain ID / Bus ID / location ID: 0 / 1 / 0
    Compute Mode:
    < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

    deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 8.0, CUDA Runtime Version = 8.0, NumDevs = 1, Device0 = GeForce GT 750M
    Result = PASS

  4. #374
    Junior Member
    Join Date
    Nov 2015
    Try hashcat 3.10

  5. #375
    Join Date
    May 2013
    Quote Originally Posted by Cricco95 View Post
    I succesfully installed Nvidia driver with Bumblebee and CUDA 8.0 but when I try to run optirun hashcat -b I get this error:

    optirun glxgears output:

    optirun ./deviceQuery output:
    I had the same issue and fixed it .
    first : I installed the driver 375.39 and cuda 8.0 from the repository . my GPU is Gt-740M
    if you installed Cuda from the repository . it's saved as nvidia-cuda-toolkit in /usr/lib/nvidia-cuda-toolkit.
    you need to create a symbolic link in /usr/local/ that points to the path of cuda-toolkit .
    ln -s /usr/lib/nvidia-cuda-toolkit  /usr/local/cuda
    if you are not root add sudo .
    follow the first post to set $PATH in bashrc and path use cuda instead of cudaxxx version. because of the symlink above.

    now the issue I came across was. in bumblebee.conf if I set the kernel-driver as nvidia-current . pyrit and hashcat don't work .
    so I created a symbolic link (shortcut) to the kernel modules as nvidia and nvidia-uvm just like when you install it with the driver from Nvidia's website.
    ln -s /lib/modules/4.9.0-kali3-amd64/updates/dkms/nvidia-current.ko /lib/modules/4.9.0-kali3-amd64/updates/dkms/nvidia.ko
    check your kernel version before running the commands

    ln -s /lib/modules/4.9.0-kali3-amd64/updates/dkms/nvidia-current-uvm.ko /lib/modules/4.9.0-kali3-amd64/updates/dkms/nvidia-uvm.ko
    then I changed the bumblebee.conf in kernel-driver add nvidia instead of nvidia-current.
    reboot and everything works . even with the latest hashcat version.
    check with
    modinfo nvidia
    to see if the modules are well linked .

    another thing if you are having any issues with compiling cpyrit after you compiled pyrit (the main module)
    in cpyrit folder change the line in to be like this
      nvcc_cmd = NVCC + bit_flag + ' -ccbin clang'\
    it will compile successfully .

  6. #376
    Junior Member
    Join Date
    Jun 2017

    [SOLVED] Unable to login with X11 or GNOME after installing bumblebee

    I tried to followed the guide and apparently I have succeeded, since I'm getting a PASS result at the final steps.

    However, I am unable to log into the machine using the default System X11, or neither GNOME and GNOME Classic. Only GNOME with WAYLAND works.
    When I try to log in with the first 3 methods, after finish typing in my credentials I just got loop back into the login Username screen again. Note this is without bumblebee running since it does not automatically start on boot.

    After starting bumblebee, right after finishing logging in the screen freeze, but I can still access tty. This is similar to when the Nvidia drivers were not installed correctly.

    I have successfully installed official Nvidia driver previously to installing bumblebee, as I do not know if bumblebee need Nvidia drivers already in place to function or not. The guide that I followed to install official Nvidia drivers is here:

    So if anyone know what I should do please let me know. I appreciate it a lot.

    Thank you staticn0de for an awesome guide and anyone who takes the time to help.


    I have been able to solve this by following staticn0de post in this thread. All you need to do to be able to use X11 and GNOME again is deleting the file xorg.conf at /etc/X11/

    There is still a slight issue however for those who wants to use GNOME on Wayland. If you login using Wayland, the terminal will have a black box around it. This problem is persistent before and after the GNOME fix I mentioned above. Though it is only a minor inconvenience and it only affects the terminal.
    Last edited by chaopac; 2017-06-20 at 04:48 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts