Page 1 of 38 12311 ... LastLast
Results 1 to 10 of 376

Thread: (Guide) Installing Nvidia + Bumblebee + CUDA for Optimus enabled Laptops

  1. #1
    Senior Member
    Join Date
    Apr 2014
    Down Under

    (Guide) Installing Nvidia + Bumblebee + CUDA for Optimus enabled Laptops

    Updated for Kali 2.0 Sana

    Hey guys, I'm rewriting this to use the repo as Kali Sana looks to have up-to-date nvidia drivers straight out of the gate.

    NVIDIA Driver 352.21
    CUDA 7.5.18 (the repo has 6.0.37-5, it's a bit old so I'm manually installing 7.5.18)
    VirtualGL 2.4.90
    Pyrit v308 (optional)
    cudaHashcat (optional)
    Couple of points

    1. This guide and all GPU passthrough software such as cuda_pyrit and cudahashcat will never work if run from within a Virtual Machine. Please don't post that it does not work for you in a VM because you should have read this.

    2. I'm going to assume that you are either on a fresh install of Kali or have the skills to clean up any conflicting software.

    3. I run 64bit software. If you don't, change the files you download to match what you use. (Edit: CUDA does not support 32bit anymore)

    4. If you have any issues or if something does not work, follow the template linked here and post the results of all commands.

    Lets get started.

    1. Update Kali
    apt-get update && apt-get upgrade && apt-get dist-upgrade
    2. Download VirtualGL and install it. Grab the latest non-beta
    Install with:
    cd ~
    dpkg -i virtualgl*.deb
    3. Download CUDA 7.5. Grab the x64 or 14.04 *.run file (should be 1.1gb)
    5. Install linux headers for your kernel
    apt-get install linux-headers-$(uname -r)
    6. Install dependencies we will need later. The first two are for CUDA and the last is for pyrit
    apt-get install freeglut3-dev libxmu-dev libpcap-dev
    7. Update system PATH. Notice that the PATH references CUDA 7.5. If you have a different version, change it to match.
    nano ~/.bashrc
    Add the following line and then save and close bashrc
    export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-7.5/bin
    8. Export the system path. We export the path from terminal so we can take advantage of it without restart. Run the following in terminal
    export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-7.5/bin
    9. Install bumblebee-nvidia and primus. Just press enter when the messages appear and ignore the warning about rrmod.
    apt-get install bumblebee-nvidia primus
    10. Edit the bumblebee config file so bumblebee knows we are using the NVIDIA driver. Change the 'Driver=' value. Should be line 22. The module from the repo driver is 'nvidia-current' but we set 'nvidia' here so that the nvidia section of bumblebee.conf is called.
    nano +22 /etc/bumblebee/bumblebee.conf
    Make it read:
    check line 55 and make sure it reads:
    Save and close
    11. Run the following and record the PCI address of your video card. It will look similar to 03:00.0
    lspci | egrep 'VGA|3D'
    12. Edit the xorg.conf.nvidia file so it knows the PCI address of your video card. Note that the last group of numbers is now seperated with a ":" instead of a ".". We are editing under the area 'Section "Device"'
    nano /etc/bumblebee/xorg.conf.nvidia
    Section "Device"
    Identifier "DiscreteNvidia"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BusID "PCI:03:00:0"
    14. Reboot
    shutdown -r now
    15. Now we have restarted, test the driver. glxsheres64 will test the driver and modinfo nvidia will show the version loaded.
    optirun glxspheres64
    modinfo nvidia
    16. Prepare CUDA for install
    cd ~
    chmod +x cuda*.run
    17. Run the CUDA install
    Accept the EULA
    Select yes to unsupported configuration
    No to graphics driver
    Yes to the toolkit
    Accept default location
    Yes to symbolic link
    Yes to samples
    Yes to default samples location
    The toolkit will install
    18. Set up the dynamic linker for CUDA. Notice that this is slightly different than the path added for .bashrc
    nano /etc/
    Match the contents below
    include /etc/*.conf
    19. Excute the following to load our changes
    20. Install libcuda1. You will get an incorrect driver version error if you don't.
    apt-get install libcuda1
    21. Build the NVIDIA samples so we can confirm CUDA is working with optirun
    cd /root/NVIDIA_CUDA-7.5_Samples/1_Utilities/deviceQuery/
    22. Run deviceQuery and then post your pass! If you see a pass, it all worked out! If not, follow the link at the start of the guide and post everything asked.
    optirun ./deviceQuery
    Last edited by staticn0de; 2015-12-13 at 08:19 PM.

  2. #2
    Senior Member
    Join Date
    Apr 2014
    Down Under
    Optional Installs - cudaHashcat and Pyrit

    This section is for optional installs. If you installed CUDA on Kali, Im tipping these are both applications you are interested in.


    1. If you have any issues installing any of this, post the complete output of any commands entered.


    You have two options, download the archive from the hashcat website and install it manually (sorry, I'm not going into that. If you need instructions, check their wiki)

    The second option is download my deb file. You can install it with a single command and then call cuda hashcat with either 'cudahashcat64' (for 64bit) or 'cudahashcat32' (for 32bit). Grab and install it from the link below.

    While some forum members make use of my deb, I am not a member of either the hashcat team or the Kali dev team. I could have edited the contents of the deb in any way (including maliciously). Take care when downloading from unknown sources. I provide no warranty and do not claim that it is fit for any purpose, including that which it is intended.

    I repackaged the hashcat binary in accordance with their EULA so it would install easily on Kali. I also removed non-linux binaries.

    1. cudahashcat 2.01
    dpkg -i cudahashcat-2.01.deb
    2. cudahashcat 1.36
    dpkg -i cudahashcat-1.36.deb
    3. cudahashcat 1.35
    dpkg -i cudahashcat-1.35.deb
    4. cudahashcat 1.34
    dpkg -i cudahashcat-1.34.deb
    5. cudahashcat 1.33
    dpkg -i cudahashcat-1.33.deb
    6. cudahashcat 1.31 (seems to be faster than 1.33)
    dpkg -i cudahashcat-1.31.deb
    The deb sums are
    cudahashcat 2.01
    md5sum = 69a9289e05a6e4b25728d5738a48f76c
    cudahashcat 1.36
    md5sum = f4ea04116a8495ea3e850fc993220554
    cudahashcat 1.35
    md5sum = ccdc7ebf4c4a947d14fa663a982e3c10
    cudahashcat 1.34
    md5sum = e611e16ab1f3c42c5e98d3ef615a0cd4
    cudahashcat 1.33
    md5sum = 82f4975f02af1288de058c93552b981d
    cudahashcat 1.31
    md5sum = b753c393264b3c40e51f057a96f3f6e9
    Test it with
    optirun cudahashcat64 -t 32 -a 7 example0.hash ?a?a?a?a example.dict
    To remove it
    dpkg -r cudahashcat-2.01
    and check the following directories and files are removed
    /usr/bin/cudahashcat32 (file)
    /usr/bin/cudahashcat64 (file)
    /usr/share/cudahashcat (directory)

    The following instructions are slightly modified from the pyrit google code page here
    1. Move to your home directory (I'm installing it there) and then check out the pyrit trunk
    cd ~
    svn checkout pyrit_svn
    2. Build and install pyrit
    cd pyrit_svn/pyrit/
    python build
    python install
    3. Add CUDA support
    cd ../cpyrit_cuda/
    python build
    python install
    4. Test pyrit
    optirun pyrit benchmark
    Last edited by staticn0de; 2015-12-13 at 10:03 PM.

  3. #3
    Senior Member
    Join Date
    Apr 2014
    Down Under
    Reporting your issues

    Most issues people have are a simple typo in their config files. Double check them before posting. I know this is a lot of commands to go through, but many users are new and experience delays in posting. Not giving enough information can result in multiple day turn arounds.

    1. Use the [*CODE] brackets to paste the output of commands (the open and close code brackets are [*CODE] and [*/CODE] without the *. Put all the text between them.

    Commands to execute

    lspci | egrep 'VGA|3D'
    modprobe nvidia
    modprobe nvidia-uvm
    optirun glxspheres64
    dmesg | tail -n 100
    echo $PATH
    cat /etc/bumblebee/bumblebee.conf
    cat /etc/bumblebee/xorg.conf.nvidia
    service bumblebeed restart
    modinfo nvidia
    find 2> /dev/null / -name nvidia*.ko
    Last edited by staticn0de; 2015-02-17 at 08:38 AM.

  4. #4
    Senior Member
    Join Date
    Aug 2013
    lost in space

    Links for OFF-Line installation

    Great guide staticn0de!

    - This post edited with download links for an OFF-Line installation on Kali 1.1.0 -

    Download CUDA, VirtualGL, Nvidia, CudaHashcat, from previous posts above.
    This does not include Kali Linux updates or Headers. Just the extra packs required for this guide.
    All links point to Debian wheezy(stable) packages whenever possible or equivalent/default.
    • Scroll down the page at Debian and choose your architecture under "Download".
    • Choose a server to download from.

    All packs go in Home, the /root directory. Remove them when installation is done.
    Install from root with
    dpkg -i name.deb

    (6.) Download and Install dependencies for CUDA and Pyrit.





    (9.) Download and Install bumblebee and primus.

    linux-headers (another "linux headers")(mine was linux-headers-amd64_3.18+63+kali2.1_amd64.deb)






    Optional. Download and Install Pyrit and add-on for Nvidia CUDA.

    pyrit_svn 0.4.1-dev svn r308

    From Linux, enter in a console;
    svn checkout pyrit_svn
    That will download a folder in /root (Home) named, pyrit_svn
    That folder is pyrit 0.4.1 svn r308. You can then save that folder for later off-line installations.

    Built and install Pyrit and add CUDA support.

    cd pyrit_svn/pyrit/
    python build
    python install
    cd ../cpyrit_cuda/
    python build
    python install

    Total: 11 packs. 2,05 Mb
    Last edited by Quest; 2015-03-13 at 03:57 AM.
    Kali Linux USB Installation using LinuxLive USB Creator
    Howto Install HDD Kali on a USB Key
    Clean your laptop fan | basic knowledge

  5. #5
    Senior Member
    Join Date
    Apr 2014
    Down Under
    Quote Originally Posted by Quest View Post
    Great guide staticn0de!

    Everyting worked well, until...

    my output was

    Any advice?

    Many thanks staticn0de I'm getting closer!
    I'm not sure what's causing that, but let's see if we can get you sorted out.

    To start, run:
    diff /usr/src/nvidia-current-331.67/Module.symvers /usr/src/nvidia-current-331.67/uvm/Module.symvers

    Any feedback from the above command means you need to delete the Module.symvers from the folder on the right and copy from the directory on the left into the directory on the right again. Once copied, run make in the uvm/ folder and copy it to /lib/modules/3.14-kali1-amd64/updates/dkms/

    Post the feedback from below:
    echo $PATH

    Post the feedback from:
    cat /etc/modprobe.d/nvidia.conf

    Post the feedback from:
    ls /lib/modules/3.14-kali1-amd64/updates/dkms

    Run modprobe nvidia-uvm and then run dmesg right after. Post the output in code brackets.

    Run lsmod and post output in code brackets

    You could also try modprobe nvidia and then modprobe nvidia-current and then modprobe nvidia-uvm

    Edit: Some other cool stuff you could try is a:
    depmod -a
    modprobe nvidia-uvm

    and then post the output of:
    cat /lib/modules/3.14-kali1-amd64/modules.dep | grep -i nvidia
    Last edited by staticn0de; 2014-07-08 at 07:09 AM.

  6. #6
    Senior Member
    Join Date
    Aug 2013
    lost in space
    the odds are that it was the operator(me), though I would like to reassure you that I fallowed your guide precisely, on a fresh installation of Kali 1.0.7 x64. I can even point out a small mistake in a syntax(induced by LibreOffice auto correction)
    First, install the linux headers. We need this so we can compile bbswitch later
    apt-get install linux-headers-$(uname –r)
    I did however strugeled alot with the nano console, as I did not know how to save changes. Save with F2, then Y, then "File Name to Write: xxxxxx, Enter

    Last night I decided to re-install, so I will do it again, then if I still encounter the same problem, I will proceed with post#5 and report back.

    Thank you my friend
    Last edited by Quest; 2014-07-08 at 02:29 PM.
    Kali Linux USB Installation using LinuxLive USB Creator
    Howto Install HDD Kali on a USB Key
    Clean your laptop fan | basic knowledge

  7. #7
    Senior Member
    Join Date
    Apr 2014
    Down Under
    Good pickup! I've fixed it now.

    As for nano, control + x, then y and then enter will save your changes and then close the file.

  8. #8
    Senior Member
    Join Date
    Aug 2013
    lost in space
    Exact ame results as yesterday.

    root@kali:~# rm /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko
    root@kali:~# cp /usr/src/nvidia-current-331.67/uvm/nvidia-uvm.ko /lib/modules/3.14-kali1-amd64/updates/dkms/
    root@kali:~# modprobe nvidia-uvm
    ERROR: could not insert 'nvidia_uvm': No such device
    i ran into this last night when search for a possible solution. This is recent 2 May 2014. Could there be a bug with versions nvidia-graphics-drivers/331.67-1, nvidia-graphics-drivers/331.67-2, nvidia-graphics-drivers/331.79-1 ? OpenCL not supported by lastest NVIDIA driver

    These are the my outputs:

    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
    01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630M] (rev ff)
    root@kali:~# optirun glxspheres64 
    Polygons in scene: 62464
    Visual ID of window: 0x21
    Context is Direct
    OpenGL Renderer: GeForce GT 630M/PCIe/SSE2
    243.416053 frames/sec - 204.644744 Mpixels/sec
    246.672039 frames/sec - 207.382117 Mpixels/sec
    195.415671 frames/sec - 164.289863 Mpixels/sec
    170.460050 frames/sec - 143.309173 Mpixels/sec
    171.786163 frames/sec - 144.424063 Mpixels/sec
    167.925432 frames/sec - 141.178269 Mpixels/sec
    166.438969 frames/sec - 139.928570 Mpixels/sec
    168.091304 frames/sec - 141.317721 Mpixels/sec
    171.926627 frames/sec - 144.542154 Mpixels/sec
    170.618800 frames/sec - 143.442638 Mpixels/sec
    168.957864 frames/sec - 142.046256 Mpixels/sec
    174.145734 frames/sec - 146.407802 Mpixels/sec
    172.519375 frames/sec - 145.040489 Mpixels/sec
    169.868780 frames/sec - 142.812081 Mpixels/sec
    = Summary =
    Driver:   Not Selected
    Toolkit:  Installed in /usr/local/cuda-5.5
    Samples:  Installed in /root/NVIDIA_CUDA-5.5_Samples
    * Please make sure your PATH includes /usr/local/cuda-5.5/bin
    * Please make sure your LD_LIBRARY_PATH
    *   for 32-bit Linux distributions includes /usr/local/cuda-5.5/lib
    *   for 64-bit Linux distributions includes /usr/local/cuda-5.5/lib64:/lib
    * OR
    *   for 32-bit Linux distributions add /usr/local/cuda-5.5/lib
    *   for 64-bit Linux distributions add /usr/local/cuda-5.5/lib64 and /lib
    * to /etc/ and run ldconfig as root
    * To uninstall CUDA, remove the CUDA files in /usr/local/cuda-5.5
    * Installation Complete
    Please see CUDA_Getting_Started_Linux.pdf in /usr/local/cuda-5.5/doc/pdf for detailed information on setting up CUDA.
    root@kali:~# rm /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko
    root@kali:~# cp /usr/src/nvidia-current-331.67/uvm/nvidia-uvm.ko /lib/modules/3.14-kali1-amd64/updates/dkms/
    root@kali:~# modprobe nvidia-uvm
    ERROR: could not insert 'nvidia_uvm': No such device
    - CONTENT OF dkms.conf -
    # DKMS configuration for the NVIDIA kernel module.  -*- sh -*-
    # The version is replaced at build time by dh_dkms invoked in debian/rules.
    MAKE[0]="env CCACHE_DISABLE=1 \
        make -C . SYSSRC=${kernel_source_dir}"
    CLEAN="make -C . SYSSRC=${kernel_source_dir} clean"
    MAKE[0]+="; env CCACHE_DISABLE=1 \
        make -C uvm SYSSRC=${kernel_source_dir}"
    CLEAN+="; make -C uvm SYSSRC=${kernel_source_dir} clean"
    root@kali:~# diff /usr/src/nvidia-current-331.67/Module.symvers /usr/src/nvidia-current-331.67/uvm/Module.symvers
    root@kali:~# echo $PATH
    root@kali:~# cat /etc/modprobe.d/nvidia.conf
    alias nvidia nvidia-current
    remove nvidia-current rmmod nvidia
    root@kali:~# modprobe nvidia-uvm
    ERROR: could not insert 'nvidia_uvm': No such device
    root@kali:~#  lsmod 
    Module                  Size  Used by
    nls_utf8               12456  1 
    nls_cp437              16553  1 
    vfat                   17185  1 
    fat                    57965  1 vfat
    nfnetlink_log          17241  0 
    nfnetlink              12989  1 nfnetlink_log
    bbswitch               12866  0 
    binfmt_misc            16949  1 
    loop                   26605  0 
    dm_crypt               22731  0 
    joydev                 17108  0 
    snd_hda_codec_hdmi     45004  1 
    snd_hda_codec_realtek    54360  1 
    snd_hda_codec_generic    59079  1 snd_hda_codec_realtek
    btusb                  25619  0 
    bluetooth             243618  2 btusb
    6lowpan_iphc           16588  1 bluetooth
    x86_pkg_temp_thermal    12965  0 
    intel_powerclamp       17159  0 
    arc4                   12543  2 
    snd_hda_intel          39656  3 
    i915                  743012  2 
    snd_hda_codec          99921  4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
    iTCO_wdt               12831  0 
    iTCO_vendor_support    12649  1 iTCO_wdt
    snd_hwdep              13148  1 snd_hda_codec
    lpc_ich                20768  0 
    ir_rc6_decoder         12433  0 
    ir_jvc_decoder         12433  0 
    iwldvm                130998  0 
    mac80211              488308  1 iwldvm
    iwlwifi                87784  1 iwldvm
    drm_kms_helper         39998  1 i915
    drm                   240557  3 i915,drm_kms_helper
    i2c_algo_bit           12751  1 i915
    intel_rapl             17344  0 
    snd_pcm                88538  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
    snd_timer              26606  1 snd_pcm
    snd                    61039  14 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
    soundcore              13026  1 snd
    mei_me                 13446  0 
    i2c_i801               16963  0 
    mei                    50039  1 mei_me
    i2c_core               24265  5 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit
    cfg80211              436618  3 iwlwifi,mac80211,iwldvm
    ir_sony_decoder        12435  0 
    ir_sanyo_decoder       12437  0 
    ir_lirc_codec          12675  0 
    ir_mce_kbd_decoder     12574  0 
    ir_nec_decoder         12433  0 
    lirc_dev               16951  1 ir_lirc_codec
    ir_rc5_decoder         12433  0 
    coretemp               12854  0 
    kvm_intel             138949  0 
    kvm                   404503  1 kvm_intel
    rc_rc6_mce             12396  0 
    ene_ir                 21814  0 
    rc_core                18235  12 lirc_dev,ir_lirc_codec,ir_rc5_decoder,ir_nec_decoder,ir_sony_decoder,ene_ir,ir_mce_kbd_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_sanyo_decoder,rc_rc6_mce
    psmouse                86464  0 
    serio_raw              12849  0 
    evdev                  17489  13 
    rtsx_pci_ms            12802  0 
    memstick               13696  1 rtsx_pci_ms
    mxm_wmi                12515  0 
    toshiba_acpi           18063  0 
    sparse_keymap          12760  1 toshiba_acpi
    rfkill                 18902  5 cfg80211,toshiba_acpi,bluetooth
    toshiba_bluetooth      12641  0 
    battery                13101  0 
    processor              28221  0 
    ac                     12678  0 
    video                  17804  1 i915
    thermal_sys            27685  4 video,intel_powerclamp,processor,x86_pkg_temp_thermal
    wmi                    17339  2 toshiba_acpi,mxm_wmi
    button                 12944  1 i915
    ext4                  489943  1 
    crc16                  12343  2 ext4,bluetooth
    mbcache                13082  1 ext4
    jbd2                   86788  1 ext4
    dm_mod                 89276  1 dm_crypt
    hid_generic            12393  0 
    usbhid                 44481  0 
    hid                    94062  2 hid_generic,usbhid
    sg                     30043  0 
    sr_mod                 21898  0 
    cdrom                  39232  1 sr_mod
    sd_mod                 44346  5 
    crc_t10dif             12431  1 sd_mod
    usb_storage            52037  4 
    rtsx_pci_sdmmc         17076  0 
    mmc_core               93950  1 rtsx_pci_sdmmc
    crct10dif_pclmul       13348  1 
    crct10dif_common       12356  2 crct10dif_pclmul,crc_t10dif
    crc32_pclmul           12915  0 
    crc32c_intel           21809  0 
    ghash_clmulni_intel    12978  0 
    ahci                   29195  0 
    aesni_intel           151423  0 
    libahci                27103  1 ahci
    aes_x86_64             16719  1 aesni_intel
    lrw                    12757  1 aesni_intel
    gf128mul               12970  1 lrw
    glue_helper            12690  1 aesni_intel
    ablk_helper            12572  1 aesni_intel
    cryptd                 14560  3 ghash_clmulni_intel,aesni_intel,ablk_helper
    libata                169163  2 ahci,libahci
    scsi_mod              186841  5 sg,usb_storage,libata,sd_mod,sr_mod
    rtsx_pci               33623  2 rtsx_pci_ms,rtsx_pci_sdmmc
    mfd_core               12601  2 lpc_ich,rtsx_pci
    r8169                  64490  0 
    mii                    12675  1 r8169
    ehci_pci               12472  0 
    xhci_hcd              111830  0 
    ehci_hcd               48517  1 ehci_pci
    usbcore               166472  6 btusb,usb_storage,ehci_hcd,ehci_pci,usbhid,xhci_hcd
    usb_common             12440  1 usbcore
    root@kali:~# modprobe nvidia
    root@kali:~# modprobe nvidia-current
    ERROR: could not insert 'nvidia_current': No such device
    root@kali:~# modprobe nvidia-uvm
    ERROR: could not insert 'nvidia_uvm': No such device
    root@kali:~# depmod -a
    root@kali:~# cat /lib/modules/3.14-kali1-amd64/modules.dep | grep -i nvidia
    updates/dkms/nvidia-uvm.ko: updates/dkms/nvidia-current.ko kernel/drivers/i2c/i2c-core.ko
    updates/dkms/nvidia-current.ko: kernel/drivers/i2c/i2c-core.ko
    Kali Linux USB Installation using LinuxLive USB Creator
    Howto Install HDD Kali on a USB Key
    Clean your laptop fan | basic knowledge

  9. #9
    Senior Member
    Join Date
    Apr 2014
    Down Under
    I don't believe a bug is causing this as It's working here. Like all things linux, it will be a one liner somewhere that will fix it.

    Would you please post your /etc/bumblebee/bumblebee.conf and xorg.nvidia.conf in the same directory.

    The way it works is that nvidia-uvm depends on the nvidia-current module. We know that works because you can use optirun glxspheres.

    Did you have any useful dmesg feedback from after the modprobe?

    Did you add the cuda libraries and then run ldconfig? I'm sure you did, but I was just going through the feedback you posted (I assume you omitted doing it because I didn't ask for it)

    Hopefully we can get this sorted out soon

  10. #10
    Senior Member
    Join Date
    Aug 2013
    lost in space
    xD yes it definitely feels like the setup is missing a line somewhere.

    Here is the output of bumblebee.conf and xorg.conf.nvidia..

    # Configuration file for Bumblebee. Values should **not** be put between quotes
    ## Server options. Any change made in this section will need a server restart
    # to take effect.
    # The secondary Xorg server DISPLAY number
    # Should the unused Xorg server be kept running? Set this to true if waiting
    # for X to be ready is too long and don't need power management at all.
    # The name of the Bumbleblee server group name (GID name)
    # Card power state at exit. Set to false if the card shoud be ON when Bumblebee
    # server exits.
    # The default behavior of '-f' option on optirun. If set to "true", '-f' will
    # be ignored.
    # The Driver used by Bumblebee server. If this value is not set (or empty),
    # auto-detection is performed. The available drivers are nvidia and nouveau
    # (See also the driver-specific sections below)
    # Directory with a dummy config file to pass as a -configdir to secondary X
    ## Client options. Will take effect on the next optirun executed.
    # Acceleration/ rendering bridge, possible values are auto, virtualgl and
    # primus.
    # The method used for VirtualGL to transport frames between X servers.
    # Possible values are proxy, jpeg, rgb, xv and yuv.
    # List of paths which are searched for the primus when using
    # the primus bridge
    # Should the program run under optirun even if Bumblebee server or nvidia card
    # is not available?
    # Driver-specific settings are grouped under [driver-NAME]. The sections are
    # parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
    # detection resolves to NAME).
    # PMMethod: method to use for saving power by disabling the nvidia card, valid
    # values are: auto - automatically detect which PM method to use
    #         bbswitch - new in BB 3, recommended if available
    #       switcheroo - vga_switcheroo method, use at your own risk
    #             none - disable PM completely
    ## Section with nvidia driver specific options, only parsed if Driver=nvidia
    # Module name to load, defaults to Driver if empty or unset
    # colon-separated path to the nvidia libraries
    # comma-separated path of the directory containing and the
    # default Xorg modules path
    ## Section with nouveau driver specific options, only parsed if Driver=nouveau
    Section "ServerLayout"
        Identifier  "Layout0"
        Option      "AutoAddDevices" "false"
        Option      "AutoAddGPU" "false"
    Section "Device"
        Identifier  "DiscreteNvidia"
        Driver      "nvidia"
        VendorName  "NVIDIA Corporation"
        BusID	 "PCI:01:00:0"
    #   If the X server does not automatically detect your VGA device,
    #   you can manually set it here.
    #   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
    #   as you see in the commented example.
    #   This Setting may be needed in some platforms with more than one
    #   nvidia card, which may confuse the proprietary driver (e.g.,
    #   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
    #   BusID "PCI:01:00:0"
    #   Setting ProbeAllGpus to false prevents the new proprietary driver
    #   instance spawned to try to control the integrated graphics card,
    #   which is already being managed outside bumblebee.
    #   This option doesn't hurt and it is required on platforms running
    #   more than one nvidia graphics card with the proprietary driver.
    #   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
    #   If this option is not set, the new Xorg may blacken the screen and
    #   render it unusable (unless you have some way to run killall Xorg).
        Option "ProbeAllGpus" "false"
        Option "NoLogo" "true"
        Option "UseEDID" "false"
        Option "UseDisplayDevice" "none"

    I can't remember if I had any useful dmesg feedback from after the modprobe.

    I did add the cuda libraries and then run ldconfig. Yes. I can reinstall again and copy the info from ldconfig and modprobe if need be.

    Let me know if I can provide anything else for the investigation
    Last edited by Quest; 2014-07-09 at 02:28 AM.
    Kali Linux USB Installation using LinuxLive USB Creator
    Howto Install HDD Kali on a USB Key
    Clean your laptop fan | basic knowledge

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts