Page 2 of 38 FirstFirst 123412 ... LastLast
Results 11 to 20 of 376

Thread: (Guide) Installing Nvidia + Bumblebee + CUDA for Optimus enabled Laptops

  1. #11
    Senior Member
    Join Date
    Aug 2013
    Location
    lost in space
    Posts
    580
    you know what, everything is fine until that step..

    Now to fix the nvidia-uvm module (You don't know this yet, but it's broken.)

    cd /usr/src/nvidia-current-331.67
    make

    cp Module.symvers uvm/

    cd uvm/
    make
    Can you confirm that:
    1. capital 'M' in "Module.symvers uvm/" syntax
    2. the nvidia-uvm module is really broken, and needs fixing

    I will try without fixing tomorrow see what happens. Now I'm going to dream about using piryt and hashcat
    Kali Linux USB Installation using LinuxLive USB Creator
    Howto Install HDD Kali on a USB Key
    Clean your laptop fan | basic knowledge

  2. #12
    Senior Member
    Join Date
    Aug 2013
    Location
    lost in space
    Posts
    580
    Nevermind the above post.


    After a 3rd reinstall. Same results.

    Here are some interesting bits, that might have nothing to do with it(?)

    Code:
    root@kali:~# uname -r
    3.14-kali1-amd64
    
    
    
    
    
    depmod....
    
    DKMS: install completed.
    Setting up nvidia-driver (331.67-2kali1) ...
    Setting up bumblebee-nvidia (3.2.1-4~bpo70+1) ...
    update-alternatives: using /usr/lib/mesa-diverted to provide /usr/lib/glx (glx) in manual mode
    [ ok ] Restarting bumblebeed: bumblebeed.
    Processing triggers for initramfs-tools ...
    update-initramfs: Generating /boot/initrd.img-3.14-kali1-amd64
    cryptsetup: WARNING: failed to detect canonical device of /dev/sdb5
    331.67-2 !!?? There are two version of the same. Really?

    Code:
    root@kali:~# apt-get install nvidia-glx
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following NEW packages will be installed:
      nvidia-glx
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 119 kB of archives.
    After this operation, 158 kB of additional disk space will be used.
    Get:1 http://http.kali.org/kali/ kali/non-free nvidia-glx amd64 331.67-2kali1 [119 kB]
    Fetched 119 kB in 6s (19.1 kB/s)                                                                   
    Selecting previously unselected package nvidia-glx.
    (Reading database ... 343139 files and directories currently installed.)
    Unpacking nvidia-glx (from .../nvidia-glx_331.67-2kali1_amd64.deb) ...
    Setting up nvidia-glx (331.67-2kali1) ...
    root@kali:~#
    Code:
    root@kali:~# apt-get install nvidia-glx
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following NEW packages will be installed:
      nvidia-glx
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 119 kB of archives.
    After this operation, 158 kB of additional disk space will be used.
    Get:1 http://http.kali.org/kali/ kali/non-free nvidia-glx amd64 331.67-2kali1 [119 kB]
    Fetched 119 kB in 6s (19.1 kB/s)                                                                   
    Selecting previously unselected package nvidia-glx.
    (Reading database ... 343139 files and directories currently installed.)
    Unpacking nvidia-glx (from .../nvidia-glx_331.67-2kali1_amd64.deb) ...
    Setting up nvidia-glx (331.67-2kali1) ...
    root@kali:~# 
    
    
    
    
    root@kali:~# lspci | egrep 'VGA|3D'
    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
    01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630M] (rev ff)
    root@kali:~# 
    
    
    
    
    root@kali:~# apt-get install libcuda1
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following extra packages will be installed:
      nvidia-smi
    Suggested packages:
      nvidia-cuda-mps
    Recommended packages:
      libcuda1-i386
    The following NEW packages will be installed:
      libcuda1 nvidia-smi
    0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    Need to get 5,688 kB of archives.
    After this operation, 14.5 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://http.kali.org/kali/ kali/non-free libcuda1 amd64 331.67-2kali1 [5,480 kB]
    Get:2 http://http.kali.org/kali/ kali/non-free nvidia-smi amd64 331.67-2kali1 [207 kB]             
    Fetched 5,688 kB in 31s (178 kB/s)                                                                 
    Selecting previously unselected package libcuda1:amd64.
    (Reading database ... 343147 files and directories currently installed.)
    Unpacking libcuda1:amd64 (from .../libcuda1_331.67-2kali1_amd64.deb) ...
    Selecting previously unselected package nvidia-smi.
    Unpacking nvidia-smi (from .../nvidia-smi_331.67-2kali1_amd64.deb) ...
    Processing triggers for man-db ...
    Setting up libcuda1:amd64 (331.67-2kali1) ... 
    Setting up nvidia-smi (331.67-2kali1) ...
    root@kali:~# 
    
    
    CUDA 
    
    Do you accept the previously read EULA? (accept/decline/quit): accept
    You are attempting to install on an unsupported configuration. Do you wish to continue? ((y)es/(n)o) [ default is no ]: y
    Install NVIDIA Accelerated Graphics Driver for Linux-x86_64 319.37? ((y)es/(n)o/(q)uit): n
    Install the CUDA 5.5 Toolkit? ((y)es/(n)o/(q)uit): y
    Enter Toolkit Location [ default is /usr/local/cuda-5.5 ]: 
    Install the CUDA 5.5 Samples? ((y)es/(n)o/(q)uit): y
    Enter CUDA Samples Location [ default is /root/NVIDIA_CUDA-5.5_Samples ]: 
    Installing the CUDA Toolkit in /usr/local/cuda-5.5 ...
    
    WAIT.............
    
    
    ===========
    = Summary =
    ===========
    
    Driver:   Not Selected
    Toolkit:  Installed in /usr/local/cuda-5.5
    Samples:  Installed in /root/NVIDIA_CUDA-5.5_Samples
    
    * Please make sure your PATH includes /usr/local/cuda-5.5/bin
    
    * Please make sure your LD_LIBRARY_PATH
    *   for 32-bit Linux distributions includes /usr/local/cuda-5.5/lib
    *   for 64-bit Linux distributions includes /usr/local/cuda-5.5/lib64:/lib
    * OR
    *   for 32-bit Linux distributions add /usr/local/cuda-5.5/lib
    *   for 64-bit Linux distributions add /usr/local/cuda-5.5/lib64 and /lib
    * to /etc/ld.so.conf and run ldconfig as root
    
    * To uninstall CUDA, remove the CUDA files in /usr/local/cuda-5.5
    * Installation Complete
    
    
    
    
    
    
    root@kali:~# ldconfig
    root@kali:~# 
    NOTHING HAPPENS
    
    
    
    AFTER SETUP I RUN optirun glxspheres64 again and...
    
    
    root@kali:~# /etc/init.d/bumblebeed restart
    [ ok ] Restarting bumblebeed: bumblebeed.
    root@kali:~# optirun glxspheres64
    [10223.471114] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
    
    [10223.471198] [ERROR]Aborting because fallback start is disabled.
    root@kali:~#
    dmesg modprobe (Notice the interesting bit at the end):

    Code:
    root@kali:~# dmesg
    CANNOT POST THE WHOLE THING  
    
    ...
    [Package] (20131218/nsarguments-95)
    [ 6170.453345] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6170.453385] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6176.843757] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6178.305207] bbswitch: disabling discrete graphics
    [ 6178.305228] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6178.318591] pci 0000:01:00.0: Refused to change power state, currently in D0
    [ 6550.299909] bbswitch: enabling discrete graphics
    [ 6550.757766] bbswitch: disabling discrete graphics
    [ 6550.757788] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6561.213529] bbswitch: enabling discrete graphics
    [ 6561.651014] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns=none
    [ 6561.651157] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  331.67  Fri Apr  4 13:48:39 PDT 2014
    [ 6561.681517] nvidia 0000:01:00.0: irq 49 for MSI/MSI-X
    [ 6561.692369] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6561.692454] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6561.692501] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6561.692543] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6561.692584] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6561.692624] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6561.692690] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6561.692731] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6568.469916] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6657.371547] bbswitch: disabling discrete graphics
    [ 6657.371569] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
    [ 6657.384771] pci 0000:01:00.0: Refused to change power state, currently in D0
    [ 8142.331643] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns=none
    [ 8142.331723] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0de9)
    [ 8142.331723] NVRM: installed in this system is not supported by the 331.67
    [ 8142.331723] NVRM: NVIDIA Linux driver release.  Please see 'Appendix
    [ 8142.331723] NVRM: A - Supported NVIDIA GPU Products' in this release's
    [ 8142.331723] NVRM: README, available on the Linux driver download page
    [ 8142.331723] NVRM: at www.nvidia.com.
    [ 8142.331795] nvidia: probe of 0000:01:00.0 failed with error -1
    [ 8142.331853] NVRM: The NVIDIA probe routine failed for 1 device(s).
    [ 8142.331855] NVRM: None of the NVIDIA graphics adapters were initialized!
    [ 8142.332042] NVRM: NVIDIA init module failed!
    root@kali:~#
    Last edited by Quest; 2014-07-09 at 06:40 PM.
    Kali Linux USB Installation using LinuxLive USB Creator
    Howto Install HDD Kali on a USB Key
    Clean your laptop fan | basic knowledge

  3. #13
    Senior Member
    Join Date
    Aug 2013
    Location
    lost in space
    Posts
    580
    post too long continued here...

    The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0de9)
    installed in this system is not supported by the 331.67
    NVIDIA Linux driver release. Please see 'Appendix
    A - Supported NVIDIA GPU Products' in this release's
    README, available on the Linux driver download page
    OH really? Let's go and see...

    http://us.download.nvidia.com/XFree8...rtedchips.html

    Note that the list of supported GPU products provided below and on the driver download page is provided to indicate which GPUs are supported by a particular driver version. Some designs incorporating supported GPUs may not be compatible with the NVIDIA Linux driver: in particular, notebook and all-in-one desktop designs with switchable (hybrid) or Optimus graphics will not work if means to disable the integrated graphics in hardware are not available. Hardware designs will vary from manufacturer to manufacturer, so please consult with a system's manufacturer to determine whether that particular system is compatible.
    10de:0de9 is not supported by the 331.67 NVIDIA Linux driver release
    Last edited by Quest; 2014-07-09 at 06:51 PM.
    Kali Linux USB Installation using LinuxLive USB Creator
    Howto Install HDD Kali on a USB Key
    Clean your laptop fan | basic knowledge

  4. #14
    Member
    Join Date
    Mar 2013
    Location
    http://rastamouse.me
    Posts
    86
    This worked perfectly for me. Thanks staticn0de.
    OSCP
    --
    If it smells like a duck, walks like a duck and quacks like a duck; then it probably is a duck.

  5. #15
    Senior Member
    Join Date
    Aug 2013
    Location
    lost in space
    Posts
    580
    Let me understand something here... Why are we working with driver 331.67, and only that version. Is it because of bumblebee? (I'm quite stubborn and still looking for a solution, even within an obvious failure framework).

    In any case, thank you staticn0de
    Kali Linux USB Installation using LinuxLive USB Creator
    Howto Install HDD Kali on a USB Key
    Clean your laptop fan | basic knowledge

  6. #16
    Senior Member
    Join Date
    Apr 2014
    Location
    Down Under
    Posts
    315
    Quote Originally Posted by Quest View Post
    Let me understand something here... Why are we working with driver 331.67, and only that version. Is it because of bumblebee? (I'm quite stubborn and still looking for a solution, even within an obvious failure framework).

    In any case, thank you staticn0de
    Hi there Quest,

    You don't have to use that driver version. That is just what is in the wheezy backports repo.

    I have not tried a newer version on Kali (I've used 337 on Ubuntu with bumblebee - that had its own issues)

    To install a newer version, you will need to add the Jessie or Sid repo.

    Jessie is the testing repo and has the 337.19-1 driver under the name nvidia-driver or the transitional package Nvidia-glx.

    Sid is the unstable repo and has nvidia 331.79-1 under the same names as that above.

    These should work if you want to try them. I'm sure you understand how easily you can break Kali with unsupported repos (wheezy backports is not much better I'm sure)

    deb http://http.debian.net/debian sid main contrib non-free

    Or

    deb http://http.debian.net/debian jessie main contrib non-free

  7. #17
    Junior Member
    Join Date
    Jul 2014
    Posts
    3
    See this article I was very moved when I thank staticn 0. Thank you. notebook can be normal working the

  8. #18
    Senior Member
    Join Date
    Apr 2014
    Location
    Down Under
    Posts
    315
    For those interested, much to my amazement I was able to get Nvidia 340.24 working on Kali

    root@kali:/proc/driver/nvidia# cat version
    NVRM version: NVIDIA UNIX x86_64 Kernel Module 340.24 Wed Jul 2 14:24:20 PDT 2014
    GCC version: gcc version 4.7.2 (Debian 4.7.2-5)
    It was a bit of an "unclean" install as I kind of had to force it on there, but glxspheres64 and optirun is working. I'll try and get CUDA 6 working and keep you posted. If I get it, i'll clean up the process and post that too.

    Edit:

    It's looking promising!

    deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 6.5, CUDA Runtime Version = 6.0, NumDevs = 1, Device0 = GeForce GT 740M
    Result = PASS
    Last edited by staticn0de; 2014-07-11 at 10:24 AM.

  9. #19
    Junior Member
    Join Date
    Jul 2014
    Posts
    9
    staticn0de, thankyou for the work that went into this write up. It worked really well. I did have one issue but solved it here: https://wiki.archlinux.org/index.php/bumblebee
    Last edited by London; 2014-07-12 at 01:32 PM.

  10. #20
    Senior Member
    Join Date
    Aug 2013
    Location
    lost in space
    Posts
    580
    that's cool

    even though most can figure it out for themselves, I was thinking that maybe(?) it would be nice to have all the command lines, and links to, an OFF_LINE installation. There's nothing wrong with this procedure as is, but we already DLing CUDA (and now probly new NVIDIA drivers), so maybe DL everything and than install?

    I'm not a big fan of being dependent on the Internet for installations, for one, and I've had my connexion cut or network manager shut down my connexion while fallowing this guide more than once. Nothing bad happened as a result, but it made me think that I'd be better off-line.

    So without changing this guide(because it works beautifully), an 'off-Line Annex' would be appreciated. Just a link in the first post pointing to another post with the command lines/links to firstly DL everything and then the command lines to install from Home *if I have everything I need in Home maybe the whole installation can be scripted hmmm [evil laugh]* Just saying.
    Kali Linux USB Installation using LinuxLive USB Creator
    Howto Install HDD Kali on a USB Key
    Clean your laptop fan | basic knowledge

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •