Results 1 to 4 of 4

Thread: Kali not installing on Asus Transformer T100

  1. #1
    Join Date
    2014-Jul
    Posts
    2

    Kali not installing on Asus Transformer T100

    I'm trying to install Kali Linux (1.0.7) on my Asus Transformer T100, but not getting anywhere. I'm thinking it might be an issue with the Bay Trail CPU's? I first wanted to do a persistent usb boot. Since Kali doesn't support UEFI, this is a bit tricky. I disabled secure boot and changed the usb boot option. I then used Rufus to created a UEFI boot disk with Kali on. Also had to use a different bootloader (bootia32.efi). I could then actually get it booting to a Grub menu, but can't get the installation started.

    So I decided to rather try Virtualbox. With the 32bit version, the installation goes up to 80% and then gives me an installation error every time. With the 64bit version, it completes the installation, but then crash before the login screen on the first boot.

    Anyone else got Kali running on an Asus T100, or any advice on something I might be missing?

  2. #2
    Join Date
    2015-Dec
    Posts
    3
    I've been working on a similar problem and I've had some success. Here's my original post and I'll update with some more info on it later tonight so I'll briefly reply with some help for you:

    https://forums.kali.org/showthread.p...-One-Asus-T100

    In the meantime... could you reply with your T100 model number, version of windows 8/10 (and the bit). Also please post your grub.cfg (and the location you're saving that and the bootia32.efi file) and tell me which versions of Kali you've tried to USB boot.

    Ok for my brief answer to some of your questions, here's the progress I've had.

    I've got (actually had... I'm returning it for a partially unrelated reason) an Acer One 10 which uses the same processor and the procedures for putting kali on them (should be) identical. Anyway, I was able to USB Boot, USB Install, and Hard Drive Install so far. I've also been able to get Virtual Box up and running. For the USB Boot/ Installs the problem was entirely an issue between the UEFI Bootloader and the grub.cfg file. I was unable to boot a 64-bit Kali because the bootloader wouldn't permit it (even when trying rEFInd). 32-bit kali worked just fine although I had to recompile the kernal to get the keyboard up. My big problem came with HDD install because I couldn't delete the recovery partition without preventing windows from booting.

    As for virtualization, my suggestion is to make sure you're enabling PAE and using the extra extensions for virtual box using the extensions pack then later the addons pack. If your windows version is 32-bit I would probably not try using 64-bit ISO versions. If you want you can screenshot and post your configurations in the virtual machine and I can help you with that.

  3. #3
    Join Date
    2016-Sep
    Posts
    1
    I have just been completed this myself...
    I purchased a T100TAM-DK005T to set up as a Kali box, but didn't want to completely remove Win10 until the guarantee period is over XD
    So only playing with a 32GB eMMC makes it a little tricky
    First hurdle is turning of secure boot in the Bios - just mash F2 while powering the machine on and access the 'secure boot' option and select disabled.
    Next - boot into windows and run through the setup then disable bootlocker (comes enabled by default!) and allow the drive to de-crypt. If you don't do this Grub cannot install (obvious when you think about it, right?)
    While waiting for the disk decrypt you can burn the latest Kali x64 to a bootable USB (I used 2016.2) - once burnt you will need to add the x32 EFI files to the /EFI/boot/ folder on the USB drive you can get these at http://leb.ag/kali/EFI_asus_t100tam.zip
    Attach the USB to the tablet using a USB OTG cable and connect you favourite USB WiFi dongle to the USB on the docking station (I use the Edimax nano - works out of the box)
    Boot the device and again access the Bios - this time use the boot menu on the last page to boot from your USB - you should get the Kali live CD screen...
    NOTE - the only one of the options that didn't crash out immediately on me was the Text install option (not the Graphical installer as mentioned in the video!)
    Run through the Kali install as normal, but shrink the current Windows down by at least 12GB (10GB for ext4 and 2GB swap)
    Do not use the external drive for any drives you would like to auto-mount: this drive is in the docking station and you won't be able to use the device as a tablet if you do (Kali will not boot without the docking station attached!)
    Now complete the install like any other Kali install
    On reboot you will probably end up back in Windows unless you access the Bios again - this time you want to change the boot priority to boot Kali first.
    Bob's your uncle - you now have your very own Kali transformer.
    Not sure how it will perform under load, but OOTB support in Kali for the touchscreen, docking station, SD card reader and USB. Onboard WiFi doesn't have OOTB support but any Wireless dongle that works with Kali should work fine, and no onboard sound either, but I can live with that.
    Now to get some drivers for the Broadcom chipset if possible.
    Some advice came from watching a video on youtube (first in the list if you are searching for this subject) which is where I got the link to the EFI files above...

  4. #4
    Join Date
    2016-Oct
    Posts
    1

    always land in the minimal bash-like grub///

    I am trying to get Kali Live USB running on an ASUS T100TAF . Believe I need the bootia32.efi instead of the bbotx64.efi for this model? I tried running with different grub.cfg files but I always only seem to land in the minimal bash-like grub. What am I missing please?

Similar Threads

  1. I can't install Kali Linux on an ASUS Transformer Book T100H
    By Kozova1 in forum Installing Archive
    Replies: 3
    Last Post: 2016-03-09, 13:08
  2. Install Kali: Asus Transformer Book T100CHI-FG003B
    By Ericus in forum Installing Archive
    Replies: 0
    Last Post: 2015-09-19, 02:56
  3. asus transformer book t300 chi
    By mojtaba in forum General Archive
    Replies: 0
    Last Post: 2015-09-18, 13:57
  4. Kali Linux on Asus Transformer Book T100
    By @nonymous in forum Installing Archive
    Replies: 0
    Last Post: 2015-05-14, 17:12
  5. asus t100
    By shaberu in forum How-To Archive
    Replies: 0
    Last Post: 2014-07-30, 14:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •