Results 1 to 6 of 6

Thread: Installing on a Surface Pro (EFI issues)

  1. #1
    Join Date
    2013-Apr
    Posts
    3

    Question Installing on a Surface Pro (EFI issues)

    So, I am in the process of installing Kali Linux alongside Windows 8 on a Surface Pro. I have reached the point where I can run the installer, but it wont boot, which makes sense, since grub fails to install (it just boots into Windows). Here's how I get to that step.

    I have a 40GB (36.7GB) partition, and I let the installer automatically partition the space as follows:

    Code:
        Size	Type
        
        32.5 GB	ext4
        
        4.2 GB	swap

    So far, so good, I go to the next step and I get a warning message that says:

    No EFI partition was found
    and it gives me the option to go back, so I go back, and resize the partitions like this:

    Code:
        Size	Type
        32.5 GB	ext4
        4.0 GB	swap
        200MB	EFIboot
    So, now when I hit next, I get no warning about missing an EFI partition, and the OS begins to install. I can't configure a package manager since my wireless card is not supported out of the box, but I think that will be ok. I have the files I need on a thumb drive. However, eventually an error occurs that says:

    The 'grub-efi' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot.
    This message is indeed telling the truth, as it just boots into Windows. Does anyone know a good way to get around this? Basically, I need a way to install grub. Why does it fail to install the grub-efi package? Do I need to install that? Or is it possible to use a legacy boot system? I feel like I am a bit over my head here, as I consider myself somewhere between beginner and intermediate, but this EFI stuff is completely foreign to me. Where did I mess up? What should I try? Any help/advice is appreciated.

  2. #2
    Join Date
    2013-Mar
    Location
    outside Chicago IL
    Posts
    28
    EFI system partitions must be the first partition on the hard drive.

    Try the instructions at
    http://forums.kali.org/showthread.ph...highlight=uefi
    I like the bleeding edge, but I don't like blood loss!

  3. #3
    Join Date
    2013-Apr
    Posts
    3
    I actually have been using that post as my guide (thanks by the way) - I should have mentioned that. It was extremely helpful in actually being able to boot from a Kali USB. It just won't install grub-efi.

    Last night I even went as far as to fully remove Windows 8, and formatted the entire disk. When I create an EFI partition, even specifying the beginning of the drive, it creates 1MB free space partition right in front of it (at least, according to the GUI). Is this normal? I'm going to start over fresh when I get home from work today, but I fear that GRUB will continue to fail to install, and I'll be stuck with Windows/Ubuntu until someone smarter than me decides to try this with a Surface Pro. I'll post an update with the results of the fresh start later today.

    Update:

    • Formatted my USB
    • Used Universal USB installer copy the image to the drive
    • Downloaded BOOTX64.efi from the link you provided, and created grub.cfg as described
    • Created EFI/Boot/ on the root of the drive
    • Copied BOOTX64.efi and grub.cfg to the EFI/Boot/ folder
    • Booted up the Surface with the USB in (note that it would not boot at this point)


    Yesterday I copied grubx64.efi as described in these directions:

    http://forums.kali.org/showthread.ph...ull=1#post2566

    This allowed me to successfully boot from the USB drive yesterday, but I am in the same predicament with grub-efi failing. Note that I have already wiped the drive, so there is no need to worry about Windows any longer if that is a concern.
    Last edited by p337; 2013-04-16 at 23:49.

  4. #4
    Join Date
    2013-Mar
    Posts
    1
    You should be able to turn off secure boot following instructions on

    http://www.microsoft.com/surface/en-...-the-bios-uefi

    After that try booting with a new usb install without the efi steps

  5. #5
    Join Date
    2013-Mar
    Location
    outside Chicago IL
    Posts
    28
    You don't need grub-efi to be installed. grub-efi won't be installed to a usb thumb drive. If you are booting from the thumb drive to install to a local hard drive then setup the partition layout as I described and copy the boot folder from the thumb drive to the local hard drive fat32 partition.
    I like the bleeding edge, but I don't like blood loss!

  6. #6
    Join Date
    2013-Apr
    Posts
    3
    Thanks for your help. I have decided to return the Surface. It was not worth the headache of trying to get it to work. I am just not experienced enough to do that on my own, I suppose. At least not to be the only one doing it.

Similar Threads

  1. Installing on Surface 3 (non-pro)
    By SquidyP in forum Installing Archive
    Replies: 0
    Last Post: 2018-02-12, 03:46
  2. Installing and updating packages also installing kali repo issues.
    By gogito in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-08-15, 18:52
  3. installing Kali on Surface 3
    By koloss in forum Installing Archive
    Replies: 0
    Last Post: 2016-02-03, 18:13
  4. Surface Pro 3 WiFi Issues
    By codypilot in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-08-29, 20:03
  5. Surface Pro 2 Install issues
    By bbobbo177 in forum Installing Archive
    Replies: 0
    Last Post: 2014-07-24, 17:54

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •