Results 1 to 15 of 15

Thread: Touchpad Synaptics Tapping issue [Solved]

  1. #1
    Join Date
    2013-Mar
    Posts
    1

    Touchpad Synaptics Tapping issue [Solved]

    if you have issues with tapping function or scrolling function with your touchpad, then you can type the following in terminal to fix it

    Code:
    modprobe -r psmouse
    modprobe psmouse proto=imps

    to make the changes persistant create a file under /etc/modprobe.d with anyname.conf

    Code:
    options psmouse proto=imps
    followed the debian wiki at this link for this fix: http://wiki.debian.org/SynapticsTouchpad

  2. #2
    Join Date
    2013-Nov
    Posts
    2
    Thankx,, that was very helpfull for Me ........& it works

  3. #3
    Join Date
    2013-Nov
    Posts
    2
    My touchpad scrolling was working and my touchpad clicking wasn't working before I typed in

    modprobe -r psmouse
    modprobe psmouse proto=imps

    After I typed in those commands in my konsole my touchpad scrolling WASN'T working and my touchpad clicking WAS working. Does it matter that I typed those commands in KDE desktop? I apologize in advance if this is a stupid question :/

  4. #4
    Join Date
    2013-Nov
    Posts
    2
    Well, just in case someone had the same problem as me, I went to http://wiki.debian.org/SynapticsTouchpad like Audi-1 said and installed synaptics because I didn't have it installed. -_- After that I just went into system settings > input devices > touchpad to enable touchpad clicking. Hope this helps someone in the future!

  5. #5
    Join Date
    2013-Apr
    Posts
    3
    Big thumbs up!! Thanks

  6. #6
    thanks for your thread,.
    it's really helpfull,...and i tried it,...reallly work,..

    Thanks

  7. #7
    Join Date
    2014-May
    Posts
    10
    Quote Originally Posted by Audi-1 View Post
    if you have issues with tapping function or scrolling function with your touchpad, then you can type the following in terminal to fix it

    Code:
    modprobe -r psmouse
    modprobe psmouse proto=imps

    to make the changes persistant create a file under /etc/modprobe.d with anyname.conf

    Code:
    options psmouse proto=imps
    followed the debian wiki at this link for this fix: http://wiki.debian.org/SynapticsTouchpad
    Thx for your fix, works for me.

  8. #8
    Join Date
    2014-Aug
    Posts
    2
    no work, only detect one finger :/ after execute commands no show touchpad in panel xD...

  9. #9
    Join Date
    2014-Jan
    Location
    Ho Chi Minh City, VietNam
    Posts
    1
    Thank you very much !!!!!!!!!!!!!!

  10. #10
    Join Date
    2015-Jun
    Posts
    1
    Thank you very much

  11. #11
    Quote Originally Posted by Audi-1 View Post
    if you have issues with tapping function or scrolling function with your touchpad, then you can type the following in terminal to fix it

    Code:
    modprobe -r psmouse
    modprobe psmouse proto=imps

    to make the changes persistant create a file under /etc/modprobe.d with anyname.conf

    Code:
    options psmouse proto=imps
    followed the debian wiki at this link for this fix: http://wiki.debian.org/SynapticsTouchpad
    Thanks, These worked for tapping:
    Code:
    modprobe -r psmouse
    modprobe psmouse proto=imps
    But making changes peristant did not work. I made a file synaptics.conf in /etc/modprobe.d then ran the code
    Code:
    options psmouse proto=imps
    but it did not work.

    Plus tuchpad scrolling is not working any guidance in that regard?

  12. #12
    Join Date
    2016-Jan
    Posts
    1

    Even More Simple Then That

    delete this post
    Last edited by Time-Warp; 2016-01-19 at 16:12. Reason: delete this post i was wrong

  13. #13
    Join Date
    2016-Oct
    Posts
    1

    mouse fix is not permanent resets on every boot

    Quote Originally Posted by Zuhayer Tahir View Post
    Thanks, These worked for tapping:
    Code:
    modprobe -r psmouse
    modprobe psmouse proto=imps
    But making changes peristant did not work. I made a file synaptics.conf in /etc/modprobe.d then ran the code
    Code:
    options psmouse proto=imps
    but it did not work.

    Plus tuchpad scrolling is not working any guidance in that regard?

    help required same problem

  14. #14
    Join Date
    2016-Nov
    Posts
    1
    It's working but only if you dont't restart the pc, otherwise you must enter these commands again and again. Thanks anyway !

  15. #15
    Join Date
    2015-Feb
    Posts
    6
    This is what worked for me, I had too install xserver-xorg-input-synaptics,

    sudo apt-get install xserver-xorg-input-synaptics

    sudo leafpad /usr/share/X11/xorg.conf.d/70-synaptics.conf

    At the beginning of the file under Section “InputClass” add;

    Option "TapButton1" "1"

    It should look like this;

    Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    Option "TapButton1" "1"


    That's it, now after restarting the touchpad will work, the last step is optional to enable scrolling add;

    Option "VertEdgeScroll" "1"
    Option "HorizEdgeScroll" "1"

    Logout or reboot.
    Last edited by FaustNostromo; 2017-04-08 at 03:23.

Similar Threads

  1. Kali 64 Synaptics touchpad working very sensitive on MSI laptop
    By k4ro1nc in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-08-05, 12:18
  2. Vaio Duo synaptics touchpad not working
    By wtf in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-06-21, 03:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •