Results 1 to 4 of 4

Thread: Can't install Tor, browser crashing, 'failed to execute child process'

  1. #1
    Join Date
    2014-Jul
    Posts
    3

    Can't install Tor, browser crashing, 'failed to execute child process'

    Okay so I have a bunch of problems I'm hoping someone might be able to help me with. I'm running a Debian-based operating system, Kali Linux, on a dual boot on a disc on a Windows computer, and it's been really rough going.

    So first, I tried to install Tor, downloaded the file, saved it to my Desktop, and it wouldn't just open and run by double clicking like it usually does, saying "there is no application installed for tar archive (xz-compressed) files tor." So I looked online and followed some steps to extract it, with 'cd Desktop/' then 'tar -xvf (file name)', but instead of running properly it just read me back another input output error.

    But on top of that, just throughout using Linux, my Iceweasel keeps crashing, and when it's not crashing, it often won't start up, and there'll be an error that says:

    "Failed to execute child process "Iceweasel" (input/output error)"

    And sometimes I get the same error for even the terminal, so I can't even uninstall and reinstall Iceweasel or try running it from the Terminal. The only thing that sometimes works is restarting. But then I sometimes still get the input/output error for one of them.

    It just seems like this shouldn't be this hard, with this many errors that I can't really trace to anything. Could there be something wrong with my hard drive? I verified the disc and it otherwise looks graphically normal, it's just all these little things.

  2. #2
    Join Date
    2014-Aug
    Posts
    8
    just install Tor with Proxychains.

    first, go to /etc/apt and open sources.list in leafpad, then make sure these 2 lines of code are included in the file (don't remove one if there already is one in it)

    Code:
    deb http://http.kali.org/kali kali main non-free contrib
    Code:
    deb http://security.kali.org/kali-security kali/updates main contrib non-free
    if both of these are included in your sources.list, close and save it. then go ahead and open a terminal as root. then run this command to update apt:

    Code:
    apt-get update
    now try to install proxychains. by default it is already installed.

    Code:
    apt-get install proxychains
    if you have no errors or if it is already installed, go ahead and do the same with tor

    Code:
    apt-get install tor
    once tor is installed successfully, make sure the service is stopped by running this in your terminal:

    Code:
    service tor stop
    now go to your etc folder and open proxychains.conf in leafpad. then make sure this is added under ProxyList at the bottom (by default it is already if you isntalled tor first).

    Code:
    # add proxy here ...
    # meanwhile
    # defaults set to "tor"
    socks4 127.0.0.1 9050
    now start the tor service by running this in your terminal:

    Code:
    service tor start
    now you can run any program you want through tor by just addind proxychains before the program in your terminal!

    example:

    Code:
    proxychains iceweasel
    and now iceweasel will start while it is routing through Tor! go to http://www.whatismyip.com to see if your IP address is changed!

    hope this helped!

    greetings;
    Martijn1803

  3. #3
    Join Date
    2014-Jul
    Posts
    3
    Thank you for the really comprehensive help! I will definitely try that.

    But I was wondering do you have any idea what to do about the 'failed to execute child process' errors and Iceweasel and Terminal crashing so often? I read it might be an issue with hardware, but I don't really know where to start if that's the case. I just want Kali to start running more smoothly.

  4. #4
    Join Date
    2014-Aug
    Posts
    3
    There is a warning from Mike Perry (tor developer) that suggests you stay away from FoxyProxy.

    If you're really concerned someone might track you down. (Doesn't seem that way) Then I would avoid it and just use the Bundle on your regular WIndows install.

    If you're not that fussed and just want to mess around with tor and see what you can do then what is above is a brilliant little guide.

Similar Threads

  1. 'failed to execute child process' meaning and programs crashing
    By wiffleball88 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2014-08-24, 17:33
  2. Kali Linux ARM (MK/SS808) - "Failed to Execute Web Browser"
    By clearday in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-05-04, 21:24
  3. Tar process copying livesystem failed
    By amorandi in forum Installing Archive
    Replies: 1
    Last Post: 2013-03-20, 15:26

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •