Results 1 to 2 of 2

Thread: Wifi connecting to AP via terminal. "iwconfig wlan0 essid" doesn't work.

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2014-Jul
    Posts
    2

    Exclamation Wifi connecting to AP via terminal. "iwconfig wlan0 essid" doesn't work.

    Hi there.

    I know it might be a noob question but everyone needs to take a first step...

    I'm trying to make a manual connection via terminal to my AP wich has a disabled/open authentication method.

    I'm about to buy a awus036h card but before, i decided to check if is everything working fine untill i reach
    a point where the card is the only hardware that will work for a future/given purpose.

    I'm running KL 1.0.8 through a live persistent usb stick. I have an asus (k45a) notebook that comes with an
    onboard wireless adapter:

    Code:
    ~# lspci | grep -i wireless
    03:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
    As i read from a related post in another linux forum, network-manager won't deal with changes made to network stuff
    with the terminal, so i decided to stop it before i begin:

    Code:
    root@kali:~# service network-manager stop
    [ ok ] Stopping network connection manager: NetworkManager.
    root@kali:~# iwconfig
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
              Tx-Power=20 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              
    root@kali:~# ifconfig wlan0 up
    root@kali:~# ifconfig wlan0
    wlan0     Link encap:Ethernet  HWaddr 20:68:9d:bf:46:67  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:105243 errors:0 dropped:0 overruns:0 frame:0
              TX packets:76008 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:52432324 (50.0 MiB)  TX bytes:11172917 (10.6 MiB)
    
    root@kali:~# iwlist wlan0 scanning
    wlan0     Scan completed :
              Cell 01 - Address: 64:70:02:5A:BE:AE
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=29/70  Signal level=-81 dBm  
                        Encryption key:off
                        ESSID:"Leonardo Pagio"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s
                        Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=000000055ef90648
                        Extra: Last beacon: 856ms ago
                        IE: Unknown: 000E4C656F6E6172646F20506167696F
                        IE: Unknown: 010882848B960C121824
                        IE: Unknown: 030101
                        IE: Unknown: 0706425220010D14
                        IE: Unknown: 2A0100
                        IE: Unknown: 32043048606C
                        IE: Unknown: 2D1A6E1103FF00000000000000000000000000000000000000000000
                        IE: Unknown: 331A6E1103FF00000000000000000000000000000000000000000000
                        IE: Unknown: 3D16010D0000000000000000000000000000000000000000
                        IE: Unknown: 3416010D0000000000000000000000000000000000000000
                        IE: Unknown: DD180050F2020101830003A4000027A4000042435E0062322F00
                        IE: Unknown: DD0900037F01010000FF7F
                        IE: Unknown: DD9B0050F204104A0001101044000102103B00010310470010000000000000100000006470025ABE101021000754502D4C494E4B10230009544C2D57523734304E10240003342E3010420003312E301054000800060050F20400011011001B526F746561646F7220576972656C65737320544C2D57523734304E100800020086103C000101104900140024E26002000101600000020001600100020001
    
    root@kali:~# iwconfig wlan0 essid "Leonardo Pagio"
    root@kali:~# iwconfig wlan0
    wlan0     IEEE 802.11bgn  ESSID:"Leonardo Pagio"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
              Tx-Power=16 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
    The point is that it does acquire any ESSID i type in but only this.
    "Acces Point" information should return the mac of my router.
    Also, from this point, i didn't succed getting a dhcp ip ir pinging anything... as it says: i am not associated.
    Misteriously when i have network-manager activated by doing a GUI connection everything works and it does
    find the mac of the AP.
    I also typed in the essid without quotation marks but nothing.

    My question is if it's an issue related with the built in notebook wifi adapter (i.e. it will be solved with the awus036h) or is there any other process that i
    should stop (just like network-manager) before putting it to work?

    Any tip will be welcome.

    Best regards.

  2. #2
    Join Date
    2013-Mar
    Location
    milano
    Posts
    301
    Quote Originally Posted by Tichours View Post
    Hi there.

    I know it might be a noob question but everyone needs to take a first step...

    I'm trying to make a manual connection via terminal to my AP wich has a disabled/open authentication method.

    I'm about to buy a awus036h card but before, i decided to check if is everything working fine untill i reach
    a point where the card is the only hardware that will work for a future/given purpose.

    I'm running KL 1.0.8 through a live persistent usb stick. I have an asus (k45a) notebook that comes with an
    onboard wireless adapter:

    Code:
    ~# lspci | grep -i wireless
    03:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
    As i read from a related post in another linux forum, network-manager won't deal with changes made to network stuff
    with the terminal, so i decided to stop it before i begin:

    Code:
    root@kali:~# service network-manager stop
    [ ok ] Stopping network connection manager: NetworkManager.
    root@kali:~# iwconfig
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
              Tx-Power=20 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              
    root@kali:~# ifconfig wlan0 up
    root@kali:~# ifconfig wlan0
    wlan0     Link encap:Ethernet  HWaddr 20:68:9d:bf:46:67  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:105243 errors:0 dropped:0 overruns:0 frame:0
              TX packets:76008 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:52432324 (50.0 MiB)  TX bytes:11172917 (10.6 MiB)
    
    root@kali:~# iwlist wlan0 scanning
    wlan0     Scan completed :
              Cell 01 - Address: 64:70:02:5A:BE:AE
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=29/70  Signal level=-81 dBm  
                        Encryption key:off
                        ESSID:"Leonardo Pagio"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s
                        Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=000000055ef90648
                        Extra: Last beacon: 856ms ago
                        IE: Unknown: 000E4C656F6E6172646F20506167696F
                        IE: Unknown: 010882848B960C121824
                        IE: Unknown: 030101
                        IE: Unknown: 0706425220010D14
                        IE: Unknown: 2A0100
                        IE: Unknown: 32043048606C
                        IE: Unknown: 2D1A6E1103FF00000000000000000000000000000000000000000000
                        IE: Unknown: 331A6E1103FF00000000000000000000000000000000000000000000
                        IE: Unknown: 3D16010D0000000000000000000000000000000000000000
                        IE: Unknown: 3416010D0000000000000000000000000000000000000000
                        IE: Unknown: DD180050F2020101830003A4000027A4000042435E0062322F00
                        IE: Unknown: DD0900037F01010000FF7F
                        IE: Unknown: DD9B0050F204104A0001101044000102103B00010310470010000000000000100000006470025ABE101021000754502D4C494E4B10230009544C2D57523734304E10240003342E3010420003312E301054000800060050F20400011011001B526F746561646F7220576972656C65737320544C2D57523734304E100800020086103C000101104900140024E26002000101600000020001600100020001
    
    root@kali:~# iwconfig wlan0 essid "Leonardo Pagio"
    root@kali:~# iwconfig wlan0
    wlan0     IEEE 802.11bgn  ESSID:"Leonardo Pagio"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
              Tx-Power=16 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
    The point is that it does acquire any ESSID i type in but only this.
    "Acces Point" information should return the mac of my router.
    Also, from this point, i didn't succed getting a dhcp ip ir pinging anything... as it says: i am not associated.
    Misteriously when i have network-manager activated by doing a GUI connection everything works and it does
    find the mac of the AP.
    I also typed in the essid without quotation marks but nothing.

    My question is if it's an issue related with the built in notebook wifi adapter (i.e. it will be solved with the awus036h) or is there any other process that i
    should stop (just like network-manager) before putting it to work?

    Any tip will be welcome.

    Best regards.

    hi
    if this can help you for input
    i think debian used wpa_supplcant.."in my case WPA/WPA2":
    1)iwlist wlan0 scan
    2)"optional" encript-key:
    wpa_passphrase ESSID KEY ((original))
    3)leafpad /etc/wpa_supplicant.conf (after-generate-SAVE)
    ES:
    ctrl_interface=/var/run/wpa_supplicant
    #ap_scan=2

    network={
    ssid="ESSID"
    scan_ssid=1
    psk=PASSWORD encrypted by wpapassphrase
    proto=WPA2
    key_mgmt=WPA-PSK
    pairwise=CCMP TKIP
    group= CCMP TKIP
    }
    4)wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
    5)dhclient wlan0 (after this retriving connection &&& ""IP-sub""

    http://www.imagestime.com/show.php/964507_wpa.PNG.html
    click_ONTO-zOOM

Similar Threads

  1. Replies: 1
    Last Post: 2022-08-11, 21:23
  2. Replies: 1
    Last Post: 2020-07-02, 12:15
  3. Replies: 8
    Last Post: 2015-12-16, 18:48
  4. Initial password problem, "toor" doesn't work
    By Jorian in forum ARM Archive
    Replies: 6
    Last Post: 2014-12-19, 13:13

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •