Results 1 to 2 of 2

Thread: Cannot Log In After Update ( Login Loop)

  1. #1
    Join Date

    Arrow Cannot Log In After Update ( Login Loop)

    I tried updating via the "Software Update" GUI and always was stopped by a 404 error.

    So, I then did the typical
    apt-get update
    apt-get upgrade
    All seemed to flow well, skipping over a few errors and 404s occasionally. However, upon rebooting, I am not able to log in. The standard login prompt appears and I enter my credentials. Instead of popping to my desktop, the screen goes black (with cursor visible) for a few seconds before returning to the login screen. There are no authentication failure messages or anything else indicating an error, just a loop back to the login screen.

    I have experience fixing things in recovery mode, but this time, I have no idea what I broke and where to start.

    Kali 1.??? x64 Gnome

    I cannot find login issues relating to an update. Tried rebooting several times and using the default password.

  2. #2
    Join Date
    Down Under
    Hey there.

    Few things, you need to fix your repo. You should have no 404 errors. Check the official Kali repo list and have only them in your /etc/apt/sources.list file.

    Check the path variable in your bash profile. Check for typos.

    Make sure your /tmp folder has these permissions 'drwxrwxrwt # root root'

    Try this and restart the service. Do all this from terminal. (ctrl +alt +f1)

    sudo mv ~/.Xauthority ~/.Xauthority.old

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts