Results 1 to 41 of 41

Thread: ALFA AWUS036NH not injecting packets?

  1. #1
    Join Date
    2014-Aug
    Posts
    8

    ALFA AWUS036NH not injecting packets?

    Hey everyone, new user here. I have run into a bit of trouble with my alfa usb wireless card. It works fine for connecting to networks and normal use, but when i was practicing some wifi cracking i realiZed that it was not injecting packets. My internal killer wireless card that came with my laptop is, but not the alfa that i purchased? Is there anything i can do to fix this or is something wrong with the hardware itself? Any input is appreciated. Thank you.

  2. #2
    Join Date
    2014-May
    Location
    Valencia
    Posts
    48
    Please perform the aircrack injection test:

    http://www.aircrack-ng.org/doku.php?id=injection_test

  3. #3
    Join Date
    2014-Aug
    Posts
    8
    hi forum, thanks you for your response. i ran the injection test and i never get the injection is working message like i do when i run it on my internal wireless card.

  4. #4
    Join Date
    2013-Mar
    Location
    milano
    Posts
    301
    Quote Originally Posted by Aegonii View Post
    Hey everyone, new user here. I have run into a bit of trouble with my alfa usb wireless card. It works fine for connecting to networks and normal use, but when i was practicing some wifi cracking i realiZed that it was not injecting packets. My internal killer wireless card that came with my laptop is, but not the alfa that i purchased? Is there anything i can do to fix this or is something wrong with the hardware itself? Any input is appreciated. Thank you.
    hi
    for me injection worked-fine in VM && HDD install (aircrack-ng suite)...the only problem (FOR ME) with NH is "reaver && some""" break-pin-tools"""
    http://www.imagestime.com/show.php/969691_1.PNG.html

  5. #5
    Join Date
    2014-Aug
    Posts
    8
    thanks for your reply zimmaro, but i use a live usb. The alfa just wont inject at all, my internal wireless card does. I am trying to figure out what i could do to fix this or if the hardware itself on the alfa is busted.

  6. #6
    Join Date
    2013-Jul
    Posts
    841
    Try your wifi device on another computer running kali1.08. Try making a persistent usb install and update it and test it. Finally try running a VM ware install of kali-108 - update it and upgrade it and then test. One of our correspondents may have an NH. If this is true we will test and get back as we ourselves want to upgrade from the rtl8187.

  7. #7
    Join Date
    2014-Aug
    Posts
    1
    I am experiencing symptoms similar to this and also the "Wash not showing connections" post. It seems that monitor mode is being reset after any one use of wash, reaver, or airodump-ng. Airmon-ng stop and then airmon-ng start lets the interface function one more time. I have observed this behavior in both 1.0.8 and 1.0.9. I'm sticking with 1.0.7 -- it works. FWIW.

  8. #8
    Join Date
    2013-Jul
    Location
    United States
    Posts
    520
    Quote Originally Posted by mmusket33 View Post
    Try your wifi device on another computer running kali1.08. Try making a persistent usb install and update it and test it. Finally try running a VM ware install of kali-108 - update it and upgrade it and then test. One of our correspondents may have an NH. If this is true we will test and get back as we ourselves want to upgrade from the rtl8187.
    Try AWUS051NH? Dual band, 150mbps + 300mbps. Everything works well, except for lingering channel -1...

  9. #9
    Join Date
    2014-Aug
    Posts
    8
    @musket i tried it via my usb live boot on my desktop and still not getting injection. i am going to give it a shot in virtual box once i get the extension pack installed for usb support then i will report back. I am quite new to kali linux so i am still learning a bit, so when you say update it do you mean drivers for the nh? i ask because from my research before buying the nh i saw it was plug and play with kali, should i get a driver for it? if so do you mind providing the link? maybe this is the problem.

    @soxrok if i cant get this working i was thinking about just buying a new card, id rather not as buying this nh would be a waste of money, but if i need to i will. i was thinking about getting the nha, any thoughts?

  10. #10
    Join Date
    2014-Aug
    Posts
    8
    so i tried using the wireless adapter in virtualbox, installed the extension pack for usb support, everything went fine. i saw my adapter under wlan0 so i tried to run the aireplay-ng -9 test and it does nothing, says no AP's found. So i just put it into monitor mode to try and scan for AP;s and nothing comes up at all. Now i figure i did something wrong because when i use my live usb the alfa at least is able to scan in monitor mode for AP's. i am relatively new to all this so if i missed something please let me know. I am getting a bit frustrated with this wifi card

    thanks all

  11. #11
    Join Date
    2015-Jan
    Posts
    2
    so any idea for this I want to buy it too the NHA version anyone recommend it, what about tx power is dangerous to upgrade it to 30dbm

  12. #12
    I am having the exact same problem. I purchased the AWUS036NH USB wireless adapter card specifically to be used with Kai-Linux.

    It has good range and when I put it in monitor mode is able to pick up and detect far more APs than my internal wireless card which came with my laptop. The problem is that when I try packet injection, it doesn't work. However, the wireless card that came in my laptop does work. This is so frustrating!

    I assumed it was a driver issue, so I attempted to install new drivers and spent hours trying to install them with via command line code, but couldn't seem to figure out how to do it.

    The installation instructions which come with it make no sense to me. Does anyone have any ideas?


    Thanks in advance!

  13. #13
    Join Date
    2016-Apr
    Posts
    1
    same with my alfa, seems like it's a kali 2016.1 issue, something in kernel mod probably, had to switch to kali 2.0 and it works great !

    wizy
    Last edited by wizy; 2016-04-26 at 14:05.

  14. #14
    Join Date
    2016-Apr
    Posts
    15
    same here, just got my NH today, injection not working on latest kali install. Just to be sure, it is supposed to be a Ralink 2870/3070 in these units right? with that said also using the rt2800usb driver too?

  15. #15
    Join Date
    2016-Apr
    Posts
    15
    I also noticed that it is not showing ANY associated clients, while it may show way more AP's than my internal card, my internal card shows associated clients and the NH isn't catching them for some reason.

  16. #16
    Join Date
    2016-Apr
    Posts
    15
    Ok, so with this driving me nuts, I decided to dig as deep as I possibly could. I found this, https://marc.info/?l=linux-wireless&...1668331789&w=2, it seems like one of the kernel patches may have broke monitor mode (possibly intently?) if someone could elaborate on what exactly it means and how to fix it, PLEASE let me know.

  17. #17
    Join Date
    2016-Mar
    Posts
    24
    Quote Originally Posted by soxrok2212 View Post
    Try AWUS051NH? Dual band, 150mbps + 300mbps. Everything works well, except for lingering channel -1...
    i agree AWUS051NH with long-range antenna and txpower 33 ! Awesome combo...get handshakes all day long...but Nooo success with aircrack-ng dictionary attack.

  18. #18
    Join Date
    2016-Apr
    Posts
    15
    Bump still not fixed

  19. #19
    Join Date
    2016-May
    Posts
    8
    Howdy
    I just downloaded newest version of Kali Linux. I am using what is supposed to be a Railink 3072 chipset in my USB wifi adapter and everything works in regard to finding all the wifi networks and running wash commands, reaver commands, aircrack commands, Felt commands, Wifite commands etc.
    What is NOT working is when I run an injection test I am told the wifi adapter is not injecting. Getting 0 percent on all networks.
    Any suggestions on fixing this or should I just get a new USB wifi adapter? Thanks

  20. #20
    Join Date
    2016-May
    Posts
    4
    WOW all this time i was going crazy trying to find a fix for this i thought i did something wrong because i'm new to kali, I have the Alfa AWUS036NH and the 51NH as well. Mind you these are suppose to work out of the box so i was a bit thrown back when i see it's not working as in injecting or finding associated clients. However my internal wireless card is able to find associated clients

  21. #21
    Join Date
    2016-May
    Posts
    8
    Quote Originally Posted by ixcuix View Post
    Howdy
    I just downloaded newest version of Kali Linux. I am using what is supposed to be a Railink 3072 chipset in my USB wifi adapter and everything works in regard to finding all the wifi networks and running wash commands, reaver at, aircrack commands, Felt commands, Wifite commands etc.
    What is NOT working is when I run an injection test I am told the wifi adapter is not injecting. Getting 0 percent on all networks.
    Any suggestions on fixing this or should I just get a new USB wifi adapter? Thanks
    Found out it isae NOT the wifi cards probem. It is definitely a software problem. I ran the SAME EXACT commands after downloading an old version of BackTrack and everything worked perfect. So if al knows how to fix Kali to work with the Railink 3072 chipset or better yet knows of a link to a version of Kali that has fixed this please post here. THanks.

    t

  22. #22
    Join Date
    2016-Apr
    Posts
    15
    It's a driver or kernel issue, I read what the problem was and I unfortunately lost the link. But something was patched to make it ignore packets that weren't meant for it. I'll try finding it again.

  23. #23
    Join Date
    2016-May
    Posts
    8

    How to enter Patches

    Quote Originally Posted by laser411 View Post
    It's a driver or kernel issue, I read what the problem was and I unfortunately lost the link. But something was patched to make it ignore packets that weren't meant for it. I'll try finding it again.
    I found this but I have no idea how to enter this patch. Could somebody please tell me how to enter this patch.

    Thanks T

    Re: rt2800usb injection
    « Reply #4 on: January 19, 2016, 09:01:17 pm »
    ReplyQuote
    This will help you. It restores aircrack-ng compatibility with rt2800lib devices on newer kernels (> 4.2)

    ---
    drivers/net/wireless/rt2x00/rt2800lib.c | 2 +-
    1 file changed, 1 insertion(+), 1 deletion(-)

    diff --git a/drivers/net/wireless/rt2x00/rt2800lib.c b/drivers/net/wireless/rt2x00/rt2800lib.c
    index 9524564..285acc2 100644
    --- a/drivers/net/wireless/rt2x00/rt2800lib.c
    +++ b/drivers/net/wireless/rt2x00/rt2800lib.c
    @@ -1490,7 +1490,7 @@ void rt2800_config_filter(struct rt2x00_dev *rt2x00dev,
    !(filter_flags & FIF_FCSFAIL));
    rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_PHY_ERROR,
    !(filter_flags & FIF_PLCPFAIL));
    - rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_NOT_TO_ME, 1);
    + rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_NOT_TO_ME, 0);
    rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_NOT_MY_BSSD, 0);
    rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_VER_ERROR, 1);
    rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_MULTICAST,
    --
    2.7.0

  24. #24
    Join Date
    2016-May
    Posts
    8

  25. #25
    Join Date
    2016-May
    Posts
    4
    Quote Originally Posted by ixcuix View Post
    ok how do you use the code?

  26. #26
    Join Date
    2016-May
    Posts
    2
    This issue has been solved on recent updates of Kali. If you're running it on a virtual box or you have it installed on a partition just do:

    sudo apt-get update
    sudo apt-get dist-upgrade

    and reboot. Otherwise wait for the next release...

  27. #27
    Join Date
    2016-May
    Posts
    1
    Quote Originally Posted by polo_40 View Post
    This issue has been solved on recent updates of Kali. If you're running it on a virtual box or you have it installed on a partition just do:

    sudo apt-get update
    sudo apt-get dist-upgrade

    and reboot. Otherwise wait for the next release...
    I just ran an update and upgrade with no luck. I've just purchased this card and have been trying to figure out a solution. I ran an aireplay-ng -9 wlan1 which is the interface for the alfa card but I'm also not getting no replies. Looks like I should of done more research before settling on this card, if anyone has updates that'd be great.

  28. #28
    Join Date
    2016-May
    Posts
    4
    Quote Originally Posted by SlothX View Post
    I just ran an update and upgrade with no luck. I've just purchased this card and have been trying to figure out a solution. I ran an aireplay-ng -9 wlan1 which is the interface for the alfa card but I'm also not getting no replies. Looks like I should of done more research before settling on this card, if anyone has updates that'd be great.
    i have the alfa working on kali 2.0

  29. #29
    Join Date
    2016-Jun
    Posts
    2
    Quote Originally Posted by dimez View Post
    i have the alfa working on kali 2.0
    Hi Dimez.
    More info about your "Alfa" would be much appreciated.
    I can't get to work mine awus051nh v2! And i thought i buy a compatible card for kali! I hope this issue will be resolved in the near future.

  30. #30
    Join Date
    2016-May
    Posts
    8

    New Kali Version

    Quote Originally Posted by polo_40 View Post
    This issue has been solved on recent updates of Kali. If you're running it on a virtual box or you have it installed on a partition just do:

    sudo apt-get update
    sudo apt-get dist-upgrade

    and reboot. Otherwise wait for the next release...
    I have the newest version of Kali and there is a problem with the driver for the Railink chipset.
    Kali (latest version) works perfect with OTHER chips ets. I just got a TP-LInk TL WN722n today and
    it has no injection problems, but as I said the newest Kali has a problem with the Railink chipset.
    I guess I could start using an older version of Kali. Also this TP-LINK is not close to as strong in regard to picking up WIFI signals even with a huge antenna. I still need help getting a driver other than the rt2800 which definitely has problems in the newest version of Kali.
    Thanks

  31. #31
    Join Date
    2016-May
    Posts
    4
    Quote Originally Posted by Zaplancek View Post
    Hi Dimez.
    More info about your "Alfa" would be much appreciated.
    I can't get to work mine awus051nh v2! And i thought i buy a compatible card for kali! I hope this issue will be resolved in the near future.
    yea bro just download kali 2.0 instead, alfa is working fine with kali 2.0

  32. #32
    Join Date
    2016-May
    Posts
    8
    Quote Originally Posted by dimez View Post
    yea bro just download kali 2.0 instead, alfa is working fine with kali 2.0
    I am using WIFISLAX with the same hardware that does not work with the latest version of Kali and everything works perfect. It is DEFINITELY a software problem. PS wifislax is amazing.

  33. #33
    Join Date
    2016-May
    Posts
    8
    Also my wifi card with a Railink chipset worked when I used Kali version 2.

  34. #34
    Join Date
    2016-Apr
    Posts
    15
    Just downloaded and installed fresh version of kali and updated everything. Can confirm this problem is indeed fixed. Thanks guys!

    It also fixed the non-associated clients too, looks like i was right when I stumbled across someone saying it was dropping packets not destined for it.

    - rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_NOT_TO_ME, 1);
    + rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_NOT_TO_ME, 0);

    that literally says, if receiving packet not for me then drop = true, and it's been removed and changed to false in the update. Can someone explain though whether this is a driver change or a kernel change? if not either, then what?

  35. #35
    Join Date
    2016-May
    Posts
    2
    Quote Originally Posted by laser411 View Post
    Just downloaded and installed fresh version of kali and updated everything. Can confirm this problem is indeed fixed. Thanks guys!

    It also fixed the non-associated clients too, looks like i was right when I stumbled across someone saying it was dropping packets not destined for it.

    - rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_NOT_TO_ME, 1);
    + rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_NOT_TO_ME, 0);

    that literally says, if receiving packet not for me then drop = true, and it's been removed and changed to false in the update. Can someone explain though whether this is a driver change or a kernel change? if not either, then what?
    As for the patch that solved the issue, looks like a driver problem rather than a kernel one:
    Code:
    http://marc.info/?l=linux-wireless&m=145311668331789&w=2

  36. #36
    Join Date
    2016-Jun
    Posts
    4
    So there is no fix for linux 2016.1 yet? I have already made a persistent usb with a bunch of stuff on it (256 gb drive) and it would really suck to start from scratch just to get kali 2.0 just to get this card to work :/. I already have the NHA card but its def not as good as this one and would love to make this work!

  37. #37
    Join Date
    2016-Jun
    Posts
    1
    I have kali 2.0 and wifislax. The AWUS036NH is not injecting in kali but injects in wifislax so i think it's a software problem. Are there any fixes yet?

  38. #38
    Join Date
    2013-Feb
    Posts
    225
    This issue is fixed in the latest kernel of Kali-rolling.

  39. #39
    Join Date
    2016-Jul
    Posts
    10
    Does this work for Kali Linux? If so how do I implement it so my ALFA NEH will inject packets with reaver? Monitor mode is working fine

  40. #40
    Join Date
    2016-Jul
    Posts
    10
    Quote Originally Posted by polo_40 View Post
    This issue has been solved on recent updates of Kali. If you're running it on a virtual box or you have it installed on a partition just do:

    sudo apt-get update
    sudo apt-get dist-upgrade

    and reboot. Otherwise wait for the next release...

    What If I am booting from persistence USB? Is there a way to save the config to the usb to avoid having to update?

  41. #41
    Join Date
    2016-Apr
    Posts
    15
    Well, I would imagine you would have to recompile your driver. Personally I don't know specifically how to do it, however these are the important changes that need to be made in rt2800lib.c

    Code:
    diff --git a/drivers/net/wireless/ralink/rt2x00/rt2800lib.c \
    b/drivers/net/wireless/ralink/rt2x00/rt2800lib.c index 9733b31..a26afca 100644
    --- a/drivers/net/wireless/ralink/rt2x00/rt2800lib.c
    +++ b/drivers/net/wireless/ralink/rt2x00/rt2800lib.c
    @@ -1490,7 +1490,8 @@ void rt2800_config_filter(struct rt2x00_dev *rt2x00dev,
     			   !(filter_flags & FIF_FCSFAIL));
     	rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_PHY_ERROR,
     			   !(filter_flags & FIF_PLCPFAIL));
    -	rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_NOT_TO_ME, 1);
    +	rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_NOT_TO_ME,
    +			   !test_bit(CONFIG_MONITORING, &rt2x00dev->flags));
     	rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_NOT_MY_BSSD, 0);
     	rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_VER_ERROR, 1);
     	rt2x00_set_field32(&reg, RX_FILTER_CFG_DROP_MULTICAST,
    The minus represents removed or changed lines, Plus is added.

Similar Threads

  1. Alfa AWUS036NH problem
    By tes in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2017-11-11, 00:09
  2. Can't inject packets wit alfa AWUS036NH
    By bolex in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2016-04-23, 13:55
  3. Please help with my alfa awus036nh card
    By twomakewar in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2014-09-01, 14:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •