Results 1 to 14 of 14

Thread: "GRUB installation failed" HELP

  1. #1
    youkergav Guest

    "GRUB installation failed" HELP

    Yesterday I built my first computer. I'm trying to put Kali on it. I don't have wifi or ethernet on my new computer yet. Every time I try to install I get an error when installing GRUB. "The 'grub-pc' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot." Is there a way to fix this? Or can I install grub via a thumb drive? Please help.

  2. #2
    How are you trying to install it?
    Via Live boot, text install or graphic install?

    If its 'live boot', this is a known bug: https://bugs.kali.org/view.php?id=1260.
    The solution would be to use text or graphic install (when you boot up Kali)
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Search: https://www.kali.org/search/
    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: http://tools.kali.org/

  3. #3
    Join Date
    2014-Apr
    Location
    Down Under
    Posts
    315
    I had the same error on my Kali install. This was 1.0.8 and I was using a text install.

    In the end, it was because of my lack of internet. When I dumped the log files from the installer and reviewed them, it could not find the grub-efi-amd64 package.

    So, I manually installed grub-efi and wrote up some instructions in this post below. This will only help you if you are using an EFI install, if not, its a similar process but there are about 1000 guides to installing grub manually.

    https://forums.kali.org/showthread.p...ll=1#post36206

  4. #4
    Join Date
    2013-Jul
    Posts
    822
    To g0tmilk,

    We have done numerous successful Hard Drive installs of Kali-linux

    However starting with kali-1.06 we have four(4) Samsung computers which freeze at the Detect Network Hardware stage.

    We have tried live installs, graphical installs and a few other suggestions. Nothing works. Do you have any ideas?

    MTeams

  5. #5
    Quote Originally Posted by staticn0de View Post
    I had the same error on my Kali install. This was 1.0.8 and I was using a text install.

    In the end, it was because of my lack of internet. When I dumped the log files from the installer and reviewed them, it could not find the grub-efi-amd64 package.

    So, I manually installed grub-efi and wrote up some instructions in this post below. This will only help you if you are using an EFI install, if not, its a similar process but there are about 1000 guides to installing grub manually.

    https://forums.kali.org/showthread.p...ll=1#post36206
    This sounds like something for the bug tracker.
    Would be worth submitting it to: https://bugs.kali.org/
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Search: https://www.kali.org/search/
    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: http://tools.kali.org/

  6. #6
    Join Date
    2014-Apr
    Location
    Down Under
    Posts
    315
    Quote Originally Posted by g0tmi1k View Post
    This sounds like something for the bug tracker.
    Would be worth submitting it to: https://bugs.kali.org/
    Will do.

    I'll reinstall Kali 1.0.9 and if it does the same thing, I'll collect the logs and upload them on the bug tracker.

  7. #7
    Join Date
    2013-Aug
    Location
    lost in space
    Posts
    580
    that whole 'dependency on Internet' to install anything is unhealthy me thinks.

    .02
    Kali Linux USB Installation using LinuxLive USB Creator
    Howto Install HDD Kali on a USB Key
    Clean your laptop fan | basic knowledge

  8. #8
    Join Date
    2014-Apr
    Location
    Down Under
    Posts
    315
    Issue logged in the Kali Bug Tracker.

    As I noted in the tracker, I was able to get around the error when I made a custom ISO and included the missing grub files in the custom ISO build process.

    https://bugs.kali.org/view.php?id=1704

  9. #9
    Join Date
    2014-Feb
    Posts
    44
    I used one of the mini-images and also had this happen somewhat recently. It was maybe a week or so before this thread was posted. I skipped past the Grub installation and installed Lilo bootloader. working great

  10. #10
    Join Date
    2014-Apr
    Location
    Down Under
    Posts
    315
    Quote Originally Posted by staticn0de View Post
    Issue logged in the Kali Bug Tracker.

    As I noted in the tracker, I was able to get around the error when I made a custom ISO and included the missing grub files in the custom ISO build process.

    https://bugs.kali.org/view.php?id=1704
    Everyone should be happy to know I just got the email from the good gents on the bug tracker. Looks like the efi grub install failure is resolved in Kali 1.1.0

  11. #11
    Join Date
    2015-Jul
    Posts
    1
    Hello guys, I have the same problem. I read that in version 1.1.0 the bug was solved but it doesn't work on my pc..I also see that I can customize Kali's ISO but I must have a Linux system to do..or not? I haven't it can someone help me?

  12. #12
    Join Date
    2015-Nov
    Posts
    2
    Hi Guys,
    I had the same problem, installation goes well untill Grub, it just wouldn't install. After 6 beers etc i found the dumbest solution: during installation you are asked to configure Network Mirror for receiving updates. I never used it when installing Kali on VBoxes (right now I'm installing it as main OS). So, for a change, I clicked Yes,but I left the field blank. Lo and behold: installation successful! Give it a try and good luck!
    R.

  13. #13
    Join Date
    2015-Nov
    Posts
    2
    Oh yeah, I forgot to say. I first starded with Live Install, than from inside there 'Install Kali' -in the applications, and than had that problem with Grub. Fixed with Network Mirror 'Yes' and blank.

  14. #14
    Join Date
    2016-Feb
    Posts
    1

Similar Threads

  1. [Fix]"grub-pc failed to install into /target/"[Fix]
    By n0bul4r in forum How-To Archive
    Replies: 8
    Last Post: 2016-02-06, 13:19
  2. "Debian Live image failed to boot" - Cannot mount /dev/loop0 ....
    By golfsoccer9 in forum Installing Archive
    Replies: 4
    Last Post: 2014-06-07, 19:40

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •