Results 1 to 11 of 11

Thread: UEFI Dual Boot Kali Linux 1.0.9 with Windows 8.1

  1. #1
    Join Date
    2014-Sep
    Location
    India
    Posts
    2

    Exclamation UEFI Dual Boot Kali Linux 1.0.9 with Windows 8.1

    Hello,
    I was excited when heard about the latest release 1.0.9 but seems like the Kali Team has not resolved the UEFI Dual Boot issue yet.

    just like Kali 1.0.8, when I try to make UEFI bootable Kali using Rufus, its throwing an error that "Only EFI bootable ISO images are supported"

    When can we enjoy the working UEFI Bootable Kali Linux.....

    If there is any alternate solution, kindly provide the same.

    I have Dell Inspiron 15r 5521. Here are the specs:

    UEFI Boot
    2 GB AMD Radeon Graphic Card
    8Gb Ram
    1TB HDD
    Windows 8.1 OS

    Here is the snapshot of error :New Image.jpg

  2. #2
    If Rufus isn't working for you, try and follow whats on the docs page: http://docs.kali.org/category/installation
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: https://tools.kali.org/

  3. #3
    Join Date
    2014-Sep
    Location
    India
    Posts
    2

    Unhappy Re:

    Thanks for your response.

    But I tried the method illustrated in Kali Docs.

    I tried installing Kali Linux using Win32 Disk Imager but system is not recognizing the OS as UEFI Boot.

    I don't want to disable UEFI and install Kali using Legacy method.

    I though they added support for UEFI Boot and if the ISO supports UEFI then rufus would be able to load the OS Files on to USB using UEFI boot option.

    Any other solution please ?

  4. #4
    I have the exact same problem. It's getting quite frustrating....

    Come on Kali devs, pick up your game (or at least release some hot fixes!)

  5. #5
    Join Date
    2014-Apr
    Location
    Down Under
    Posts
    315
    Try cooking your own ISO from the live build. Works everytime for me.

    On that, try a usb 2.0 thumb drive that is 8gb. That fixed any other issues I had.
    chown -R us ./base

  6. #6
    Join Date
    2014-Nov
    Posts
    18
    I am facing the same problem too. I have windows 7 installed in UEFI mode on my laptop for a long time now. I wanted to try Kali Linux on a 30 GB space that was lying vacant on my laptop. But the Kali linux DVD does not seem to boot in UEFI mode. I tried to switch on legacy mode and boot the DVD. It boots but during installation the install GRUB bootloader step fails. I tried LILO too but no luck. I tried to install GRUB on the MBR, as was suggested during installation. But upon restarting my laptop, kali is not listed in my BIOS and windows boots directly. Please help, I am new to Linux. (BTW I was able to install Sabayon Linux and dual boot with no problems, but I found Gentoo to be hard to use for a newbie like me).

  7. #7
    Join Date
    2014-Nov
    Posts
    18
    I got Kali up and running in EFI mode, along with Windows 7. My situation might be atypical but here's what I did:

    1. Booted Kali DVD in legacy mode (EFI mode does not work)
    2. Installed Kali by replacing Sabayon (format and replaced) on the same partition.
    3. During installation GRUB install failed. So I skipped that step and moved on to the next step and completed the installation. (I got a message with a root=/dev/mapper/NAME_OF_LVM when GRUB failed to install, which I noted down)
    4. Emptied my DVD drive then rebooted my laptop and configured the BIOS to boot Sabayon in UEFI mode. Sabayon's entry still existed on my EFI partition.
    5. Booting Sabayon predictably failed. So I landed in a grub shell.
    6. I booted Kali from my HDD from the grub shell by issuing the following commands:

    grub> linux (lvm/NAME_OF_LVM)/boot/vmlinuz-3.14-kali1-amd64 root=/dev/mapper/NAME_OF_LVM init=/sbin/init
    grub> initrd (lvm/NAME_OF_LVM)/boot/initrd.img-3.14-kali1-amd64
    grub> boot

    Then I followed the instructions on the following page to install grub:

    http://www.thinkwiki.org/wiki/UEFI_Firmware

    Then unmounted /boot/efi and did a grub-mkconfig to generate grub.cfg and placed it in /boot/grub. I now have to get my NVidia card configured with Xorg and also get CUDA up and running. BTW, I don't like the bug ridden iceweasel and want to change to firefox and chrome ASAP.
    Last edited by nikkipolya; 2014-11-04 at 16:39.

  8. #8
    Join Date
    2013-Jul
    Posts
    6
    I had similar problems with an ASUS netbook with UEFI. I solved the problem using the guidance available at:

    https://wiki.debian.org/GrubEFIReinstall

    In summary I followed these steps (after installing Kali to my netbook's hard drive without installing legacy Grub):

    1. Download rEFInd rescue media -- I made a bootable USB with the rEFInd utility. This little utility parses the HDD and finds bootable kernels.
    2. Boot your computer with the Refind media
    3. Reinstall grub-efi on your hard drive

    The instructions for these steps are available at the link provided. This worked like a champ. I also found that rEFInd is a great utility in case you ever munge your boot loader.

  9. #9
    Join Date
    2014-Dec
    Posts
    4
    The reason Rufus did not detect Kali iso as EFI bootable ISO, is because EFI/BOOT section was not placed in the root of the ISO image. Just edit the ISO image by adding EFI/BOOT folder, which you will find in the same iso image in boot directory (there is another image there, called efi.img - just copy it to desktop and open using 7zip)

  10. #10
    I know this post has been dead for a while but I had the same issue and I was able to solve it simply by setting an admin, hdd, and system password. That allowed me full access to the boot sequence allowing me to install Kali using UEFI

  11. #11
    Join Date
    2016-Sep
    Posts
    2
    Can you please explain what you meant by setting system admin?

Similar Threads

  1. UEFI: How to repair kali-linux grub dual boot with Windows 10
    By _defalt in forum Community Generated How-Tos
    Replies: 89
    Last Post: 2021-09-02, 08:31
  2. Dual boot Windows 10 & Kali Linux 2016.2 UEFI
    By stevo4mkd in forum How-To Archive
    Replies: 6
    Last Post: 2017-04-06, 16:55
  3. Replies: 63
    Last Post: 2016-10-01, 13:31
  4. Dual Boot Kali Linux with Windows 8.1 (UEFI and SECURE BOOT)
    By sentostv in forum Installing Archive
    Replies: 2
    Last Post: 2015-01-01, 02:53

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •