Results 1 to 4 of 4

Thread: Openvas issue: login failed. omp service is down

  1. #1
    Join Date
    2014-Oct
    Posts
    10

    Openvas issue: login failed. omp service is down

    Hi,

    I installed openvas but I got failure when try to logon on the web console "login failed. omp service is down". I'm not sure whether installation was completed correctly because in the end of the process when it starts update annual CVE issues terminal windows closed unexpectedly without any messages.
    I tried to run openvasmd --rebuild but it does not bring any output. Openvas-nvt-sync says "Feed is already current".

    I tried to installed openvas manually and it failed:

    root@kali:~# apt-get -y install greenbone-security-assistant openvas-cli openvas-manager openvas-scanner openvas-administrator sqlite xsltproc rsync Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    greenbone-security-assistant is already the newest version.
    greenbone-security-assistant set to manually installed.
    openvas-cli is already the newest version.
    openvas-cli set to manually installed.
    openvas-manager is already the newest version.
    openvas-manager set to manually installed.
    openvas-scanner is already the newest version.
    openvas-scanner set to manually installed.
    rsync is already the newest version.
    rsync set to manually installed.
    xsltproc is already the newest version.
    xsltproc set to manually installed.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    openvas-administrator : Depends: libopenvas6 but it is not going to be installed
    openvas-manager : Conflicts: openvas-administrator but 1.3.2-0kali1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    root@kali:~#


    I appreciate your ideas how to fix the issue or a way of full openvas re-installation.

  2. #2
    Join Date
    2014-Oct
    Posts
    10
    After system files review solution was found as run openvas-setup again and repeat installation process. Later I added yet another user using openvasmd and successfully logon to the console.

  3. #3
    Join Date
    2014-Sep
    Posts
    4
    try update the feed not enough i think

  4. #4
    Join Date
    2014-Sep
    Posts
    176
    This was updated in the new kalimenu. These were the steps it took to get it running for me:
    Code:
    apt-get update && apt-get install -y openvas
    openvas-setup && openvas-scapdata-sync && openvas-certdata-sync && openvas-check-setup && openvas-stop 
    openvasmd --create-user=admin --role=Admin
    openvasmd --user=admin --new-password=NEWPASSWORD
    To start openvas:
    Code:
    openvas-start

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •