Results 1 to 10 of 10

Thread: kali 1.0.9 plain black screen after GRUB

  1. #1
    Join Date
    2014-Oct
    Posts
    1

    kali 1.0.9 plain black screen after GRUB

    Hi,

    I just started 'playing' with Kali recently. Initially I just boot Kali 1.0.9 live from USB.
    However, subsequently I succesfully installed Kali on my HDD (dual booting with Windows 8.1).

    I can get to GRUB menu and select Kali to boot, but just after it echoes 'loading initial ramdisk', the screen goes plain black and stucked there, no GUI/terminal can be accessed.
    There's no any blinking cursor, but i noticed the backlight of the screen is working. Ctrl + Alt + F1 dont work.

    I've tried nomodeset, grub_gfxmode=1280x1024x24, nolapic, as initially i'm thinking it has something to do with my graphic card, but they were unsuccesfull.


    My laptop specs:
    MSI GE60 2PE Apache Pro
    1TB HDD
    8GB RAM
    NVIDIA GTX860M with Intel HD Graphic 4600

    Can someone please direct me to any useful resource or suggest something that I can try?

    Please do not hesitate to ask for further information.

    Thank you so much!

  2. #2
    Join Date
    2014-Oct
    Posts
    1

    Same issue: Kali Won't Load Past Grub - Black Screen

    Did you get this to work? I have the same issue.

    Thanks!

  3. #3
    Join Date
    2014-Nov
    Posts
    2
    The Issue I got was that it would freeze on boot with EDID checksum invalid, remainder is 224.
    that I solved by updating grub to use nomodeset.
    Now my problem is kinda like above grub boots fine and i get into a black screen that flickers greenish. . .

    2.0 GHz Intel Core i7-2630QM processor
    1.5 GB NVIDIA GeForce GTX 560M graphics card,
    8 GB of DDR3 RAM

    Kali being the only OS installed

    anyone got a solution for this?

  4. #4
    Join Date
    2014-Nov
    Posts
    2
    The Issue I got was that it would freeze on boot with EDID checksum invalid, remainder is 224.
    that I solved by updating grub to use nomodeset.
    Now my problem is kinda like above grub boots fine and i get into a black screen that flickers greenish. . .

    2.0 GHz Intel Core i7-2630QM processor
    1.5 GB NVIDIA GeForce GTX 560M graphics card,
    8 GB of DDR3 RAM

    Kali being the only OS installed

    anyone got a solution for this?

  5. #5
    Join Date
    2014-Nov
    Posts
    13
    Pretty sure I'm having the same problem. I've installed kali multiboot on my laptop and was using everything just fine for about a week. Now all of a sudden it loads to grub and no further. I think the last thing it successfully did was an update but I have no way of knowing what update it took that could have caused the issue. I can still access grub to boot in normal or recovery but it doesnt make it any further. I do have access to edit load commands by pressing e but thats all i can get to. Any sugguestions?

  6. #6
    Join Date
    2014-Dec
    Posts
    2
    rEFInd is the solution for this. Grub doesnt work for me. google it and install it use it as your primary boot loader and it should work

  7. #7
    Join Date
    2014-Aug
    Posts
    8
    try installing ubuntu nezxt to it and use ubunti its grub.. Thats my workaround

  8. #8
    Join Date
    2015-Jan
    Posts
    1
    yes, I got the same trouble. It was stuck in "Booting kernel" when I boot to Kali Linux on macbook pro. So any suggestions for this?

  9. #9
    Join Date
    2014-Oct
    Posts
    3
    I am experinceing something along the same lines after grub I get a black screen but I have a mouse I can move around the screen and here is my workaround as crazy as it seams see if any of you can use this way.
    1. at black screen put in suspend/hibernate/sleep after hdd light stays off
    2. bring it out of the state you put it in
    3. with moving the mouse around the screen will make the login manager pop up but everything is very graphically glitched but seams steaddy if mouse is in upper right corner (for me)
    4. log in (preferably into gdm3, has the best working I found with the next step)
    5. open a terminal window (which may be difficuilt depending on your icon or hot-key set-up since mouse is invisable for me since step 2)
    6. just type anything into the terminal window and move the mouse you do not have to hit enter. the mouse should appear on screen and now all graphical glitches are gone and you can log out and log in using whatever window manager you want.

    Yes this is the steps I go thru every time I boot up but it works... (shrugs)

  10. #10
    Join Date
    2015-Jan
    Posts
    6
    Quote Originally Posted by vixidem View Post
    Hi,

    I just started 'playing' with Kali recently. Initially I just boot Kali 1.0.9 live from USB.
    However, subsequently I succesfully installed Kali on my HDD (dual booting with Windows 8.1).

    I can get to GRUB menu and select Kali to boot, but just after it echoes 'loading initial ramdisk', the screen goes plain black and stucked there, no GUI/terminal can be accessed.
    There's no any blinking cursor, but i noticed the backlight of the screen is working. Ctrl + Alt + F1 dont work.

    I've tried nomodeset, grub_gfxmode=1280x1024x24, nolapic, as initially i'm thinking it has something to do with my graphic card, but they were unsuccesfull.


    My laptop specs:
    MSI GE60 2PE Apache Pro
    1TB HDD
    8GB RAM
    NVIDIA GTX860M with Intel HD Graphic 4600

    Can someone please direct me to any useful resource or suggest something that I can try?

    Please do not hesitate to ask for further information.

    Thank you so much!
    Did this happen right after installation? After you updated? Have you attempted to reformat that partition and re-install?

Similar Threads

  1. Kali Linux black screen BEFORE grub shows up
    By LambdaPi in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-12-24, 13:38
  2. Black screen after grub with kali linux 1.0.9 intel hd4600 + nvidia gtx870m
    By defconctugt in forum TroubleShooting Archive
    Replies: 5
    Last Post: 2014-12-26, 03:21
  3. Black screen after grub MSI GS70 dual boot with Windows 8.1
    By inuyasha in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2014-11-19, 20:52

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •