Hi guys,
I'm new so be gentle,

The problem is this: Building the main guest additions fails no matter what, and there is no widescreen resolution selectable only 4:3

I have been busy for several hours reading forum posts and trying out different stuff, nothing worked.
Let me introduce my specs

Mac Os Lion, Virtual Box 4.3.18 + expansion , kali-linux-1.0.9a-amd64.iso
General: Debian (64bit)
System: 1024mb, PAE/NX enabled, dual core
Storage: 20gb VDI Sata
Display: 128 Video memory (3d acc enabled/disabled tried both)

Guest additions 4.3.18_96516

vbodadd-install.log /tmp/vbox.0/Makefile.include.header:97 *** Error unable to find the sources of your current...
Creating user for the guest...
Creating udev rule for the guest additions kernel module
/tmp/vbox.0/Makefile.include.header:97 *** Error unable to find the sources of your current..
etc. etc.

And when you restart offcourse it gives the error. Also i can't choose any other resolution format than 4:3

What i have tried(apologize for being noob):
update rc.d rpc bind defaults / enable
apt-get install (the normal virtual box and i tried x11)
sudo apt-get update/upgrade
sudo apt-get instal dkms (couldnt be found)
i put the official links in the sources.list, also had no effect.
i updated in the settings.
i updated in the terminal
aptitude install linux-headers etc etc.
i have reinstalled Kali

I tired to find people with similar problems but they were outdated.

I hope someone can help me out here, ive been at it for HOURS.

Best regards.