Results 1 to 9 of 9

Thread: OpenVas 7 - Solution

  1. #1
    Join Date
    2013-Mar
    Location
    Brazil
    Posts
    52

    OpenVas 7 - Solution

    I've been experiencing a lot of problems with openvas.
    My original Kali installation is 1.0.5. I was doing all upgrades.
    But this last month Openvas stop working properly. A ERROR message always appeared, no matter what tutorial I followed.
    Hope comes when I got to this solution. It is not good, is bad, I know. But now the openvas is working perfectly.

    Ugly solution:
    apt-get purge openvas openvas-* ;
    rm -fr /var/cache/openvas;
    rm -fr /var/log/openvas;
    rm -fr /var/lib/openvas;
    apt-get autoremove;
    apt-get install alien nsis rpm;
    apt-get install openvas;
    From Menu: Applications > Kali Linux > System Services > Openvas > openvas Initial Setup;
    openvasmd --user=admin --new-password=<your password>.

    It has fixed the bug, but, remove all previous scans and configurations.

    Usage:
    Access https://127.0.0.1:9392/, enter login as 'admin' and password 'your password'.
    Eventually the page will stop working. If this happen, just execute "service greenbone-security-assistant restart".

  2. #2
    Join Date
    2013-Dec
    Posts
    1
    Thanks, it has fixed my openvas issue too !

  3. #3
    Join Date
    2014-Apr
    Posts
    1
    i just used the last command on the terminal of initial setup and it worked for me to change finally the admin password!

  4. #4
    Join Date
    2014-Feb
    Posts
    44
    this is for v7 install. much easier than 6 was.

    SCM Repository

    Documentation for Subversion (sometimes referred to as "SVN") is available here.
    Anonymous Subversion Access

    This project's SVN repository can be checked out through anonymous access with the following command(s).

    svn checkout https://scm.wald.intevation.org/svn/openvas/trunk
    svn checkout https://scm.wald.intevation.org/svn/openvas-nvts

    root@kali:~# ./openvas-check-setup and just do the fixes listed; which will be starting openvassd,openvasmd,gsad and then openvasmd--rebuild once openvassd is running.

  5. #5
    Join Date
    2015-Feb
    Posts
    5
    PePe....THANK YOU!!!!THANK YOU!!!!THANK YOU!!!!! Great help. Went step by step and it worked perfectly. Thank you.

  6. #6
    THANK YOU I've been like this before

  7. #7
    Join Date
    2015-Mar
    Posts
    1
    Quote Originally Posted by PePeLeGal View Post
    I've been experiencing a lot of problems with openvas.
    My original Kali installation is 1.0.5. I was doing all upgrades.
    But this last month Openvas stop working properly. A ERROR message always appeared, no matter what tutorial I followed.
    Hope comes when I got to this solution. It is not good, is bad, I know. But now the openvas is working perfectly.

    Ugly solution:
    apt-get purge openvas openvas-* ;
    rm -fr /var/cache/openvas;
    rm -fr /var/log/openvas;
    rm -fr /var/lib/openvas;
    apt-get autoremove;
    apt-get install alien nsis rpm;
    apt-get install openvas;
    From Menu: Applications > Kali Linux > System Services > Openvas > openvas Initial Setup;
    openvasmd --user=admin --new-password=<your password>.

    It has fixed the bug, but, remove all previous scans and configurations.

    Usage:
    Access https://127.0.0.1:9392/, enter login as 'admin' and password 'your password'.
    Eventually the page will stop working. If this happen, just execute "service greenbone-security-assistant restart".
    Hi PePeLeGal! I went step by step and it seems to work! But every time I reboot I face these three errors:

    OpenVas Scanner is not running
    OpenVas Manager is not running
    openVas Greenbone Security Assistant is not running

    Once I fix these three errors, Greenbone Security Assistant works pretty fine, but I can't launch OpenVas-gsd! any solution to this problem? thanks in advance for your help!

  8. THANK, I like this. Very good

  9. #9
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    805
    Thanks much, PePeLeGal...got me past an OpenVAS problem I was having!

Similar Threads

  1. solution for static dns
    By brazen in forum General Archive
    Replies: 5
    Last Post: 2015-03-02, 22:02
  2. OpenVas - Solution
    By PePeLeGal in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2014-11-13, 17:51
  3. fglrx solution?
    By Stainedhat in forum General Archive
    Replies: 0
    Last Post: 2014-01-31, 03:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •