Results 1 to 2 of 2

Thread: Sub-process /usr/bin/dpkg returned an error code (1)

  1. #1
    Join Date
    2013-Sep
    Posts
    1

    Sub-process /usr/bin/dpkg returned an error code (1)

    Fresh install 1.0.9a amd64 onto a 16GB Sandisk Cruzer using the how to USB Persistence. All went well, but when I go to update and upgrade it, I keep on getting this error. Is anyone esle running into this.

    apt-get update && apt-get upgrade
    Hit http://http.kali.org kali Release.gpg
    Hit http://security.kali.org kali/updates Release.gpg
    Hit http://http.kali.org kali Release
    Hit http://security.kali.org kali/updates Release
    Hit http://http.kali.org kali/main Sources
    Hit http://security.kali.org kali/updates/main Sources
    Hit http://http.kali.org kali/contrib Sources
    Hit http://security.kali.org kali/updates/contrib Sources
    Hit http://http.kali.org kali/non-free Sources
    Hit http://security.kali.org kali/updates/non-free Sources
    Hit http://http.kali.org kali/main amd64 Packages
    Hit http://security.kali.org kali/updates/main amd64 Packages
    Hit http://http.kali.org kali/contrib amd64 Packages
    Hit http://security.kali.org kali/updates/contrib amd64 Packages
    Hit http://http.kali.org kali/non-free amd64 Packages
    Hit http://security.kali.org kali/updates/non-free amd64 Packages
    Ign http://http.kali.org kali/contrib Translation-en_US
    Ign http://http.kali.org kali/contrib Translation-en
    Ign http://security.kali.org kali/updates/contrib Translation-en_US
    Ign http://http.kali.org kali/main Translation-en_US
    Ign http://security.kali.org kali/updates/contrib Translation-en
    Ign http://http.kali.org kali/main Translation-en
    Ign http://security.kali.org kali/updates/main Translation-en_US
    Ign http://http.kali.org kali/non-free Translation-en_US
    Ign http://security.kali.org kali/updates/main Translation-en
    Ign http://http.kali.org kali/non-free Translation-en
    Ign http://security.kali.org kali/updates/non-free Translation-en_US
    Ign http://security.kali.org kali/updates/non-free Translation-en
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages have been kept back:
    sleuthkit volatility
    The following packages will be upgraded:
    aircrack-ng apt apt-utils at ca-certificates curl debian-archive-keyring dhcpig dnschef exim4 exim4-base exim4-config exim4-daemon-light hashcat-utils
    iceweasel kali-linux kali-linux-full lbd libapache2-mod-php5 libapt-inst1.5 libapt-pkg4.12 libc-bin libc-dev-bin libc6 libc6-dev libc6-i386 libcurl3
    libcurl3-gnutls libkeyutils1 libmozjs24d libmysqlclient18 libperl5.14 libpq5 libpurple-bin libpurple0 libsnmp-base libsnmp-perl libsnmp15 libssl1.0.0
    libtasn1-3 libxml2 libxml2-dev libxml2-utils live-config live-config-doc live-config-sysvinit locales locales-all maskprocessor metasploit
    metasploit-framework multiarch-support mysql-client-5.5 mysql-common mysql-server mysql-server-5.5 mysql-server-core-5.5 openssl openvas perl perl-base
    perl-modules php5 php5-cli php5-common php5-mysql pidgin-data postgresql-9.1 postgresql-client-9.1 python-libxml2 recon-ng responder rsyslog ruby-ansi set
    snmp snmpd statsprocessor tzdata tzdata-java wget wireless-regdb xdg-utils xulrunner-24.0
    84 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
    Need to get 0 B/422 MB of archives.
    After this operation, 607 MB disk space will be freed.
    Do you want to continue [Y/n]? Y
    dpkg-deb: error: subprocess tar was killed by signal (Bus error)
    dpkg-deb (subprocess): decompressing archive member: internal gzip write error: Broken pipe
    Traceback (most recent call last):
    File "/usr/bin/apt-listchanges", line 238, in <module>
    main()
    File "/usr/bin/apt-listchanges", line 102, in main
    pkg = DebianFiles.Package(deb)
    File "/usr/share/apt-listchanges/DebianFiles.py", line 133, in __init__
    self.binary = pkgdata.Package
    AttributeError: ControlStanza instance has no attribute 'Package'
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    dpkg-deb: error: subprocess tar was killed by signal (Bus error)
    dpkg: error processing /var/cache/apt/archives/perl_5.14.2-21+deb7u2_amd64.deb (--unpack):
    subprocess dpkg-deb --control returned error exit status 2
    dpkg-deb: error: subprocess tar was killed by signal (Bus error)
    dpkg: error processing /var/cache/apt/archives/libperl5.14_5.14.2-21+deb7u2_amd64.deb (--unpack):
    subprocess dpkg-deb --control returned error exit status 2
    dpkg-deb: error: subprocess tar was killed by signal (Bus error)
    dpkg: error processing /var/cache/apt/archives/perl-base_5.14.2-21+deb7u2_amd64.deb (--unpack):
    subprocess dpkg-deb --control returned error exit status 2
    Errors were encountered while processing:
    /var/cache/apt/archives/perl_5.14.2-21+deb7u2_amd64.deb
    /var/cache/apt/archives/libperl5.14_5.14.2-21+deb7u2_amd64.deb
    /var/cache/apt/archives/perl-base_5.14.2-21+deb7u2_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  2. #2
    Join Date
    2015-Feb
    Posts
    2
    has this error been solved ? i'm having the same issu with "dpkg : error processing archive /var/cache/apt/archives/ruby-zip_1.1.6-1_amd64.deb (--unpack):
    says to run " apt-get autoremove or apt-get -f install " but when both run i'm still givin the error above.

Similar Threads

  1. Sub-process /usr/bin/dpkg returned an error code (1)
    By gio__gio in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2014-07-21, 08:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •