Results 1 to 3 of 3

Thread: Live USB not booting on MacBookPro

  1. #1
    Join Date

    Live USB not booting on MacBookPro

    I will try to be very descriptive, to the fullness!

    I have an early 2011 MacBookPro (MBP), i5 cpu, 320GB HDD 4GB RAM OSX 10.9.5

    I Downloaded kali-linux-1.0.9-amd64.iso

    Using a USB Flash drive , I did the diskutil thing and the dd command to image the flash drive.
    After it was done, I restarted the MBP, held down the alt button after the boot-sound, and I was the boot menu, I selected the usb flash drive, pressed enter, and Kali started booting.
    I checked out a couple things, everything was working, cool, so I ended the session and shut the MBP down (properly).

    I booted it back up into OSX later on that day and did my thing, shut it down, things were ok.

    Next day, I wanted to boot into Kali again, I plugged in the USB flash drive and turned on the MBP, pressed the alt button after the boot up-sound, and I selected the flash drive, pressed enter, and........... it just stayed there! frozen, the mouse want moving, buttons, nothing, so I pressed the power button for 5 seconds till it turned off.

    ever since then, I cannot boot back into Kali off the usb drive

    I tried multiple Flash drives, re-dowloaded the image, I tried both usb ports on this computer, nothing!

    OSX boots fine,

    so, I followed the instructions for installing refined in an attempted to install Kali on a small partition on the hard drive, refined installed, I attempted to boot off a fresh USB flash drive using the refined boot menu, it calls it Windows, but thats normal, I selected it, pressed enter, and it took me to a MS-DOS like screen and in white text it displayed one line at the top of a black screen "No bootable device -- insert boot disk and press any key"

    what is going on !

    OSX still boots fine with refined installed,

    Keep in mind, I was only able to boot Kali the first time I ever attempted to boot it, which was successful.

    any input helps!



  2. #2
    Join Date
    I want to add and update:

    I downloaded 1.0.9a 32 bit and 64 bit, and i used 2 different usb flash drives, I did one at a time

    I unmounted the usb flash drive using : diskutil unmountDisk /dev/disk1

    Then I used the dd command as follows : dd if=kali-1.0.9a.iso of=/dev/disk1

    I tested them on my MBP, and the same error was happening and described above ^^^

    I decided to test them on a HP laptop, and they boot up right away!,


  3. #3
    Join Date
    I have the exact same Issue as G186. I have also a 2011 MacBook Pro with 16 GB RAM, Core i7 and an 256 GB SSD. I tried with OS X 10.10.
    I will try right now if it works with an older kali version.

    Kind Regards,


Similar Threads

  1. OCLHashcat on MacbookPro through vmware
    By mandrew98 in forum General Archive
    Replies: 2
    Last Post: 2015-01-02, 23:15
  2. Kali Linux Live on MacBookPro
    By invinicolaveritas in forum Installing Archive
    Replies: 3
    Last Post: 2014-06-12, 17:52
  3. Macbookpro Wifi
    By Hadi1992 in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-11-25, 11:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts