Results 1 to 6 of 6

Thread: Kali UEFI Installation on ASUS T100T

  1. #1
    Join Date

    Kali UEFI Installation on ASUS T100T

    I have ASUS T100T, on which I am trying to install Kali, using a USB flash drive (32Gb). I have downloaded the latest .iso image of kali today, and followed about 10 different forums/blogs/instructions, but cannot for the life of mine get the UEFI to "see" the files in EFI/BOOT section of the flash drive. I know it does look there, because when I put there some of the .efi files from windows partition, it comes up with errors telling me that there are missing dependencies and so forth, which makes sense since I did not copy those there and have no need to.
    But with Kali image, it does not want to initiate the installation of the operating system. This is a bit sad since the reason I got this device is to use with Kali more than anything else.
    I am not a kali professional, but learning for a while now and was able to help people with it, like recovering hard drives and inspecting their computers systems, correcting them, and I know that there is a lot more to learn - but that is running Kali on an old MSI netbook.

    Please assist me with an advice on what configuration or what files I should use in order for this UEFI to load operating system from my flash drive.

    Here is specific details of my device and properties:

    2gb of RAM
    25GB of free space on SSD for Kali (unformatted)
    Intel Atom CPU Z3740 @ 1.33 GHz 1.33 GHz
    Windows 8.1 (which I do intend to keep and run Kali alongside it)
    BIOS Information
    Vendor: American Megatrends, Version: 214, GOP Version: 7.0.1028, EC Version: t2bt0600
    Secure boot is not active

    Honestly I am not sure why this device says: "BIOS", because by all means and intentions it behaves like UEFI, and from close inspection of every menu and submenu of the UEFI, there is no legacy mode at all to support BIOS based operating systems. At the same time Kali does support the EFI now, but unfortunately I must be doing something incorrectly to manage not to boot it for two days now.


  2. #2
    Join Date
    Do you have a bootia32.efi file in your EFI/boot folder on your flash drive?

  3. #3
    Join Date
    I just looked inside of the EFI/BOOT folder (unaltered from Kali downloads), and it has BOOTX64.efi, syslinux.efi, and syslinux.cfg along with many other files in the same directory.

    I flashed a USB drive with rEFInd, and computer loads it without any problems - I has choice of booting into Windows that is installed, and also several rEFInd optoins. Can I use that in any way to install Kali?
    Last edited by KSYSK; 2015-01-05 at 23:01.

  4. #4
    Join Date
    i have a similar Atom Bay Trail device and i can boot if i use refind to load bootia32.efi and then manually configure grub to launch the kali kernel and initrd.

    however, i run into other issues with kali not seeing my gpt partitions within it's installer.

  5. #5
    Join Date
    I am way less advanced then you are! With bootia32.efi I do end up at GRUB 2.02 CLI, but from there I do not know how to configure it to launch Kali kernel. What commands do you use to accomplish that?

    Edit: after looking online on how to load kernel from grub, I did this:
    grub> set root=(hd0,gpt1)
    grub> linux /install/vmlinuz
    error: invalid magic number.

    So I looked at what that means, and found out that grub does not recognize this Kali kernel as a valid file, despite me trying to load 64 bit version or 32 bit version of the iso from official Kali Linux downloads page.
    Last edited by KSYSK; 2015-01-07 at 17:39.

  6. #6
    Join Date
    had this same issue worked out a fix know im a bit late but maybe can help others

    install Kali 2.0 to ASUS t100t with efi bios

    1. Rufus or choice usb iso tool the standard 64bit amd iso

    2. open the usb /boot/efi.img on if doing from windows 7-zip can open as acrchive. inside will see a efi folder copy that to the USB /root

    3. add bootia32.efi to USB /EFI/BOOT/

    4. USB /boot/grub/ create a grub.cfg

    add this:
    # Config file for GRUB2 - The GNU GRand Unified Bootloader
    # /boot/grub/grub.cfg
    # Linux Grub
    # -------------------------
    # /dev/fd0 (fd0)
    # /dev/sda (hd0)
    # /dev/sdb2 (hd1,2)
    # /dev/sda3 (hd0,3)
    # root=UUID=dc08e5b0-e704-4573-b3f2-cfe41b73e62b persistent
    set menu_color_normal=yellow/blue
    set menu_color_highlight=blue/yellow
    function load_video {
    insmod efi_gop
    insmod efi_uga
    insmod video_bochs
    insmod video_cirrus
    insmod all_video
    set gfxpayload=keep
    # Timeout for menu
    set timeout=15
    # Set default boot entry as Entry 0
    set default=0
    set color_normal=yellow/blue
    menuentry "Kali - Boot Non Persistent Mode" {
    set root=(hd0,1)
    linux /live/vmlinuz boot=live noconfig=sudo username=root hostname=kali
    initrd /live/initrd.img
    menuentry "Kali - Boot Persistent" {
    set root=(hd0,1)
    linux /live/vmlinuz boot=live noconfig=sudo username=root hostname=kali persistence
    initrd /live/initrd.img
    menuentry "Kali Failsafe" {
    set root=(hd0,1)
    linuxefi /live/vmlinuz boot=live config memtest noapic noapm nodma nomce nolapic nomodeset nosmp nosplash vga=normal
    initrdefi /live/initrd.img
    menuentry "Kali Forensics - No Drive or Swap Mount" {
    set root=(hd0,1)
    linuxefi /live/vmlinuz boot=live noconfig=sudo username=root hostname=kali noswap noautomount
    initrdefi /live/initrd.img
    menuentry "Kali Graphical Install" {
    set root=(hd0,1)
    linux /install/gtk/vmlinuz video=vesa:ywrap,mtrr vga=788
    initrd /install/gtk/initrd.gz
    menuentry "Kali Text Install" {
    set root=(hd0,1)
    linux /install/vmlinuz video=vesa:ywrap,mtrr vga=788
    initrd /install/initrd.gz
    5. make sure secure boot is disabled unfortunately the wifi isn't being recognized so will need a USB-RJ45 Ethernet adapter to be able to install grub in the final step of install

    install update ( forgot to include could have been a issue with my location or even a isp hickup but grub install failed first attempt so i whent back one stage and picked use Mirror and then installed and is booting and working fine finally )

    on a side note just after all this i had to disassemble and pull battery reset seams that the 3-4 month break i took from attempting to make this work the battery discharged and is defective unable to hold charge so now i have to order and wait for a new battery ... -_- so i found out that the keyboard dock for some reason slowly drains the battery even shut down. So if you let your sit for any time separate dock and tablet.
    Last edited by thunderman; 2016-03-26 at 14:01. Reason: info update

Similar Threads

  1. Replies: 1
    Last Post: 2015-12-17, 19:54
  2. Kali 64 UEFI Installation problem
    By Overload in forum Installing Archive
    Replies: 1
    Last Post: 2014-01-30, 12:24

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts