I want to change the Document Root of apache2 from the default /var/www to my custom directory (in mounted NTFS drive) /media/home/localhost.

I tried modifying etc/apache2/sites-enabled/000-default file to the follwoing

<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /media/home/localhost
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        <Directory /media/home/localhost/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
I restarted apache2 after making this changes but when I navigate to localhost, I get a 403 Forbidden error.

So, where am I doing wrong?