Results 1 to 3 of 3

Thread: Update Kali Chroot

  1. #1
    Join Date

    Update Kali Chroot

    Hello Everyone

    I have just installed NetHunter on the Nexus 7 (2013) and I am having some issues on the update of the chroot.
    All the rest seems to work ok.
    Specifically, inside Kali Launcher app when I first hit the "update kali chroot" it started to download some pakages updates but eventually stopped producing an error with reference to tzdata.
    Eventually I tryed to repeat the operation several time but with the same error message as a result.
    This is what I am getting back (I have highlighted the part in relation with the error message):
    The following NEW packages will be installed:
    binfmt-support fastjar jarwrapper
    The following packages will be upgraded:
    apache2 apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common apt-utils binutils
    burpsuite cpio libapache2-mod-php5 locales locales-all metasploit metasploit-framework
    multiarch-support openssl php5 php5-cli php5-common set wget wireless-regdb xdg-utils
    23 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
    22 not fully installed or removed.
    Need to get 0 B/292 MB of archives.
    After this operation, 2696 kB of additional disk space will be used.
    Preconfiguring packages ...
    Setting up tzdata (2014j-0wheezy1) ...
    file_context_open: Error getting file context handle (No such file or directory)
    Could not load file_contexts: No such file or directory
    dpkg: error processing tzdata (--configure):
    subprocess installed post-installation script returned error exit status 255
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    u0_a82@flo:/ $

    I hope someone can help and explain what this is and how to fix it.



  2. #2
    Join Date
    I get the same error. Nexus 7 2012 version.


  3. #3
    Join Date
    You need to edit /var/lib/dpkg/info/tzdata.postinst and substitute set -e with set -x
    After that change it did worke


Similar Threads

  1. Chroot update failing
    By AWV in forum NetHunter General Questions
    Replies: 5
    Last Post: 2015-12-09, 01:26
  2. postgresql update failing in chroot update
    By AWV in forum NetHunter General Questions
    Replies: 4
    Last Post: 2015-05-31, 14:18
  3. chroot update breaks wifite on Nexus 6
    By megaflop666 in forum NetHunter General Questions
    Replies: 2
    Last Post: 2015-05-26, 15:45
  4. update kali chroot error: postgresql service start fail!
    By dacurakali in forum NetHunter General Questions
    Replies: 3
    Last Post: 2015-04-16, 20:44

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts