Results 1 to 5 of 5

Thread: MITMf Error

  1. #1
    Join Date

    MITMf Error

    This is what I get when I try to start MITMf from the Kali NetHunter Menu in Terminal....

    Enter Interface: wlan0
    Enter Gateway IP:
    Enter Target IP:
    Beef-xss is running. Will load autobeef...
    /usr/bin/kalimenu: line 469: cd: /opt/MITMf: No such file or directory
    Logs saved to /captures/sslstrip/mitmf.log
    [*] ------------------------------------------------------
    python: can't open file '': [Errno 2] No such file or directory
    2|u0_a155@flo:/ $

    If anyone knows how to fix this than please post a response. I checked the directory and there is most definitely not a directory named MITMf in /opt. I went as far to edit the kalimenu file and switch it to use MITMf in /usr/bin or /sbin and changed the command line to just MITMf and not Also had to change some of the switches because it did not recognize some of them, such as --iface and -w I think it was, but in the end it failed (not at my nexus at the moment, sorry for some of the guessing).
    Last edited by shad0vvfax; 2015-02-04 at 04:05. Reason: attempted a fix

  2. #2
    Join Date
    I get the same error, you solved? Someone?

  3. #3
    Join Date
    I am also having problems getting mitm going. Can anyone clue me in?

  4. #4
    Join Date
    Says something about magic domain. And install cert on client machine???

  5. #5
    Join Date
    create folder "logs" in the mitmf folder.

Similar Threads

  1. Need to fix MITMf. Help me!
    By tung29794 in forum General Archive
    Replies: 2
    Last Post: 2016-05-26, 22:33
  2. Install MITMf
    By karencho in forum How-To Archive
    Replies: 3
    Last Post: 2016-02-06, 01:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts