Results 1 to 4 of 4

Thread: update kali chroot error: postgresql service start fail!

  1. #1
    Join Date

    Question update kali chroot error: postgresql service start fail!

    in Kali Launcher --> Update Kali chroot, everything is OK, except postgresql and metasploit
    At first, it says directory "/var/lib/postgresql/9.1/main" has group or world access, permissions should be u=rwx.

    Then I change the permission to 700: chmod -R 700 main, still fail. It says: /usr/lib/postgresql/9.1/bin/pg_ctl start ... FAIL!!

    What's the problem? Anyone knows?

  2. #2
    Join Date
    Idk what causes the issue but I run into it every time there's a metasploit update. If it happens in the future, after you get the error run "service postgresql start" then "apt-get upgrade -y" and it should work fine. Like I said it happens to me every time msf updates but this works for me every time. Good luck.

  3. #3
    Join Date
    I literally had to flash Nethunter 3-4 times before postgresql started to work.

  4. #4
    Just do a:

    service postgresql start

    Then run chroot update again.

    That should fix it. It did mine

Similar Threads

  1. Postgresql service wont start after reboot.
    By kalipi2 in forum ARM Archive
    Replies: 0
    Last Post: 2015-05-24, 09:28
  2. Kali on AWS - service postgresql start issue
    By 2bitwannabe in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2014-03-05, 01:52
  3. Failed #service postgresql start
    By Castor_Troy in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-06-25, 00:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts