Results 1 to 6 of 6

Thread: Fix Kernel Headers Problem

  1. #1
    Join Date
    2013-Aug
    Posts
    7

    Unhappy Fix Kernel Headers Problem

    The command is not working. I don't know why. So that i cant use VMware Workstation. Plz help

    root@kali:~# sudo apt-get install linux-headers-`uname -r`
    sudo: unable to resolve host Gh0sT
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package linux-headers-3.14-kali1-amd64
    E: Couldn't find any package by regex 'linux-headers-3.14-kali1-amd64'
    root@kali:~#

  2. #2
    Join Date
    2013-Aug
    Posts
    7
    any body plz help me

  3. #3
    Join Date
    2013-Mar
    Location
    Somewhere in the hell
    Posts
    15
    Quote Originally Posted by Alton Jhon View Post
    The command is not working. I don't know why. So that i cant use VMware Workstation. Plz help

    root@kali:~# sudo apt-get install linux-headers-`uname -r`
    sudo: unable to resolve host Gh0sT
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package linux-headers-3.14-kali1-amd64
    E: Couldn't find any package by regex 'linux-headers-3.14-kali1-amd64'
    root@kali:~#

    @Alton Jhon,

    The correct command is :

    Code:
    apt-get install linux-headers-$(uname -r)
    By the way, you need to upgrade your Kali by :

    Code:
    apt-get update 
    apt-get dist-upgrade
    Samiux
    Last edited by samiux; 2015-02-15 at 17:44. Reason: add upgrade command
    While you do not know attack, how can you know about defense? (未知攻,焉知防?)
    Think like a criminal and act as a professional.
    Not only Try Harder but also Try Smarter!

  4. #4
    Join Date
    2014-Nov
    Posts
    39
    samiux has it right but do it in this order:

    Code:
    apt-get update
    apt-get upgrade -y
    apt-get dist-upgrade -y
    reboot
    #Boot into 3.18 kernel from grub instead of 3.14
    apt-get install linux-headers-$(uname -r)
    If you absolutely need the linux-headers-3.14-kali1-amd64 the removed it from the repo as they upgraded the kernel to 3.18 I have submitted a bug request to have this package added back along side keeping the one for the new kernel for backwards compatability as 3.18 still has it's quirks but this hasn't been adressed yet. Let me also tell you not to waste your time looking for a snapshot for kali 1.0.9a as you won't find one that has this package for you as I've been down this road. Bug ID number is 0002121. I requested it for being able to be backwards compatiable with the Nvidia drivers with the old kernel 3.14. Hope this helps you please reply.

    To add to this they did decline the request for backwards compatability with the headers found here https://bugs.kali.org/view.php?id=2121

    So you will have to use the new kernel to use nvidia drivers no choice in the matter
    Last edited by lillypad; 2015-02-20 at 13:57.

  5. #5
    Join Date
    2013-Aug
    Posts
    7
    thanks for your help @lillypad

  6. #6
    Join Date
    2015-Feb
    Posts
    1
    can helpme please i try all and dont work i cant install vmware or virtual box for this problem please helpme...

    root@Parvati:~# #Boot into 3.18 kernel from grub instead of 3.14
    root@Parvati:~# apt-get install linux-headers-$(uname -r)
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package linux-headers-3.14-kali1-amd64
    E: Couldn't find any package by regex 'linux-headers-3.14-kali1-amd64'

Similar Threads

  1. Kernel headers problem
    By Philly in forum TroubleShooting Archive
    Replies: 59
    Last Post: 2016-09-12, 13:58
  2. kernel headers arm rootfs
    By johnjohnsp1 in forum ARM Archive
    Replies: 0
    Last Post: 2014-07-12, 11:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •