Bought a bluetooth dongle and am trying to get it working w/ Nethunter on my Nexus 5. I tried to do a bit of troubleshooting but got stuck when the bt service gave an interesting error (that looks like it is coming from bluez): "Too small read version complete event (probably an old kernel)".

Here are the commands I ran leading up to the error:

service dbus start
rfkill unblock bluetooth
bluetoothd -n
> bluetoothd[32119]: Too small read version complete event (probably an old kernel)
> Aborted

I have no idea what to do to resolve this error. If anyone has any ideas on how to get it working, I'd appreciate your input. Below is some information that may help:

  • The nethunter kernel: 3.4.95-furnace-1.3.6
  • The bluez version: 4.99
  • The device seen from "lsusb": Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
  • I see no results from "hciconfig -a".
  • I get no devices found from "hcitool dev".

According to the bluez documentation, v4.99 should work with this kernel. So I'm not sure why that error is being thrown...