Results 1 to 4 of 4

Thread: Encrypted Kali install, only 255mb avail. Trash filed and won't empty-now not booting

  1. #1
    Join Date
    2015-Mar
    Location
    California, the poor area of Sacramento
    Posts
    3

    Encrypted Kali install, only 255mb avail. Trash filed and won't empty-now not booting

    I hope my title is descriptive.

    **Updated March 6th 2015 at 5:20pm***
    My system:
    Acer 4*** AMD64 dual-core
    320gb HD
    Kali 1.1.0 AMD 64 Encrypted Install using entire computer


    -Everything worked correctly until I got the Mirrors and package manager, which did not work -I couldn't connect to the net through DHCP and use the mirros. The proxies available did not work.
    I've used the system many times with airmon, airodump, and aircrack, but I was always limited by the 255mb hard drive size [which obviously is misleading]
    I had tried to install VMware Player on it, but it did not complete due to HD space issues.

    There are currently 2.5 problems:

    1) Did it install correctly? It booted up into the desktop and the vast majority of the 320gb hard disk was unavailable. I knew this was going to be a problem, with my intended usage of the computer. -- It took a LONG TIME to install, to reformat the system and make an encrpyted volume. I'm not doing that again.

    2) How to I open up the hard disk to the full 320gb size? Look at the picture below -- it looks as if the filesystem is correct, but I can't make it function. What is the step, the guide, or the command to make it functional?

    3) Is there a guide or list of commands to run on Kali-recovery? So that I can fully repair my system -- perhaps even automatically?--

    Fdisk -l
    Code:
    Device     Boot       Start     End       Blocks      ID       System
    /dev/sda1  *          2048      499711    248832      83       Linux
    /dev/sda2           501758    625141759 312330001     5        Extended
    /dev/sda5           501760    625141759 312320000     83       Linux
    So what I need:
    -Learn how Kali 2nd boot [maintenance] works, so I can boot correctly and overcome the 2 failures I've had. A guide, or a list of commands, or a video on youtube.
    -Fix the partition issue so that I can install things and the filesystem is setup correctly. Perhaps the encrypted install didn't complete? Or my Linux skills are low?
    I'm going to assume that encrypted linux, the 255mb partition is correct, and there's something tricky about how much space is actually available, and how to access it, and how to install applications. I'll learn how to make it function.

    Img link: http://i.imgur.com/2AgnERq.png


    Please help! I'd like to get this laptop running and working again, for many uses.
    Love, Sinelanguage
    Last edited by Sinelanguagesin; 2015-03-07 at 01:18. Reason: Fixed a problem, computer sit. was updated

  2. #2
    Join Date
    2015-Mar
    Location
    California, the poor area of Sacramento
    Posts
    3
    I was asking on the IRC channel -- and they asked me if I accidentally installed only a 255mb partition.
    But I believe that the automated Kali encrypted install worked right -- and I just don't know how to make the system partitions function.
    To the right of the image [it's been cut off], there's a "lock" [unlocked] on the center 320gb partition: it says "Encrypted / 320 GB" but it doesn't do anything when I click on it.

    Of interest and note: in Computer, under Deives: there are 2 drives:
    -255 MB
    -320 GB Unrecognized
    When I click on the 320 GB unrecognized, it says: "Unabled to mount 320 GB unrecognized \ One or more block devices are holding /dev/dm-0"

    So I believe it has to be the configuration of the Encrypted Kali install.
    What's most important is that the filesystem says it has "Free Space: 485.2 MB" and that's higher than 255 MB.

    So somebody who knows the Kali Encrypted Install -- please help!

  3. #3
    Join Date
    2014-Apr
    Location
    Down Under
    Posts
    315
    I wrote a guide on an encrypted LVM install for Kali. Take a look at the post linked below or read the thread from the start.

    You should be able to make it work without the dual boot (as the guide just uses free space, so treat the drive as free space)

    https://forums.kali.org/showthread.p...ll=1#post37598

    If you look at the image in the post I linked, just ignore sda1 and sda2 as you wont see them if you are not EFI dual booting.
    chown -R us ./base

  4. #4
    Join Date
    2015-Mar
    Location
    California, the poor area of Sacramento
    Posts
    3
    I fixed it--
    The system is installed right, and the encrypted install was successful.
    The vast majority of my free space is hidden away in the file system, somewhere else. and I found it today.
    I still only have minimal space for my FS and the apps, but it will work.
    -The free space was located in /home [not /Home] and it is running well.
    Close this thread!

Similar Threads

  1. Problem booting from USB with encrypted persistence
    By husmari in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-06-01, 01:42
  2. Filed to load libmenu.c32
    By keithchristian in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2015-05-05, 17:18
  3. Problem while booting from encrypted bootstick
    By M3m0r3X in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-03-16, 15:27

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •